[REL] Latest Build Update rFactor 2 - 1.1119 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, Jun 4, 2020.

  1. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    78
    Likes Received:
    51
    need to create yourself
     
  2. RaceTobi

    RaceTobi Registered

    Joined:
    Apr 21, 2019
    Messages:
    2
    Likes Received:
    0
    Well the Broadcast overlay doesnt work now just get an error it cant load the config.json :(
     
  3. Javibeza

    Javibeza Registered

    Joined:
    Oct 5, 2010
    Messages:
    22
    Likes Received:
    25
    Hi Alex! First of all, I'm very amateur in tweaking graphics so I want to apologize for any mistake on my questions.
    Our mod has DashboardElementShader on leds and after last week update we noticed brightness on leds were very low. We tweaked ambient and emmisive values to match brightness we want, but we felt this was increased again slightly so this afternoon we had to lower them to fix it again. I dont know why this was caused, but anyway we have adjusted it.

    Other thing has changed and we cant re-adjust is a chrome effect on a json modified texture of car paint material. We had these textures with cubeMapFresnel modified to make a chrome effect but has been vanished in this update.

    I tried to play again with cubeMapFresnel values on material editor but it does not seem to do any change now with any value I put. Is this intented?

    Thank you.
     
  4. Filip

    Filip Registered

    Joined:
    Feb 9, 2017
    Messages:
    1,006
    Likes Received:
    774
    Real men use vi exclusively
     
  5. Jkarlo

    Jkarlo Registered

    Joined:
    Nov 3, 2014
    Messages:
    24
    Likes Received:
    3
    As far as i know, the overlays folder its inside rfactor2/Bin/Bundles/ folder a file call net.rfactor2.app.overlays.jar, you can open it with winrar, and inside you have the default folder and costumize folder to edit, but i cant find images and videos folder
     
    Last edited: Jun 5, 2020
  6. Alex Sawczuk

    Alex Sawczuk Member Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    263
    Likes Received:
    236
    Hi, a lot of our content uses the Dashboard Element, so there may have been some slight adjustment to overall exposure, I don't think anything was done huge in this area to cause a terrible change at least.

    With regards to cubeMapFresnel, many many cars were using really bad values which meant they looked literally terrible. So I set them to decent fail safe defaults. I have a plan to make them editable via a new check box in the Material Editor. I'll see when we can do that. There's likely to be another update next week.

    I am sorry that some stuff is getting messed around here and it is obviously inconvenient, but we need to do it so we can give you better tools and options as modders going forward - as well to allow us to author content to a higher standard and keep the old content compatible. Obviously that has meant a few short term bumps, but please keep giving feedback so we can iron them out.
     
    Redpxl, GeraArg, McKiernan and 4 others like this.
  7. nipzon

    nipzon Registered

    Joined:
    Dec 23, 2011
    Messages:
    244
    Likes Received:
    34
    Why is it that the steering wheel and pedals move in increments from 0%-100% whereas is other games it is a smooth transgression?
     
  8. Javibeza

    Javibeza Registered

    Joined:
    Oct 5, 2010
    Messages:
    22
    Likes Received:
    25
    Thanks Alex, change to leds was only disturbing on some darker o rainy light conditions, so maybe we didn't adjust it very well to v1118 and little change made them too bright. Anyway it's now OK and adjusted to perfection in v1119.

    Awaiting for cubeMapFresnel tweak avaiability so we can make this car chrome effect again:

    GRAB_005.jpg

    As I understand, we should wait and not waste time on changing textures or trying to replicate old chrome behaviour if we are getting this tweak avaiable again on future update, am I right?

    I wish we on our community had enought knowledge to upgrade our car to L2IBLCARBODY shader, but for now its too much for us, unfortunately.

    As always, thanks for all that hard work!
     
  9. Alex Sawczuk

    Alex Sawczuk Member Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    263
    Likes Received:
    236
    Using iblcarbody is indeed the best way to get chrome I think. But yes I think at present just wait on the chrome with the old shader
     
  10. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,238
    Likes Received:
    1,365
    What makes you think it does? Surely the game uses the raw signal from the wheel drivers. If it used 1% increments for steering any car would be undrivable.
     
  11. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    774
    Likes Received:
    385
    I get the error too but I click ok and it works for me.
     
  12. nipzon

    nipzon Registered

    Joined:
    Dec 23, 2011
    Messages:
    244
    Likes Received:
    34
    When I look at the calibration section of the steering and I turn the left, it is not a smooth increase. it might just be what it looks like and not what the game sees, I don't know.
     
  13. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,205
    Likes Received:
    3,591
    The new UI has a low update speed, so it'll look stepped. Move it very slowly and you should see it's progressive.
     
    nipzon likes this.
  14. Diego Barjollo

    Diego Barjollo Registered

    Joined:
    Feb 4, 2020
    Messages:
    24
    Likes Received:
    19
    I find an issue using the new IU after 1119 update. The setups doesn't load. Just in the new IU.
     
  15. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,466
    Likes Received:
    1,970
    I think if you look in the settings folder, you will see the setups are still there, but I'm betting a slight format change may have made the old setups unrecognizable. Try these steps. Make a new setup and save it. Give it a name that stands out from your normal setups so you can recognize it easily. Then use a text editor and load up both an old and the new setup. Look for changes in the opening lines, or even the the file title. I'm betting you will find a small change between old and new. If so, make the same change to all the old setups and they should re-appear next time you load rF2.
     
    McKiernan and Diego Barjollo like this.
  16. Diego Barjollo

    Diego Barjollo Registered

    Joined:
    Feb 4, 2020
    Messages:
    24
    Likes Received:
    19
    It was exactIy that! I solved it following the steps you told me. Only one of the first lines had different numbers.

    Thank you very much @davehenrie!
     
    McKiernan and davehenrie like this.
  17. mixer61

    mixer61 Registered

    Joined:
    Dec 26, 2011
    Messages:
    395
    Likes Received:
    113
    How to access "all tracks and cars" with the new interface (UI)?
    Thank you.
     
  18. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,466
    Likes Received:
    1,970
    ON THE single player screen, just below SINGLE PLAYER and just above the track & car info is an > It may be just to the right of any special rfmod you may have loaded. click on that arrow.
     
  19. mixer61

    mixer61 Registered

    Joined:
    Dec 26, 2011
    Messages:
    395
    Likes Received:
    113
    Okay, I'll try today.
    Thx
    Edit :
    Okay, it works, but it's not really intuitive.
    Thank you very much!
     
    Last edited: Jun 5, 2020
  20. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    78
    Likes Received:
    51
    upload_2020-6-5_9-56-15.png
    In this .zip you can find the images and videos folder, and everthing.
     
    buzz hornet likes this.

Share This Page