[REL] Easy Icon Creator Showroom

Discussion in 'Other' started by redapg, Sep 16, 2020.

  1. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    233
    Likes Received:
    96
    @redapg cant we have a visual confirmation / indicator that the screenshot has been taken? I mean apart from the sound (that doesn t work for me)

    eg screenshot_[name_of_screenshot] successfully captured! Or smth similar..(imagine that you want to capture 50 shots and afterwards to find out you have taken only 45..)
     
    Last edited: Jan 12, 2021
  2. Vanisch

    Vanisch Registered

    Joined:
    Oct 21, 2018
    Messages:
    97
    Likes Received:
    67
    Thanks, Yes..the Carnival- Sound is ok...
    the screenshot sound is ok now ... very strange, but everything is ok now. Thank you
     
  3. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    233
    Likes Received:
    96
    Game crashes (at the end of loading screen) for each track

    Edit:

    I used an other car and the track loads (Joesville). And yes i can hear the carnival sound too
     
    Last edited: Jan 12, 2021
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Sorry, i can not help with that. Maybe someone who can program Plugins can do it.

    OK, at least 1 for that it works now. :)

    I currently don't have more Ideas, how to solve the missing Screenshot Sound.
    As you can see, for @Vanisch it works now.
    Such Things can be caused by so many Reasons, that it is hard to find the one Reason that causes the Problem, without to have the PC in front of me.
    And if the DevMode totally crashes while loading, it is always helpful to take a look into the Trace File.
    In most of the Cases, you can find the Reason for a Crash inside of it.
     
  5. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,702
    Likes Received:
    628
    No, in DevMode the screenshots still doesn't work - for me. No idea why.
     
  6. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    What exactly doesn't work?
     
  7. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,702
    Likes Received:
    628
    My userdata/screenshots-folder is empty

    But I reverted to the old UI, then it works.
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Just to clarify it.
    With the new UI you can not make Screenshots in the DevMode?
    I also use the new UI now permanently and in the Single Player Mode, Screenshots don't work in the Menu or Showroom, that's right.
    But in DevMode, they work as they always did here.
     
    Mauro likes this.
  9. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,702
    Likes Received:
    628
    @redapg
    Old UI - native (rF2-created) screenshots work everywhere. The ones stored in devmode/userdata/screenshots.

    New UI - I've only managed to use Steams screenshot-function, which doesn't work with your crop-webtool.
     
  10. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    793
    Likes Received:
    1,168
    Maybe Cselt will find some way to hide or remove the banner on the left.
    Steam screenshots are here
    "c:\Program Files (x86)\Steam\userdata\123837433\760\remote\365960\screenshots\"
    Sin título.png
     
  11. RoWo

    RoWo Member

    Joined:
    Jul 16, 2014
    Messages:
    386
    Likes Received:
    457
    Click on the lock (to unlock) and move your mouse to the right!
     
    Corti likes this.
  12. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    793
    Likes Received:
    1,168
    20210115220254_1.jpg
    thx ;)
     
    Last edited: Jan 15, 2021
  13. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Do we talk about the same Thing?
    The Creation of proper Screenshots in PNG Format works in DevMode only, currently.
    So it doesn't matter if you use the old or the new UI, because the DevMode is the same.
    I have to ask again: when you use the new UI, do you make the Screenshots in DevMode and that does not work?
    If that is the Case, please use another Key for the Screenshot in the DevMode than Steam uses for the Steam Screenshot and check if it works then.
    One User could get it working in that Way.
    And as a Hint: The Steam PNG Screenshots don't have an empty Background as you can get it in the rFactor 2 Showroom, so my Crop Tool can not crop something. ;)
     
    Corti likes this.
  14. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    793
    Likes Received:
    1,168
    sry ... now understand
     
  15. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    793
    Likes Received:
    1,168
    Dev Mode png format, but... :)
    GRAB_000.PNG

    20210116113833_1.jpg
    This is the capture in the new UI, edit the player file with value 3 (png) but continue saving in jpg format :(
    P.d: Configuring the Steam parameters (Steam / Parameters / in game) you can customize the key to make the captures, as well as another folder to save and if you activate (save uncompressed copy) the capture is saved in png format although the result is the same
    365960_20210116113833_1.png
     
    Last edited: Jan 16, 2021
  16. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    @Corti Are you sure that you have set the Format for the Screenshot Picture to PNG in the player.JSON of the DevMode?
    Sorry that i ask, but I can only repeat myself: here it works as it ever did without any Problem.
    And i use the new UI, that, as said doesn't matter, because the DevMode is the same for the old UI and the new UI Build.
    And you have to use the rF2 Screenshot, NOT the Steam Screenshot.
     
    Corti likes this.
  17. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    793
    Likes Received:
    1,168
    yep DevMode & SinglePlayer
    "Screenshot Format":3,
    "Screenshot Format#":"0=default (jpg), 1=bmp, 2=jpg, 3=png, 4=dds, 5=clipboard",

    Simple Showroom test samples:
    365960_20210116124432_1.png 365960_20210116124424_1.png
     
    redapg likes this.
  18. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    @Corti Is the Picture without the Upgrades Menu from the DevMode?
    If yes, is it PNG Format?
    If yes, did you hit the Key 1 (above of the Q) to hide the Showroom Mesh?
     
  19. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    793
    Likes Received:
    1,168
    No :oops: both screenshots are in single player UI. Go to try :)

    GRAB_003.PNG GRAB_002.PNG
    ModDev ;) thx mate​


     
    Last edited: Jan 16, 2021
    redapg likes this.
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Currently it works in DevMode ONLY. ;)
     
    DA, Corti and Mauro like this.

Share This Page