[REL] Easy Icon Creator Showroom

Discussion in 'Other' started by redapg, Sep 16, 2020.

  1. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Inspired from some Posts in the Forum and some own Experiences, i thought it would be good to have a Possibility, to create the Icons, that are used in the Car Selection Menu of the new UI, in an easier Way.

    Normally you have to edit the Screenshot, that was made in the Showroom, to get rid of the Background and have only the Car left on the Picture.

    Together with Marco @Slow Motion , we have made some Tests and tried a lot of Things, to get a good png Screenshot, that don't has to be edited by Hand anymore.

    Unfortunately we've found some Limitations and Bugs, but we think that the current Version is a good Compromise, with the existing Possibilities of the Games Code.

    We had actually planned to offer a DevMode Version and also a Version for the Single Player.
    Due to the Fact, that the Single Player Screenshot in png Format, doesn't show the Car, we only release the DevMode Version now.

    The ZIP File contains the Showroom and a short "Manual", with some Information about how to use it.
    Please read it, to get all Info, because, for Example, you have to edit the player.JSON File, to get it working.

    With the Screenshots from this Showroom and the Icon Creator Tool from my online Tools Website, you normally have to do only this:
    - make the Screenshots
    - rename them as required
    - load them up to the Icon Creator Tool Website
    That's it.

    Extract the ZIP File directly into the DevMode Showroom Folder:
    ..\rFactor 2\ModDev\Showroom

    UPDATE 1.1 (22.09.2020 Info)
    Here is the Download Link: Easy Icon Creator Showroom

    If any Problems show up, please report here in this Thread.
    We hope you find this helpful.
     
    Last edited: Jan 11, 2021
    svictor, Slamfunk3, Corti and 9 others like this.
  2. atomed

    atomed Registered

    Joined:
    Jul 9, 2019
    Messages:
    509
    Likes Received:
    356
    This is fantastic, thank you so much.
     
    redapg and Slow Motion like this.
  3. Mauro

    Mauro Registered

    Joined:
    Oct 14, 2011
    Messages:
    1,826
    Likes Received:
    2,823
    just tried with old UI, it works very well

    [​IMG]

    P.S. new UI devmod don't work on my system so no test
     
    atomed, redapg and Emery like this.
  4. Slow Motion

    Slow Motion Registered

    Joined:
    Aug 14, 2012
    Messages:
    2,446
    Likes Received:
    4,907
    [QUOTE="Mauro, post: 1039749, member: 25261"

    [​IMG]

    P.S. new UI devmod don't work on my system so no test[/QUOTE]

    New ui in devmode doesn't yet exist. If you want to test icons, each time you must build the rfcmp and using retail
     
    Mauro likes this.
  5. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    We have uploaded an Update V 1.1 (download it again, in the first Post), because Marco (@Slow Motion ) got the Information, that the Showroom Mesh can be "hidden" by pressing the Key 1 on your Keyboard (the one that is above of the Key Q).
    So the "pre" Showroom, to check the Shadow, is not needed anymore and the Files:
    EasyIconCreatorShowroompre_SMMG.mas
    EasyIconCreatorShowroompre_SMMG.ini
    can be deleted from the Folder:
    ..\rFactor 2\ModDev\Showroom
    If you have deleted these 2 Files, unzip the 1.1 Zip into the same folder and overwrite the existing Files.

    The Usage is the same as before, but you can do everything in one Showroom now.
    If everything looks good, just press the Key 1 and make your Screenshots.
    To unhide the Showroom Mesh, press the Key 2.
     
    Legend, dylbie, Emery and 3 others like this.
  6. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    835
    Likes Received:
    241
    Right now i can't download any generated images. I get a 404 error on the DL page
     
  7. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    835
    Likes Received:
    241
    Problem on my side. Addblocker :confused:
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Thank you for reporting this, it can help other People to solve that Problem.

    Can you please tell me which Browser you did use and if it was the default or a 3rd Party Addblocker?
    Maybe i can reproduce and fix that Problem.
     
  9. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    835
    Likes Received:
    241
    I used Firefox 81.0.1 with uBlock Add Blocker
     
  10. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    I have tested it with the same Browser/Version and the Adblocker uBlock, but here it worked properly.
    So i can do nothing to fix it.
    But when Deactivating or Removing uBlock fixes it, it should be OK for Others with the same Problem. ;)
    Thanks again for reporting it. :)
     
  11. r00b Driver

    r00b Driver Registered

    Joined:
    Feb 7, 2020
    Messages:
    57
    Likes Received:
    27
    Hi!
    Because I'm an idiot, I have no idea what I do with these icons when I've created them.

    I've created a driver .rcd file and associated folder, even modded a skin , but not a clue where to put these icons...

    Do they go into the .mas file of the modded driver?


    Thanks!
     
  12. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Sorry, i never work with these "virtual" Drivers/Skins, so i can not answer this.
    I would suppose that they have to be included into the MAS File.
    Maybe you better ask in another Subforum or start a Forum Search.
    I guess you'll find some Threads about it.
     
  13. r00b Driver

    r00b Driver Registered

    Joined:
    Feb 7, 2020
    Messages:
    57
    Likes Received:
    27
    That's fine - I did some digging around and I don't think it can be done with a 'virtual' driver - only with skin packs.
    Never mind, I can live without it!
    Thanks for replying.
     
  14. KostasGR

    KostasGR Registered

    Joined:
    Mar 17, 2016
    Messages:
    26
    Likes Received:
    2
    First of all amazing job with those tools. I tested them and work awesome!
    However, I have a different workflow and i thought i could share it here if someone wants to follow it.
    First, I export the car with 3DSimed. I load all GMTs and then export it for Assetto Corsa as KN5 file.
    Then, I make content/cars/carname folder and push there the KN5. I make a skins folder too with all the skins i want screenshots.
    Then I use Content Manager with custom shaders (for each car if necessarily and if they have custom shaders at rF2) and showroom and take PNG no-background no draw-ground screenshots for all the cars as a batch command. I end up having PNG screenshots for all the cars at 1920x1080. I rename them using Bulk Rename Utility Program to match the .veh files.
    Last I have make some Actions to Photoshop that it takes the screenshots from one folder and resize them to 255x72,509x144,512x512,1018x288,2036x576,4073x1172. and prefix them -icon-resolution
    Job Done!
    For me that workflow gives the best result as quality. It requires some pre-work and to 'play' with Content Manager but then it's very easy.
    Some samples follows. The FS_5 is the png that i get from Content Manager. The others are the downscaled-upscaled version using photoshop actions
     

    Attached Files:

    svictor likes this.
  15. khan1670

    khan1670 Registered

    Joined:
    Nov 8, 2020
    Messages:
    4
    Likes Received:
    2
    Is it possible for this showroom to work in the regular game? (not devmode)
    Although the main game doesn't save png properly, you can get Steam to save as png.
    In fact main game doesn't seem to saving any screenshots (for me anyway) right now.

    This would make it easier to get better icons for the S397 cars which you can't get into devmode.
    I was able to get this showroom in main game, but can't make the background disappear or get the side panel to go away.
     
  16. Thaichang

    Thaichang Registered

    Joined:
    Jun 3, 2019
    Messages:
    17
    Likes Received:
    5
    Hi redapg.
    First of all thanks so much for your work! rf2 won't survive without this community support.
    Followed your showroom instructions of
    F12 and Steam takes the png (Player.JSON modified (...= 3)) to the folder defined.
    But always including the black background seen in the Showroom.
    What I'm doing wrong? Is this common or the backgorund of the png shall be black and then edited in PS?

    Thanks again!
     
  17. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    @khan1670 @Thaichang
    What was not working all the Time, was to use this Showroom in the Single Player Mode, because the rF2 png Screenshot didn't show the Car.
    And also to use the Steam png Screenshot didn't work, because it always showed the Background of the Showroom.
    (@khan1670 to get rid of the Menu in the Showroom, press "Enter" on your Keyboard)

    You have to use the rFactor 2 Screenshots from the Folder
    ..\rFactor 2\ModDev\UserData\ScreenShots
    not the Steam Screenshots.
     
    Last edited: Dec 4, 2020
    Mauro likes this.
  18. khan1670

    khan1670 Registered

    Joined:
    Nov 8, 2020
    Messages:
    4
    Likes Received:
    2
    You're right, the Steam screenshot doesn't give the transparency to the png. Dang you Steam.

    However, it's the 1 & 2 key that make the background disappear in the showroom, not F1 & F2.
     
    juanchioooo likes this.
  19. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,708
    Likes Received:
    469
    Thank you, you are right.
    I should have read my own Manual again. :D
     
    davehenrie and lagg like this.
  20. Thaichang

    Thaichang Registered

    Joined:
    Jun 3, 2019
    Messages:
    17
    Likes Received:
    5
    Thank you @redapg! I found them.
    But the screenshots from C:...rfactor2/ModDev/Userdata/ScreenShots has still the black background.:confused:
     

Share This Page