Track AIWs

Discussion in 'Third Party Content' started by t0p5ecret, Sep 17, 2019.

  1. Manfredk2

    Manfredk2 Guest

    Could you make a screenshot where the braking in the esses is?
     
  2. Angus May

    Angus May Registered

    Joined:
    Apr 23, 2023
    Messages:
    11
    Likes Received:
    3
     

    Attached Files:

  3. Angus May

    Angus May Registered

    Joined:
    Apr 23, 2023
    Messages:
    11
    Likes Received:
    3
    this can be taken with a full throttle or slight lift off
     
  4. Manfredk2

    Manfredk2 Guest

    ok, please try the fix no. 3 - uninstall previous fix first. Version should be 1.02
     
  5. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    54
    Likes Received:
    19
    Mt Panorama by Hellboy V0.982
    Unfortunately have found more issues with this track. A Part from the qualifying issue posted earlier i have found that the AI cars during a race are not entering their pitbox properly so do not refuel so DNF in the pits... they come to a stop on an angle to their pitbox but dont enter the pitbox correctly to fuel up... seems to be an issue that has started with the latest updates to RF2... could someone please look at and fix the two issues... seems like Hellboy is missing at this time... Cheers
     
  6. Manfredk2

    Manfredk2 Guest

    yes, the devs of S397. This all has nothing to do with the AIW
     
    Corti likes this.
  7. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    54
    Likes Received:
    19
    Agree with what your saying, but surely you guys could have a look and fix??? You guys are the boffins when it comes to this stuff... your track expertise would be greatly appreciated! Its Bathurst a track that gets used by many racers regularly! Please help...
     
  8. atomed

    atomed Member

    Joined:
    Jul 9, 2019
    Messages:
    1,341
    Likes Received:
    1,352
    There is nothing that can be done at this moment at track side to fix this, these are calculations and behaviors that are track independent.
    For 2023 the developers are working on the AI side of the sim and we have seen big improvements on that side. I´m pretty sure this issue will also be fixed, we just have to be patient.
     
    Last edited: May 17, 2023
    Corti likes this.
  9. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    I was curious, why the AI would not make a proper Pit Stop and so i've made a quick Test.
    To keep it short: the Problem is, that the Track has no Static01 Reflection Mapper defined in its SCN File.
    It's a bit strange, but it is as it is. :)
    I have made a small Update rfcmp, that you can test it (you have to have Version 0.982 installed).
    In the Menu it appears as Mountpanorama 0.982PitFix.
    With a bit of Luck, that also solves the Quali Problem of the AI.
     

    Attached Files:

    vava74 likes this.
  10. Manfredk2

    Manfredk2 Guest

    this will fix also the black raindrops and hopefully the colour changing of the road cracks:)
     
  11. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    Is the Problem with the black Drops, if there is no Static01 Reflection Mapper defined in a Tracks SCN File, still not fixed by S397? :D
     
  12. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    54
    Likes Received:
    19
    Ok so i redownloaded the V0.982 Bathurst Track and added your patch and it works!
    Still a small issue of not all of the AI cars qualifying (1st test 3 didnt qualify the 2nd test 5 didnt qualify) but on two racing tests all cars are pitting and refuelling correctly!
    So thankyou very much for your time and work!
    Have agreat day
    Cheers
    Craig
     
  13. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    I also did make another Test and when i let the AI drive 5 Quali Laps, they all seem to get a Laptime.
    Seems as if only 3 Quali Laps doesn't work properly.
    Most of the Cars enter the Pits at the End of their 2nd Lap and with the Setting of 3 allowed Quali Laps, they can not make another Lap, to get a Laptime, then.
    But i will make another Test, because i have seen something in the AIW File, that maybe can be the Reason.
     
    atomed likes this.
  14. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    @Craigbowie I did make another Test, but what i thought it might be Reason for the AI not doing Quali Laptimes, didn't cause the Problem.
    It indeed seems to be something in the Game Code, because it also happens on official Tracks (also in DevMode).
    So i would suggest, to set the allowed Count of Quali Laps to 5 as a temporary Workaround.
    That, at least, seems to work.
    And keep in Mind, that S397 is currently working with the AI a lot. ;)
     
  15. Manfredk2

    Manfredk2 Guest

    It depends obviously also a bit on the car...

    with redapg´s fix
    Screenshot 2023-05-18 120756.jpg

    without the fix
    Screenshot 2023-05-18 120626.jpg
    the AIW in general needs an overhaul. Some cut corridors are bad
    GRAB_013.PNG
     

    Attached Files:

  16. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    @Manfredk2 Yes, the whole AIW should be made completely new.
    Maybe that also solves the Problem with the Quali Laptimes.
    I've made another Test and on other Tracks all the AI get Quali Laptimes, so it seems to more be a Track Problem though.
    BTW You should compare with and without my Fix with the same Cars or different Cars, both with or without the Fix, to get comparable Results. ;)
    And in the first Screenshot, can it be that these Cars still use the old rF1 Engine.ini?
    That seemed to be a Problem too.
     
  17. Manfredk2

    Manfredk2 Guest

    Sure, i wanted to show only that the problem lies probably deeper.

    As you wrote i also happens on official tracks in combination with some mods
    Screenshot 2023-05-18 130433.jpg

    Same track, other car
    Screenshot 2023-05-18 130500.jpg
     
    redapg likes this.
  18. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    54
    Likes Received:
    19
    Interesting cause ive set the allowable laps to 40, it doesnt seem to make a difference. I also made the qualifying session 30 minutes which should be more than enough time to do at least 3-4 laps.
    This is the only track ive found the issue on.
    The most important thing was the cars not refuelling but you have nailed that issue with the fix. I can live with a few cars not setting a time, although they do in practice, which can be used to set the grid!
    Thankyou again for all your help and work, at least now we can race Bathurst again!
     
    redapg likes this.
  19. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    I'll continue investigating, because it interests me, what causes that Problem.
     
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,092
    Likes Received:
    2,938
    I'll try it with a complete new AIW now.
     

Share This Page