Logging Out-of-Realtime Physics Freezes [public-test]

Discussion in 'Technical & Support' started by Christopher Elliott, Mar 19, 2019.

  1. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    We merged the changes from public-test to our master branch, so for the moment public-test and default branch have the same build ID.
     
  2. felippe kiss

    felippe kiss Registered

    Joined:
    May 5, 2017
    Messages:
    9
    Likes Received:
    9
    Well after unistall, subscribed only in official content, and reinstall, freezes gone
     
    WiZPER likes this.
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,002
    Likes Received:
    1,217
    Christopher posted that everyone using the beta should opt out for now. The new LM includes updates not in the beta program.
     
    christos_Swc likes this.
  4. geepee

    geepee Registered

    Joined:
    Jun 17, 2012
    Messages:
    8
    Likes Received:
    4
    yesterday another bad day at srvn, 70 minute race on sao paolo had several casualties from lag moments.
    I only experienced one minor moment with only VR loading visual around 30 minutes into the race
    caused me to spin as I warped a bit into somebody, but at least I could continue the race. some others were not so lucky roughly

    vid snapshots at
    view from car behind me :
    same moment from my car

    my log files at: https://geepeester.stackstorage.com/s/F5hURp1C41s6GIS
     
  5. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    116
    Likes Received:
    42
  6. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    22
    Likes Received:
    6

    Jun./20/2019 2:30:10~

    https://drive.google.com/file/d/1IemtQqafrPTsMJDrgYEjhODynkeJmikd/view?usp=sharing
    Frame index:192827 and others
    Server Replay file
    Result(Sim Result)

    rFactor 2 version: 1.1112
    Steam Build IDs: 3921932 (client) ,3921933 (dedicated server)
    (not Public Beta)

    This race has many Out-of-Realtime.
    I think, When do not use TUNING ,I feel that no Out-of-Realtime will occur.
    But, may be my misunderstanding.
    Thank you.

    PC specs
    OS:Windows 10 Home 64bit
    CPU:Intel Core i7-8700 & Dynatron L5 Liquid Cooler
    M/B:ASUS TUF Z370-PLUS GAMING
    MEMORY: DDR4-2400 16GB(8GBx2)
    G/B:GTX1070(GDDR5/8GB)
    SSD1(OS):Crucial CT1000MX500SSD1 1TB
    SSD2(game):Crucial CT500MX500SSD1 500GB
    Power supply:SILVER STONE STRIDER GOLD S SST-ST75F-GS V2
    Monitors:I-O DATA EX-LD2702DB x3
    Sound:SB-Z

    Mod and Track
    S397 GT3pack(Radical GT3) & GT3 Challengers Pack
    Nurburgring v2.30

    plugins
    Plugin:Z1 dash,DAM plugin
    HUD:SHQM HUD

    Server
    Weather:rf2WeatherPlugin(Real Weather)
    Start:Selfrolling
    Flag:Full w/o DQ
    Driving aids:AC AI
    Fuel Usage:x2
    Tire Usage:normal
    Time Scale:x10
    Realroad Time Scale:normal
    Mech Failures:normal
    Damage:20%
    Start time:AM11:00
    Race Rejoin:1(yes with fresh vehicle)
    Race:2.4Hr
     
    Last edited: Jun 24, 2019
  7. AirplaneRider

    AirplaneRider Registered

    Joined:
    Jun 23, 2019
    Messages:
    11
    Likes Received:
    1
    I can confirm this problem exists in Windows 7 as well as Windows 10 with the same hardware. I can't get through a single player 25 lap race at Lime Rock in the GTE's without it glitching.

    My log is attached.
     

    Attached Files:

  8. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @AirplaneRider @yashiman @Alexandr Meshkov @geepee and to all other people having stutters, can you try removing ALL the 3rd party plugins and then check if the stutters are gone?

    Also please could you test with RealtimeLogging set to 1 in the player.json file?
     
    yashiman likes this.
  9. geepee

    geepee Registered

    Joined:
    Jun 17, 2012
    Messages:
    8
    Likes Received:
    4
    Thought i had it set at 1, but will check. Regarding plugins, certainly had the same issue while I was not using motec plugin, for me that is the only one currently enabled (most of the time).
     
  10. HungryForSky

    HungryForSky Registered

    Joined:
    Jul 8, 2018
    Messages:
    7
    Likes Received:
    0
    I'm not sure that this is what you need. but in the single-player mode, when the start or ESC button is pressed, a strong physics freeze occurs for the ai.

    repeatability is constant. It would be great if there was an opportunity to remove or reduce this effect.
     
    Last edited: Jun 26, 2019
  11. AirplaneRider

    AirplaneRider Registered

    Joined:
    Jun 23, 2019
    Messages:
    11
    Likes Received:
    1
    How about asking us if there is a commonality of plugins that we're using? Could save time.

    I'm using:

    SimXperience (SimXperience_0_4_x64.dll)
    Crew Chief (rFactor2SharedMemoryMapPlugin64.dll)
    Steam (SteamPlugin.dll)
     
    Last edited: Jun 27, 2019
  12. AirplaneRider

    AirplaneRider Registered

    Joined:
    Jun 23, 2019
    Messages:
    11
    Likes Received:
    1
    No Crew Chief or anything else? Steam?
     
    Last edited: Jun 27, 2019
  13. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,444
    Likes Received:
    2,358
    I don't think they want this thread flooded with posts discussing plugins. By getting people to remove/disable all plugins it isolates the game itself, so if there's stuttering it's a game issue they need to find and fix.

    As they identify problem plugins they will list them here: https://forum.studio-397.com/index.php?threads/plugins-you-should-stop-using.63452/
     
  14. AirplaneRider

    AirplaneRider Registered

    Joined:
    Jun 23, 2019
    Messages:
    11
    Likes Received:
    1
    Correct me if I'm wrong, but using plugins is a part of the game, is it not? Perhaps the portion of their core API that the plugins rely on is the problem and should be looked at. Just telling customers to not use plugins is not a solution. Pinpointing the exact cause of the bug is what is needed, even if that happens to be some interaction where a plugin is performing a data call via the API, for example.
     
  15. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,081
    Likes Received:
    740
    4thworld hasn't just told customers to not use plugins.
    He has asked to check if the stutters disappears without 3rd party plugins.
    It's a way to know what's causing the problem.
     
    Marcel Offermans likes this.
  16. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    576
    Likes Received:
    2,520
    If you've ever studied our documentation for plugin authors, you will have noticed that we extensively explain what constraints plugin authors need to take into consideration when writing their code. With great power comes great responsibility! Most plugins are well behaved. Some, we have found over the years are not. For this testing we therefore ask you to disable plugins. In general we will start listing plugins that, from our logging, have proven to be problematic. We also encourage authors of those plugins to get in touch so we can help them find a solution.
     
    Filip and The Iron Wolf like this.
  17. AirplaneRider

    AirplaneRider Registered

    Joined:
    Jun 23, 2019
    Messages:
    11
    Likes Received:
    1
    I understand Marcel. But it only takes one person reporting that they aren't using plugins to falsify that idea. I was just trying to take that a step further and see if there is a common link between those having the issue and perhaps a particular plugin in use. If you suspect plugins as a possible culprit, it seems like this would be helpful information. But everyone can feel free to ignore me.
     
  18. Filip

    Filip Registered

    Joined:
    Feb 9, 2017
    Messages:
    831
    Likes Received:
    636
    Your bold part is wrong.
    In complex cases like this there can be multiple causes that can produce similar unwanted behavior or stutters in this case.
    So to isolate possible core issues you need to remove other possible causes or plugins in this case.

    It also makes testing much easier, sometimes it can be almost impossible to calculate all interactions of different components and their influence on final issue.

    So if you have one person that doesn't use plugins but experiences stutters that doesn't falsify idea of testing without plugins because that single case could be insufficient.
    For instance it could be that person in case has different cause of stutter than other users. And it could be even that his stutters are unrelated to problem in case.
    As said there could be multiple initial causes that manifest as same issue. Sometimes you'll need to debug many cases until you can pinpoint the root of problem.
     
  19. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    22
    Likes Received:
    6
    p.s.2019 Jul. 26
    This race, I not used Z1Dash, But I forgot to turn off plugin.
    So, I had stutters at sun set times.
    Disconnect freez was not occur.

    results
    log files
    server replay files

    p.s. 2019 jul. 13
    I played race w/o disconnect freez and Stutter at this race.
    I think this freeze was caused by car mods (especially UPGRADE).
    Because I've raced on this cars many times but never experienced disconnect freeze.

    results
    server replay file
    log files
    I hope this will help:)

    p.s. 2019 jul. 7
    Disconnection bug was occurred at least before 2016. It was fate day today.

    p.s. 2019 Jul. 4

    1h54m40s~
    Race detail
    Logfiles and server replay
    I did to retry to use plugins at multi race.
    Also, I had many stutter.
    GRAB_1678.jpg
    This is my plugins.
    Z1 Dash, Crewcheif, DAM and etc... Which one is bad?
    Thank you.


    1:40:10~
    p.jpg
    Replay&Log files
    https://drive.google.com/file/d/1Rm5CWRpIXzUbSKWmoO58iRNoTVUMbh_d/view?usp=sharing
    Replay position:1733.536

    I tried your suggestion that 3rd party Plug-in's uninstalled.
    I feel certainly stetters (short time lag) better than before. (But in the race, I lost FFB 2 times.)
    And I crashed suddenly When other driver conection lost.
    Actually ,this issue has existed before 2016. rFactor 2 Issues
    (Maybe this problem has occurred since the end of 2015.)
    I thank S397 members. Please do your best in the future.

    私は4thworld氏の「サードパーティー製プラグイン」を削除するという提案を試してみました。
    確かに、スタッター(ショートタイムラグ)は、減少したと思います。(ただし、レース中に、FFBが2回消えました)。
    そして、他のドライバーのconnection-lostが発生した時、私は突然クラッシュしました。
    実は、この問題は2016年以前から確認されています。
    (多分、2015年の年末頃から発生しています。)
    S397のメンバーにはいつも感謝しています。今後共がんばってください。
     
    Last edited: Jul 26, 2019
  20. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    116
    Likes Received:
    42

Share This Page