Logging Out-of-Realtime Physics Freezes [public-test]

Discussion in 'Technical & Support' started by Christopher Elliott, Mar 19, 2019.

  1. Stefan_L_01

    Stefan_L_01 Registered

    Joined:
    Nov 18, 2012
    Messages:
    346
    Likes Received:
    161
    I had some freezes in recent race, but I did not run log and situation is very excotic.
    We use simsync to get a skinpack for that league. New skinpacks are made as new version of existing mod package. Here the problem start: simsync does not update the mod like a real installation would do (say delete the old one, install new one), it just adds. So you have V1.1, V1.2 ... .
    On the server, as I know meanwhile, they delete the old mods. I did not know that this could cause issues.
    Now: During race I saw at leat 5 other cars driving around with my own car and skin, and I know they did not drive the RSR. In the youtube stream (made by server observer) you can see them in the right car. So for my rf2 instance cars and skins where loaded wrong due to the version conflict, having multiple versions available for same mod (somehow, no expert in this case).
    Now, whenever some of them driving my car and skin left the race (it was an 3h endu, some gave up), I had a freeze. I suppose the server said that guy is off driving a unique car design (server view), the car & skin was removed on my rf2, then my rf2 instance found ups there is still someone driving that design (at least me) and reloaded it, something like this
    Very excotic situation but happened a few times for me
     
  2. pablos

    pablos Registered

    Joined:
    Oct 5, 2018
    Messages:
    8
    Likes Received:
    13
    @4thworld Here is log from today's drive: https://drive.google.com/open?id=1wDfSLtFZaR8XpIrxnjwtJe-3ydJmBWUx
    I did about 12 laps and recorded only one freeze in the beggining of session, from results log I suggest the timestamp was between 120 and 250. Besides that everything ran smoothely.
     
  3. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Davvid I can't open the link for the log you attached in your post
     
  4. Davvid

    Davvid Registered

    Joined:
    Feb 11, 2012
    Messages:
    142
    Likes Received:
    22
  5. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Davvid thanks, your log shows that everything is ok.

    We are using a little bit more of CPU resources when the physics load is lower in order to be more precise on starting the next physics step or recovering from being late on a previous one.
    When the physics load is higher you shouldn't witness any issues, let us know if you encounter any.
    Cheers.
     
    The Iron Wolf likes this.
  6. Davvid

    Davvid Registered

    Joined:
    Feb 11, 2012
    Messages:
    142
    Likes Received:
    22
    Thanks @4thworld. Yeah, current test is ok-ish but that previous one really scared me, as I feared I'll need to upgrade my cpu really soon ;-) I think it shows that one should be watchful with those changes regarding cpu usage.
     
  7. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    Build update ID [3788578] :
    - Improvements to main thread , FFB thread and CPU load

    @Davvid you can take a look to see if the idle CPU usage is lower for you.

    branch name: public-test
    password : UpERYPhIblEHorTiO
    verify your files via Steam after joining the branch

    1. Select rFactor 2 from steam game library, right click and select properties.
    A dialog box with a number of tabs will appear, your looking for one that says "BETAS".
    2. select the "BETAS" tab it by clicking on it.
    You will see 2 things now, a drop down menu and a text box to enter a beta access code.
    3. enter the password provided,
    4. select public-beta from the dropdown menu
     
  8. Davvid

    Davvid Registered

    Joined:
    Feb 11, 2012
    Messages:
    142
    Likes Received:
    22
    Yes it is, although not by that much. Maybe 5% or so. But it's better.

    Edit:
    This test build crashes rFactor2.exe when using 'Reset FFB' command while driving.
    @4thworld
     
    Last edited: May 2, 2019
  9. krusti

    krusti Registered

    Joined:
    Apr 20, 2016
    Messages:
    578
    Likes Received:
    495
    And my rF2 keep freezing when i alt-tab it and i return into it after some minutes, also it freezed heavily when someone joined the server, i have to close it thorugh the task manager. (I'm using borderless mode btw, this started to happens today after the last beta update).

    It freezed right now when loading drivers list in the server, again i have to close it throught the task manager.

    update
    Trace file of a freeze (and again i needed to close rf2 through the task manager) occured when entering a server.

    update
    same issue, occured when i voted for a weekend restart, another trace and realtime logging attached as well now
     

    Attached Files:

    Last edited: May 3, 2019
  10. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    265
    Likes Received:
    79
    @4thworld System updated to build ...8578. Tested for the first time this morning and after a couple of minutes it crashed. The screen went black, but a loop of sound continued. The picture in VR was black, but on the screen was frozen and no response from any keys. Had to escape by closing SteamVR. No log generated unfortunately.
     
  11. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    Build update ID [3791195] :
    - Addressed some changes that caused issues.

    Let me know if the build is ok for you now.
    Thanks

    branch name: public-test
    password : UpERYPhIblEHorTiO
    verify your files via Steam after joining the branch

    1. Select rFactor 2 from steam game library, right click and select properties.
    A dialog box with a number of tabs will appear, your looking for one that says "BETAS".
    2. select the "BETAS" tab it by clicking on it.
    You will see 2 things now, a drop down menu and a text box to enter a beta access code.
    3. enter the password provided,
    4. select public-beta from the dropdown menu
     
    yashiman likes this.
  12. krusti

    krusti Registered

    Joined:
    Apr 20, 2016
    Messages:
    578
    Likes Received:
    495
    Problems fixed for me :)
     
    The Iron Wolf likes this.
  13. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    265
    Likes Received:
    79
    @4thworld Fixed for me as well :)
     
    The Iron Wolf likes this.
  14. Davvid

    Davvid Registered

    Joined:
    Feb 11, 2012
    Messages:
    142
    Likes Received:
    22
    Yeah, fixed.
     
  15. dradecki

    dradecki Registered

    Joined:
    Jan 14, 2012
    Messages:
    299
    Likes Received:
    22
    The public-test seems to be worlds different for me. The AI stutter and track pauses appear to be gone now. Thanks.
     
  16. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    116
    Likes Received:
    42
    Today I had reasonable freeze in online race when someone exiting server. My realtime logs for that here.

    We are using Nascar 2016 mod, Watkins Glen track. Server was configured for fixed setups and fixed upgrades but upgrades wasn't fixed somehow and all drivers set them manually. Other drives also reported problems when others exiting server.

    That moment on replay at 794 (26:59 on stream)
    Second moment after the finish when other driver exit server at 3784 (1:16:47 on stream)


     
    The Iron Wolf likes this.
  17. dradecki

    dradecki Registered

    Joined:
    Jan 14, 2012
    Messages:
    299
    Likes Received:
    22
    I experienced a similar experience. I thought the stutter was gone, but after about 10 minutes the AI jitter came back at Imola with ASR '93 F1 mod, and the after another minute or so I got a screen freeze. I'll upload my logs tonight.
     
  18. Brent

    Brent Registered

    Joined:
    Nov 5, 2015
    Messages:
    92
    Likes Received:
    22
    public beta 3791195, confirmed I'm using that buildID and then verified the files via Steam after joining the branch. No stuttering, just wanted to post a new log with the latest public beta. Also "Realtime Controller Detection":false Loading any controller profile automatically sets this back to true and the stuttering returns.

    Log and trace files of one lap with AI control and one lap my control around Silverstone in the C6R with Build ID 3791195:
    https://www.dropbox.com/s/jzi57brt3puanyj/2019-04-24 RF2 Trace and RTL files ID3791195.zip?dl=0

    Stream of the above 2 laps with CPU GPU and FPS data on and replay of those laps, any stuttering in the track replay is in the stream only:
     
    The Iron Wolf likes this.
  19. Noah Reuvers

    Noah Reuvers Registered

    Joined:
    May 10, 2019
    Messages:
    1
    Likes Received:
    1
    Since the newest beta build, all my issues with screenfreezes/stutters are solved. rF2 runs flawlessly now for me, I appreciate your work guys!
     
    The Iron Wolf likes this.
  20. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    64
    Likes Received:
    37

Share This Page