rFactor 2 Issues

Discussion in 'Bug Reports' started by osiris32, Feb 14, 2016.

  1. osiris32

    osiris32 Registered

    Joined:
    Feb 6, 2015
    Messages:
    76
    Likes Received:
    4
    Build 1052 still experiences lag or stutter when people join and leave server. This freezes the screen for about a second. This has been happening to my knowledge since about build 1028 or sooner. This happens on a variety of hardware and the only thing that has changed on the server is the rF2 build.

    A driver reported that he was able to join with a different password than what was currently used. This was a previously used password.
     
  2. Ho3n3r

    Ho3n3r Registered

    Joined:
    Feb 18, 2012
    Messages:
    521
    Likes Received:
    94
    Just to add, I was the user. I thought it was still the old password, and it worked. Then after driving a while, the server was restarted, and I tried to re-join and the old password wasn't working. To my surprise, I was informed that the password had already been changed before I joined the first time, and the new password wasn't even remotely the same, so no typo error etc.
     
  3. DocJones

    DocJones Registered

    Joined:
    Jan 26, 2011
    Messages:
    403
    Likes Received:
    4
  4. osiris32

    osiris32 Registered

    Joined:
    Feb 6, 2015
    Messages:
    76
    Likes Received:
    4
    Thanks DocJones.
     
  5. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    24
    Likes Received:
    6

    Is this same lag? That has been since B1028, I think so.
     
  6. osiris32

    osiris32 Registered

    Joined:
    Feb 6, 2015
    Messages:
    76
    Likes Received:
    4
    Yes that is the exact issue.
     
  7. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    24
    Likes Received:
    6
  8. Gijs van Elderen

    Gijs van Elderen Member

    Joined:
    May 1, 2014
    Messages:
    1,399
    Likes Received:
    467
    you'll need to calculate 256kbs per driver. You've set a max off 5000kbs on your server.
    this means your server can handle 19 drivers max.

    To keep a little headroom i whould limit the server to 16 driver, to be sure your event will be smoothless.

    Also monitor CPU usage and RAM usage of the server during an event.


    Edit:
    I don't think "Fix Upgrade" will solve any connection issues.
    Disabling Skin transfer could resolve some connection issues during the practice sessions.
    I don't think skins are Uploaded/downloaded from the server during race sessions. So i don't think this would solve connection issues during race sessions.
     
    Last edited by a moderator: Mar 11, 2016
  9. Yotan

    Yotan Registered

    Joined:
    Jan 17, 2012
    Messages:
    69
    Likes Received:
    5
  10. Yotan

    Yotan Registered

    Joined:
    Jan 17, 2012
    Messages:
    69
    Likes Received:
    5
    Last edited by a moderator: May 12, 2016
  11. benmttf

    benmttf Registered

    Joined:
    May 15, 2013
    Messages:
    91
    Likes Received:
    0
    Hello! When i put Num Race Sessions in player.JSON to anything different to 1 all driver are not allowded to race ???
     
  12. benmttf

    benmttf Registered

    Joined:
    May 15, 2013
    Messages:
    91
    Likes Received:
    0
    Up! ;)
     

Share This Page