Jumbo TV screens

Discussion in 'Track Modding' started by Leonardo1962, Aug 13, 2019.

  1. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    617
    Likes Received:
    847
  2. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
    Yes Corti, but it doesnt work...

    When it`s not updated, you can show a single pic instead, isnt it? Thats what i understand from the above posting so far.
     
  3. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    Do you get it working in game?

    In my opinion, that is one of the reasons that so many modders have left rfactor 2.
    Low level modder support.
    In this case i guess, it would last 5 minutes to write down what exactly it needs to get it working, while the modders spend hours to figure it out, with no success.
    That is no fun really.
     
    Juergen-BY and TheGame316 like this.
  4. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    Hi Bernd,
    i tested it in devmode,
    yes it works in devmode, but i noticed a some hesitations, from time to time. But i think that might be ok.
    [​IMG] (can someone. give me a hint, how to publish better pictures)
    As you asked for a Screenshot, you can see it in a big flat screen TV at pitbuilding(top left).
    Now i try, to create a TV gmt that fits in Joesville, so you also can check it out.
    (But i have to manage to bring a file in a reply)

    Thanks for your interest :)
     
    Last edited: Jun 8, 2020
    Corti likes this.
  5. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    Hi,
    can you try this GMT as an new track object in Joesville . (link is now correct)
    If it works, you should see a working big tv screen right unter the start finish flagholder official.
    You can test it by copying textures gmt file to …\Assets\Maps in moddev Joesville.
    > For now, i do not know how many material bitmaps are used
    > and forgive the low resolution DDS textures for test

    please give it a try
    and thanks for feedback.
     
    Last edited: Jun 8, 2020
    Corti and Bernd like this.
  6. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    That sounds great.
    You can also post here what you have done to get it working, to enlighten all of us. :)

    EDIT
    @Leonardo1962 I have tried your gmt, but still have the black screen.
    That is strange, when it works for you, but not here.
    I have installed a fresh devmode, so it should be completely default.
    Do you have a special devmode? :D
     

    Attached Files:

    Last edited: Jun 8, 2020
  7. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    Sorry i've put the wrong gmt in the Zip.
    > Give it a second try with this GMT
    (After repositioning 3DSimed reseted the shader to T1 again)
    I've created a new GMT zip and with this new link it should work, even with the bad textures. (I've tested it)

    The main thing i did, was change the shadername (in the GMT file) to L2TRACKSIDELIVETVMONITOR
     
    Last edited: Jun 8, 2020
  8. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    Now its 100% transparent (or the normals are flipped?). :)
    Do you maybe have a json file for the material?
    I think 3dsimed will always corrupt it.
     

    Attached Files:

  9. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    strange this is what my screen shows.

    [​IMG]
    I try to change NumBitmaps to 1 (that should also work)
     
  10. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    Really strange!
    Now it's up to me, to figure out what might be different here.
    Would you test a mesh from me (same mesh), that i export directly from 3dsmax, just to see if that works for you too?

    BTW you can upload the screenshots directly here in the forum.
     
  11. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    Ify want to give another try: You may try this GMT
    Yes, please send me yor gmt ...
    Great Idea, but could you give me a hint how to improve upload pictures.
     
  12. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    May be this is the wrong thread, but how can i upload the screenshots directly here in the forum?:confused:
    If you send me a gmt, i could test it. May be we get the TV screens running.
     
    Last edited: Jun 8, 2020
  13. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    click on more options and then upload a file.

    @Leonardo1962 I have uploaded the mesh directly exported from 3dsmax.
    Here again i only see the black screen.
    Would you please test it, if it works for you?
    I have to leave the forum now, but will come back later.
     

    Attached Files:

  14. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    Did you change anything? (It looks and works like my gmt).
    upload_2020-6-8_17-56-16.png
     
    Corti likes this.
  15. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
    For me Bernds version is black and yours (Leonardo) is transparency.
    @Leonardo1962 : why do you add the framebuffer.tga?
     
    Last edited: Jun 8, 2020
  16. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    I see, you have found the way to upload pictures here. :)

    I have converted your mesh into rfactor 1 format, imported it into 3dsmax with the rfactor 1 gmt importer script, used your materials for the cover, applied the Track Side Live TV Monitor shader for the Videowall material, linked the framebuffer.tga texture, gave it a white emissive color and exported it.
    Now, that it works for you, means that there must be another reason than the mesh itself, why it don't works here.
    I will investigate tomorrow and report here.
    THANK YOU for testing the mesh :)
     
  17. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    617
    Likes Received:
    847
    here too, transparent & black.
    these rare values appear in Jumboframe & Jumboscore. And also a point on Videowall channel 1 (not used)
    Sin título.png
     
  18. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    Hi, thanks a lot for your interest,
    I also noticed, that my vertices color for the screen do not differ very much.
    Instead of black (0,0,0) i used (20,20,20) i think that is not important :)
    I used framebuffer.tga, because i noticed a function behind that texture name in the past, but it isn't important any more
    > "mat." does also work.
    Next i compared the materials settings in detail: there are slightly differences, ideed f.e. a alpha value in material (i call it emmisive value) the cubeheaderflag had an Alphachannel, but i think, because both gmt are working similar, so that is also unrelevant.
    Does one of the gmt's work with your setting?
     
    Last edited: Jun 8, 2020
  19. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    @Corti you looking to the frame material. (Frame of the TV screen)
    That is not responsible für the Jumbo screen video wall. You have to look for the material, i called "VIDEOWALL".
    It has 1 texture (name is unimportant) and the shader (in gmt file) is found by "L2TRACKSIDELIVETVMONITOR" they have white vertices (may be alpha does matter sometimes)
     
    Corti likes this.
  20. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678

Share This Page