Jumbo TV screens

Discussion in 'Track Modding' started by Leonardo1962, Aug 13, 2019.

  1. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
  2. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    GTX 1080
    Ok.. i set the MATH as texture and tried to eliminate the transparency in this GMT
    It's still working with some hesitation (all in moddev)
    May be thats's better. Thanks for feedback :)
    upload_2020-6-8_20-27-45.png
     
    Corti likes this.
  3. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
     
    Corti likes this.
  4. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    618
    Likes Received:
    847
    Nvidia GTX 760
    Sin título.png
     
    Last edited: Jun 8, 2020
  5. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    With that mesh i get the black screen again.
    That is the weirdest thing that i've ever had.
    I have tested it on another computer with windows 7 and an amd graphics card (my current system is windows 10 with nvidia), but also there i only see the black screen.
    I have installed a fresh devmode again, installed the rfactor 2 directx, the 4 runtime executables, set different graphic settings, installed latest graphics driver....
    I honestly run out of ideas, what else could be the problem.
    That is a simple feature of the game, nothing complicated, it should run out of the box as @Alex Sawczuk has said.
    Anybody with an idea here? :)

    BTW @Juergen-BY and @Corti Do you have the S397 new york or berlin eprix track and can see their monitors working?
     
    Corti likes this.
  6. Alex Sawczuk

    Alex Sawczuk Member Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    226
    Likes Received:
    178
    If you can wait until after LM, I can help.
     
  7. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    Do we have a choice? :)
    That would be really great, if you would do that!
     
  8. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    199
    Likes Received:
    44
    great, thanks a lot :) :)
     
  9. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
    With the gmt from Bernd i got the black screen, with the gmt from Leonardo (from yesterday, cant test the latest version at the moment) i have no screen, just the framework.

    No FE tracks here.
     
  10. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    618
    Likes Received:
    847
    sry no e-prix tracks
     
  11. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
    Just want to add, i got time to test the latest version from Leonardo (jumbotron_04), screen is black for me.
     
  12. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    618
    Likes Received:
    847
    hello guys, Jumbotron running in Barber 2020
    jumbo_1.png
    jumbo_2.png
     
    Last edited: Jun 10, 2020
    Bernd likes this.
  13. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
  14. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    618
    Likes Received:
    847
    sorry I got confused in the year :oops:, the steam version Barber Motorsports Park 2020
     
  15. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    No problem, i'm confused sometimes too. :D
    I have installed that track, but the screen didn't show up.
    Not only the screen, the complete object wasn't there.
    I have put it into the devmode then and in the scn file, the 3 screens were commented.
    I removed the // and, what a miracle, the screen showed up and worked. :)
    Now i have to find out, why the mesh, that i have exported from 3dsmax, don't works, especially because it worked for Leonardo, but not for me and Juergen.
     
    Corti likes this.
  16. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
    Barber is working for me, too.
     
    Corti likes this.
  17. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,934
    Likes Received:
    324
    Just want to add, when i load my Albi_2006 into Moddev using the jumboscreen version 4 from Leonardo, loading the Materialeditor and add the L2TRACKSIDELIVETVMONITOR to my TVSCREEN, its working.
     

    Attached Files:

    Bernd and Corti like this.
  18. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    So we can use a json file to overwrite the material. :)
    But it still is not working in the way as @Alex Sawczuk has said, so i'll wait until LM is over, because i'm tired of wasting time with no result.
    I have the suspicion that the problem is the converter plugin.
     
    Corti and Juergen-BY like this.
  19. Garitt Gibsn

    Garitt Gibsn Registered

    Joined:
    Dec 13, 2017
    Messages:
    76
    Likes Received:
    144
    @Juergen-BY Hi, are you working with the beta version? I don't find the material editor in "old" DevMode.
     
  20. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    Hello Garitt, before you use it, open the scn file of the track and add the line
    MaterialPath=XXX
    where XXX has to be the path to a folder of the track. (take one that is already linked as SearchPath=)
    Save the scn file
    Start the devmode and when you are on track, open your internet browser with this adress
    http://localhost:5397/materialeditor/index.html
    Select your material and the screen, where you can select a shader and change the settings, opens.
    Set it up as you want.
    If that is done, scroll to the top of the screen and click save to devmode.
    Now you should have a json file with the material name in the folder that you had linked before, that overwrites the material.
    BTW I have tested it with a json file too, but also that don't works here.
     

Share This Page