[NEED INFO] Unstable 515

Discussion in 'Technical Archives' started by 88mphTim, Mar 5, 2014.

  1. vali

    vali Registered

    Joined:
    Oct 5, 2010
    Messages:
    104
    Likes Received:
    0
    I was trying to check the memory usage with the new +memstats but was not able to locate where the log is written. Checked the trace log and no information about it either.

    Did anyone tried it?
     
  2. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,160
    Likes Received:
    38
    Ok I did not read the terms of Unstable Build.
    Because I had been provided by a My Admin.
    I'm sorry I removed the link, and I put the link to the web page of the section Devs Corner

    Babs
     
  3. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,021
    Likes Received:
    199
    Yes, same result here !
     
  4. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    126
    I know it's a bit silly, but the wall is put up so that it's very obvious it's not an official release.
     
  5. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,160
    Likes Received:
    38
    No problem Tim, I agree with your thinking.
    Returning to 515, so far everything is working well.
    No member of my staff, to detected problems.
    We hope to relase in a short time.


    Babs
     
  6. Turbigno

    Turbigno Registered

    Joined:
    May 13, 2013
    Messages:
    26
    Likes Received:
    0
    Build 515 seems to be going pretty well, too bad that there are a few servers for now.
    thx
     
  7. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    126
    Issues up to this point reported in my latest round up...
     
  8. fujitsu1

    fujitsu1 Registered

    Joined:
    Mar 7, 2012
    Messages:
    110
    Likes Received:
    0
    I only can find not ISI servers with this build. Have tried 2 servers but not yours. Where are them, in case of there are?
    Only find 513 and 518 with password.

    EDIT: Sorry, did found them like Testing.+
    At the moment, everything seems to works find except the main servers list, where you have to go out and refresh a few times to get the join/mod button active.
     
  9. Backdraft26

    Backdraft26 Registered

    Joined:
    Dec 23, 2011
    Messages:
    144
    Likes Received:
    0
    In F1CL league, no issue, everything is ok. The join button grey out seems to be fixed :) Nice job thanks ISI
     
  10. Jeremy Miller

    Jeremy Miller Former ISI Senior Programmer

    Joined:
    Oct 5, 2010
    Messages:
    276
    Likes Received:
    3
    The default HTTP port is 64297. That is now required to be open/forwarded to join the server.
     
  11. mavericckk

    mavericckk Registered

    Joined:
    Feb 14, 2012
    Messages:
    202
    Likes Received:
    2
  12. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    826
    Dedicated Server test (-F2R-515-Test-)

    Dedicated server Build 515 crashes when some players join with Chevrolet Corvette C6.R v 1.43 car number 03.
    Server crashes so far with 3 players, Valtteri Leinonen, rafnix and H.......(SRL) and it happens
    every time to same players, they can not join with c6.r v 1.43 car number 03.

    I have also this error with different vmod and Dedicated Server Build 494.

    Loggnavn: Application
    Kilde: Application Error
    Dato: 07.03.2014 21:12:35
    Hendelses-ID: 1000
    Oppgavekategori:(100)
    Nivå: Feil
    Nøkkelord: Klassisk
    Bruker: I/T
    Datamaskin: Packardbell
    Beskrivelse:
    Programnavn med feil: rFactor2 Dedicated.exe, versjon: 1.5.1.5, tidsangivelse: 0x5316f19a
    Modulnavn med feil: rFactor2 Dedicated.exe, versjon: 1.5.1.5, tidsangivelse: 0x5316f19a
    Unntakskode: 0xc0000005
    Feilforskyvning: 0x002d1e3e
    Feil prosess-ID: 0x13d0
    Feil starttid for program: 0x01cf3928e6249e10
    Feil programbane: D:\Rfactor2 TestServer\Core\rFactor2 Dedicated.exe
    Feil modulbane: D:\Rfactor2 TestServer\Core\rFactor2 Dedicated.exe
    Rapport-ID: d1da925d-a634-11e3-95d6-001bdc000327
    Hendelses-XML-fil:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-03-07T20:12:35.000000000Z" />
    <EventRecordID>41919</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Packardbell</Computer>
    <Security />
    </System>
    <EventData>
    <Data>rFactor2 Dedicated.exe</Data>
    <Data>1.5.1.5</Data>
    <Data>5316f19a</Data>
    <Data>rFactor2 Dedicated.exe</Data>
    <Data>1.5.1.5</Data>
    <Data>5316f19a</Data>
    <Data>c0000005</Data>
    <Data>002d1e3e</Data>
    <Data>13d0</Data>
    <Data>01cf3928e6249e10</Data>
    <Data>D:\Rfactor2 TestServer\Core\rFactor2 Dedicated.exe</Data>
    <Data>D:\Rfactor2 TestServer\Core\rFactor2 Dedicated.exe</Data>
    <Data>d1da925d-a634-11e3-95d6-001bdc000327</Data>
    </EventData>
    </Event>
     
  13. ElPronto

    ElPronto Registered

    Joined:
    Jan 30, 2012
    Messages:
    24
    Likes Received:
    0
  14. ElPronto

    ElPronto Registered

    Joined:
    Jan 30, 2012
    Messages:
    24
    Likes Received:
    0
    This is a back to basics type of comment,
    To test open ports:
    http://www.whatsmyip.org/port-scanner/ select port scan ... custom port scan
    If you are looking to test to see if you can host it is advised to have the dedicated host running.
    Ports that are know ( I dont know if they are all needed ) are:
    54297
    54347
    44297
    443
    64297

    Some modems will let you open both UDP and TCP for the same port numbers. They have to be done tcp then udp ( double the work)
    Windows firewall will not let you do "both" so one at a time.

    I know that Mr cisco does not like udp and tcp on the same port number, but it is working for 494 and 515 when hosted on a local machine . Remote severs with muliple hosts is WIP.

    With all this in place we move onto Syntax/ naming convetion of mods etc. NO SPACES IN NAME...USE UNDERSCORE OR HYPHEN eg: xxxx_yyyy or xxxx-yyy

    Simple vmod creation ONE CAR ONE TRACK AND PASSWORD for 494 testing For 515 try joining the ISI servers. Although our private testing of 515 works with these ports.
    Also a good idea to check multiplayer.ini that the ports are correct:
    Simulation Port="54297" // range is 1025 - 65535
    HTTP Server Port="64297" // range is 1025 - 65535. Used for file sharing

    I have had mixed reports for vmod creation. some are saying pre 494 mas2 works .. some are saying that 494 mas2 works. This is beyond the scope of my investigations ATM Our focus was join getmod.

    Regards to all

    Paul
     
  15. rer8

    rer8 Registered

    Joined:
    Dec 19, 2010
    Messages:
    492
    Likes Received:
    23
    Two hours on the Skip Barber ISI Server with total of 3 drivers... no faults noted.
     
  16. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,707
    Likes Received:
    629
    I can second that... Thanks for racing, Randy :)
     

Share This Page