Rfactor 2 won't recognize my NVIDIA.

Discussion in 'Technical & Support' started by Alexxx0, Apr 21, 2017.

  1. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    I've tried everything,nothing worked. When I open the rf Config from Bin32, I can select my NVIDIA. But when I open the game with the launcher and go to video settings, I can't. It shows Intel. When I try to change it in the game,I can't change the Intel to NVIDIA. What should I do ? I already set the whole Rfactor and even Steam folder to use NVIDIA in the control panel. Thanks for your help!
     
  2. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Hi and welcome!
    I would disable the internal Intel HD graphics in BIOS. Best way!
     
  3. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Hi. Can you help me with that? I can't find any option in my BIOS that says that I can disable the Intel card. Maybe because it's my primary graphics card ?
     
  4. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    What means "primary graphics card"? I hope you conected your monitor to the Nvidia card!?
    By the way: PC specs are interesting as well here. Would be helpful if you write down
    Windows version, graphics card, CPU, mainboard and RAM.
     
  5. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    I have a laptop, so I think the monitor is connected to the Intel.

    Alienware 14

    Ram : 16 GB
    CPU : 4th gen Intel core I7 - Intel Core i7-6700HQ (Quad-Core, 6MB Cache, up to 3.5GHz w/ Turbo Boost)
    Graphics card :
    - Integrated : Intel HD Graphics 4600
    - NVIDIA GeForce GTX 765 M
    Windows 8.1
     
  6. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
  7. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    I could solve it. I had to reinstall the drivers, I couldn't use the Fn + F5 before,but now I can finally.
    I can now run the game with my Nvidia,but I still have problems.
    I auto-assigned the fps to be 60. But the FPS still goes up to 100-120. My screen is tearing,the cars are lagging (singleplayer-this might be the tearing,I'm not sure). And the game freezer for a second like every minute. What should I do ? I think my laptop is good enough to run this game on decent graphics without lagging.
     
    CamiloNino likes this.
  8. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Where did you auto-assigned the 60 fps? Important question!

    For lag and stuttering try the following:
    Go to Nvidia control panel (right click on desktop), choose 3D settings, choose rfactor2 and set
    maximum pre-rendered frames to "1"
    Might help.
     
  9. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    which file should I change ? rf config or rfactor ? bin32 or bin64 folder ? or the whole rfactor folder ?

    I solved the tearing with changing the sync to video
     
  10. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Wait, wait! One step after the other!
    Where did you "auto-assigned"?
    Is the panel G-sync? Edit: No, I thnk it isnt. Then I would avoid sync.
     
  11. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    I
    I opened the video settings from the launcher
     
  12. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    No,it's just ,,Sync''
     
  13. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    OK. No the thing in the launcher isnt a cap function.
    In nvidia control panel 3D settings, programs choose rfactor2 exe.
    Dont sync in launcher config! (not for now) Syncing will add lag.
     
  14. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Okay. Set Sync to none.
     
  15. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Now do the maximum pre-rendered frames to "1" thingy
     
  16. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Okay. Ready
     
  17. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Any better now? Please test without any AI alone on the track.
    You must set AI in session properties from main menu in game.
     
  18. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Okay,the screen tearing is back after turning off Sync. The car still lags. It seems like the wheels want to jump off the suspension,like the car wants to reposition itself (all driving aids are disabled !)
     
  19. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    umpf! Strange. What car, what track? Any mods/plugins installed?

    Tearing is the last and easiest thing you should solve.
     
  20. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Barcelona (downloaded) with ISI F1 2012 cars. Trackmap plugin downloaded
     

Share This Page