[Official] DX9 vs DX11 performance difference

Discussion in 'Technical & Support' started by 4thworld, May 4, 2017.

Thread Status:
Not open for further replies.
  1. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    212
    Likes Received:
    912
    Let's keep it structured:

    • Run the DX9 branch using a uitility like FRAPS benchmark mode.
      Record a section of gameplay in benchmark mode (pressing F11).
    • Switch to DX11 make sure to be in the v1108-dx11-open-beta branch (the one with the latest updates).Do the same thing (same car, track, same conditions, etc..) with DX11, and record in benchmark mode the same situation with FRAPS.
    Use same graphics settings, MAKE SURE POST PROCESSING IS SET TO NONE IN DX11.
    Please post attaching the benchmark files if your frame rate in DX11 is lower than the one in DX9.
    We will investigate the specific issues from there.

    In DX11 build if you can attach also the perf log.

    Thanks a lot.
     
    Last edited: May 4, 2017
  2. Mulero

    Mulero Registered

    Joined:
    Jan 16, 2012
    Messages:
    347
    Likes Received:
    146
    Switching between DX9 and DX11 is a small problem since you have to download 3GB at a time.
    Luckily I did a few benchmarks to compare before upgrading to DX11.

    Track: Nola
    Car: Indycar
    Resolution: 1920 * 1080, All to Max, 35 FOV
    AA: Level 8 in DX9, Level 5 in DX11 (no PP)
    Conditions: 1 full lap from the finish line to the finish line.

    https://drive.google.com/file/d/0B_rUPpnzorzXVnZIamhUMTdVUW8/view?usp=sharing
     
  3. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    212
    Likes Received:
    912
    @Mulero ok that's perfect thanks, as i told you in the previous thread i think there's something wrong with your CPU timings
    You're not the only one that has this issue, but they all have AMD processors.
    Since we changed the scheduling in the past updates i'll set the ability to have the new thread scheduling or keep the old one.
    The default option will be the old one.
    Let me know after i post the new build.
     
  4. Proscribo

    Proscribo Registered

    Joined:
    Nov 16, 2013
    Messages:
    6
    Likes Received:
    0
    Uploaded all fraps data and perflog of the DX11 run (it's a bit longer than what I set for fraps).
    One lap at silverstone international, USF2000, 15 AI cars. AA level 3 on both and rest max (except shadows medium and shadow blur optimal), PP off.

    I have i5 2500K @ 4,7GHz so maybe there's problems with intel too (or it is a different problem)?
     

    Attached Files:

  5. ChalkyWIS

    ChalkyWIS Registered

    Joined:
    Sep 14, 2016
    Messages:
    10
    Likes Received:
    2
    USF2000 (21 AI) rolling start at Silverstone International starting at the back. Stopped at Village and let the AI run off both times, to get a bit without other cars.
    CPU: Intel i5-6600K @ 3.5GHz
    GPU: AMD R9 Fury 4096MB (Radeon Software Version 17.4.4)
    Run maxed out on everything AA @ x8 on DX9 and x5 on DX11
    Post Effects = None on DX11
    Resolution: 2048x1152

    This build is a vast improvement on the 'stable' release that had around 35FPS in the same situation.
     

    Attached Files:

  6. Gijs van Elderen

    Gijs van Elderen Member

    Joined:
    May 1, 2014
    Messages:
    1,396
    Likes Received:
    451
    GPU: GTX Titan Black
    CPU: i5-3570K @ 5.10 GHz

    5760 x 1080 : Multiview

    DX 9 AA level 6
    DX11 AA level 3, EPostProcessingSettings=1 //None
    DX11_2 AA Level 0, EPostProcessingSettings=0 //OFF
    20170504224217_1.jpg


    DX9:
    Code:
    Frames, Time (ms), Min, Max, Avg
      4217,     60000,  56,  72, 70.283
    
    DX11:
    Code:
    Frames, Time (ms), Min, Max, Avg
      2900,     60000,  38,  52, 48.333
    
    DX11_2: AA OFF and PP OFF
    Code:
    Frames, Time (ms), Min, Max, Avg
      3472,     60000,  45,  62, 57.867
    
     

    Attached Files:

    Last edited: May 4, 2017
  7. kimbo

    kimbo Registered

    Joined:
    Jan 16, 2016
    Messages:
    105
    Likes Received:
    141
    don t work for me, dx9 130-100 fps, dx11 with several settings between 70-54 max - 30-12 min
    amd fx8350 - 8gb ram - r9 270x.
    back to dx9
     
  8. kiko0602

    kiko0602 Registered

    Joined:
    Dec 25, 2011
    Messages:
    235
    Likes Received:
    24
    same settings in dx9&11 with no pp in dx11

    -dx9 in garage 144 fps on track from 130 to 180+ AA level 8

    -dx11 in garage 68 fps on track from 65 to 80 AA level 5
     

    Attached Files:

    Last edited: May 4, 2017
  9. hitm4k3r

    hitm4k3r Registered

    Joined:
    Jun 15, 2016
    Messages:
    448
    Likes Received:
    834
    GPU: GTX 770, CPU: Phenom II X4 955 @ 3.2 GHz, 1440x900, Win 7 64bit

    Running DW12 at Indy with 9 AI, same time and similar weather scripting (default), 9 AI cars (even if that doesn't make a big difference in both version for me)
     

    Attached Files:

  10. BoothJoe

    BoothJoe Registered

    Joined:
    Oct 12, 2015
    Messages:
    202
    Likes Received:
    8
    I7 4770 with 24G RAM, sapphire rx480 8gb. USF2000 at NOLA in Dx9 about 130 FPS. Same car, same track DX11...less than 40FPS with None. I'm back to Dx9. Disappointed.
     

    Attached Files:

  11. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,389
  12. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,389
    I just downloaded latest unstable and it has got worse. Check updated image.

    Besides, rFconfig is not correctly detecting my GPU.
    It is assigning a differenf VideoGUID compared to dx9 builds (1108 and 1098).
    DX11 - VideoGUID=00001247-0000-0000-0000-000000000000
    DX9 - VideoGUID=D7B78E66-4256-11CF-0E6C-5D00B3C2DB35.
    this provokes a very weird behaviour:
    - Fullscreen does not scale to fit when using differente resolutions to the native one.
    - Alt Tab does not work. rF2 stays on top of everyhting until you terminate it.

    Thanks for recognising and addresing these issues

    upload_2017-5-5_2-20-10.png
     

    Attached Files:

    ECAR_Tracks likes this.
  13. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    212
    Likes Received:
    912
    Hi guys, thanks for the report, we're working on it, the next update will be available soon.
    Can i ask you to keep the conversation structured as i instructed in the first post?

    This would help me getting a better signal from your feedback!
    If you want to add something to your previous post edit it instead of posting again.
    I will remove the posts that didn't followed the structure required at the beginning of the post, nothing personal.
    thanks a lot!
     
    Last edited: May 5, 2017
  14. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    212
    Likes Received:
    912
    I just released an update, this has "Aggressive Threading" turned off.
    @Mulero this might help users like yourself, give it a test leaving "Aggressive Threading" turned off (don't change the default value of the config.exe)
     
    vegaguy5555 likes this.
  15. gor

    gor Registered

    Joined:
    Apr 4, 2015
    Messages:
    43
    Likes Received:
    5
    Can you explain AA level differences between dx9 and dx11?
    For dx11 it is a cutoff 6-8 or re-scale 0-8 to 0-5?
    Its very important to know before give a feedback here coz AA has huge impact.

    upd. i just read your answer, ty. I think its a good idea to add this info to first post. Ty again!
     
    Last edited: May 5, 2017
  16. patchedupdemon

    patchedupdemon Registered

    Joined:
    Jan 3, 2017
    Messages:
    1,394
    Likes Received:
    899
    Where can I find the build number,all I see is dx11 beta and dx11 last stable
     
  17. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    212
    Likes Received:
    912
    @gor , @patchedupdemon we need to keep this report section structured, as i said before.
    the build id you can find it inside steam->right click rfactor2->properties->local files->current content build id,
    ONCE you're in a steam beta branch.

    @gor , in dx11 we have a different scale of AA, what we want is for you having the same performance when setting the same "Level" of AA in the options.

    I will delete your posts shortly after this, if you need to ask questions that do not follow this thread structure, please do it in another thread,
    thanks a lot
     
    gor likes this.
  18. Proscribo

    Proscribo Registered

    Joined:
    Nov 16, 2013
    Messages:
    6
    Likes Received:
    0
    Improved! I tested with both aggressive set on and off and oddly, there wasn't too much difference, except that with aggressive setting one thread is still at 100% almost all the time. Same settings and setup as yesterday, so not quite DX9 numbers yet.
     

    Attached Files:

  19. Ferrari64

    Ferrari64 Registered

    Joined:
    Nov 3, 2011
    Messages:
    25
    Likes Received:
    0
    Track: Indianapolis Oval
    Car: Indycar
    Resolution: 6010 * 1080
    Ingame Settings: All to Max
    AA DX9: Level 1
    AA DX11: Level 1 no PP
    Conditions: 1 full lap from the finish line to the finish line.

    DX9 BuildID: 1796904
    DX11 BuildID: 1802039

    https://docs.google.com/spreadsheets/d/1KWcaI0qUE8NoSO1N772bw_sIE_KcpnlrfC6WU2-QW7M/edit?usp=sharing

    I am surprised about my DX11 benchmark because even that the FPS is compareable to DX9, the game feels so much worser in terms of performance. My Steering Input is 2 or 3 tenth of the second delayed even my FFB feels a couple of tenth off. In DX9 my input is instant. My FFB is spot on and if I turn my steering wheel the game reacts immediatly. In DX11 everything feels more like "Slow-Motion".

    My Computer:
    Nvidia Driver 378.92
    | CPU: Intel Core i7 3770K @ 4,2GHz | 1 GPU: GeForceĀ® GTX 1070 G1 Gaming 8G
    | RAM: 2x8GB @ 1600 MHz| OS: Win 10 Home 64bit Version 1703 (Build 15063.250)
    | Sound: Creative Soundblaster Recon3D
    | Wheel: Fanatec Porsche 911 GT3 RS V2 | Pedals: Clubsport Pedals V1 | Shifter: Thrustmaster TH8A
    | Monitor: Samsung SyncMaster BX2331 + 2x Samsung SyncMaster S23B300 (Triple Screen 6010x1080)
     

    Attached Files:

  20. demerzel

    demerzel Registered

    Joined:
    Aug 30, 2015
    Messages:
    197
    Likes Received:
    127
    By your request I did the performance check:

    Silverstone international 15 USF2000 ai + me at the last position. Sunny without clouds weather.
    No pp in dx11. And LVL 1 AA.

    I also attached the graphics settings.

    NVIDIA GTX 1050 TI GPU.
    AMD FX 6300 CPU
    8Gb ram.
    Windows 10.
     

    Attached Files:

Thread Status:
Not open for further replies.

Share This Page