My Modding Notes using Opensource & Free software

Discussion in 'Modding' started by svictor, Dec 24, 2021.

  1. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Thanks,
    Now It crashes right at the start but if I set frame count to 1 it loads but no animation.
    Here is the json file Im using now, with IBL shader. Cheers
     

    Attached Files:

  2. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    899
    Likes Received:
    6,165
    the file is missing "SkipFrame0":false, line, which is important and must have, otherwise will crash (see the guide post from previous page). Also, if this value is false, you must provide TEXTURE00.dds; else if it is true, then game will read sequence start with TEXTURE01.DDS
     
  3. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    899
    Likes Received:
    6,165
    Also, the texture name in JSON is wrong, you should not write frame index, as game will do that for you:
    "Texture":"WaterNorm_00",


    So, it should be changed to following:

    "MipBias":0,
    "MipLevels":-1,
    "Name":"normalMap",
    "ShaderPass":0,
    "ShadowMipBias":0,
    "SkipFrame0":false,
    "StageType":"CUBETST_LINEAR",
    "TexChannel":4,
    "Texture":"WaterNorm_",
    "hasDefault":true,
    "inactive":false,
    "runtime":false
     
    philrob likes this.
  4. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Thanks, Still does not work, here is the error message with updated json
     

    Attached Files:

  5. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Another thing is Im using PNG file is that okay or should it be DDS?
     
  6. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    899
    Likes Received:
    6,165
    Looks like you are missing some essential setting:

    1. Add this line to your SCN file just below SearchPath (must point to a valid folder where stores your JSON file):
    MaterialPath=YourTrackName\ASSETS\Materials

    2. Make absolutely sure that all water textures are located in a folder that is referenced by track's SCN. Game will not find texture if you put them elsewhere. And yes, convert png to dds, IBL shader support old DXT1 DXT5, so you can use those old format if that is more convenient for testing (official mapconverter is easy to use as well).

    3. "name":"WATER", this red text must match the material name that you set in GMT.
    ---------------
    And your json file has duplicated code (line 247 to 249):
    "MipBias":0,
    "MipLevels":-1,
    "Name":"normalMap",

    which already exist in line 181 to 183.

    Last, I would suggest to try & test track in DevMode instead of using Viewer.
     
    Last edited: May 11, 2022
    philrob likes this.
  7. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    899
    Likes Received:
    6,165
    I have just tested water animation using your last JSON file(replaced textures with my dds files, and removed duplicated code), and works perfectly. So there is no issue with JSON (after removed duplicated code). You probably need to double check Viewer setting/SCN file/texture format.
     
  8. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    I just got the heli rotors animation working :)
    and it was the texture, strange that the texture name is heli_rotor01.dds
    but it was looking for heli_rotor0001as indicated by the error message. Everywhere it is heli_rotor01.dds from max to the viewer
    and even the materials editor, but when played in the viewer, it was looking for heli_rotor0001.dds
    Again thanks for your help, much appreciated.
    Also thanks for all the information you provided in the modding notes :)
     
    svictor likes this.
  9. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    I also got the water plane animation working too, Thank you :)
     
    Woodee and svictor like this.
  10. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    I thought you may be interested in what track Ive Created;
    2000 - released adelaide street circuit for Sports Car GT

    2003 - upgraded it for F1 Challenge
    Link

    Currently the Adelaide track for RFactor 1 and 2 and Also Assetto Corso are upgrades of my track by modders.
    Cheers
     
    svictor likes this.
  11. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Hi Again, Sorry to bother you, just another favour, wondering if you would have a working max 2012 plugin that doesn't corrupt the meshes on export and opens up in GJed?
    Mine is dated 211120 and the current one doesnt work either. Thank you
     
  12. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    899
    Likes Received:
    6,165
    Hi, sorry I don't have and never used 3dsmax. Have you tried to export object as FBX? As Gjed and many other software support FBX import.
     
  13. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Thanks thats fine, Ive done that with Assetto Corsa using fbx. I just preferred the workflow with Max, Cheers
     
  14. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,874
    Likes Received:
    2,681
    Here are the ones (64 bit) that i use and that still work, even if you sometimes get some "Error" Messages, that can be avoided by proper Mapping in most of the Cases.
    Try out, if they work for you too.
     

    Attached Files:

    Corti likes this.
  15. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Thanks for that much appreciated. Ive tried it and its the same outcome; GJed crashes. Im looking for a version that was prior to 2020.
    Anyways the work around is to load the gmt into 3DSimed and export as RF2 gmt and then it work fine in GJed. cheers
     
    svictor likes this.
  16. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,339
    Likes Received:
    2,471
    i have gJED v840...
     

    Attached Files:

    svictor likes this.
  17. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Okay thank you.
     
    Corti likes this.
  18. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,339
    Likes Received:
    2,471
  19. Wizzo58

    Wizzo58 Registered

    Joined:
    Apr 15, 2022
    Messages:
    40
    Likes Received:
    23
    Okay thank you, Ive got that version, cheers
     
    Corti likes this.
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,874
    Likes Received:
    2,681
    In the Past i did make some Backups of former Plugin Versions, maybe you can find a working one there. ;)
    Here is the DOWNLOAD (File is too big to upload it here).
     
    Corti and svictor like this.

Share This Page