[REL] Latest Release Candidate - June 2021

Discussion in 'News & Notifications' started by Christopher Elliott, Jun 10, 2021.

  1. 3NPV5IRR

    3NPV5IRR Registered

    Joined:
    Feb 27, 2014
    Messages:
    99
    Likes Received:
    45
    Unfortunately, with the new RC my FPS dropped down from stable 90 to lower than 50 in WMR even with one car without rain. This makes RF2 practically unplayable. I tried several combination of the official content. I also tried cleaning shaders and cbash folders, checked integrity of files. Nothing helped. I used to play with almost everything on "off" in video settings, so left the video setting unchanged. As soon as I returned to stable built I got stable 90 FPS as usual.
    My specs: AMD Rysen 5 5600X @4.8GHz, Asus GTX 1080Ti @ 1796 MHz, 16GB RAM, SSD, WMR helmet - Lenovo Explorer, Windows 10 with all the latest updates.

    EDIT: Deleting player.json solved FPS problem. If I find time I'll try to investigate it further.

    EDIT2: This was the only line of Player.json causing the FPS drastic drop: ""Max Framerate":92,". Returning the value to "0" solved it. In previous builds it helped not to overload too much GPU.
     
    Last edited: Jun 11, 2021
  2. Bernat

    Bernat Registered

    Joined:
    Jun 15, 2020
    Messages:
    26
    Likes Received:
    17
    I've just done two races and in the second one I also got very low FPS but I think it was because rF2 was using all my memory and some swap. Can you check if it's the same for you? I also have 16GB RAM.
     
  3. leseb64

    leseb64 Registered

    Joined:
    Jul 6, 2020
    Messages:
    143
    Likes Received:
    397
    Dady Cairo likes this.
  4. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,261
    Likes Received:
    1,209
    i have tested in portland, lemans, silverstone, with the bmw gt3 gte ferrari gte, and the engine sounds are choppy, no continuous sound is heard
    I have checked file cache and it doesn't work:(:confused:
    I go back to the previous candidate, until it is solved
     
  5. 3NPV5IRR

    3NPV5IRR Registered

    Joined:
    Feb 27, 2014
    Messages:
    99
    Likes Received:
    45
    My SWAP is 24 GB, so I doubt it could be a bottleneck in my case. Moreover, since I play with very low graphic settings my 16 GB of RAM should be enough at least I never had such problems before.
    I solved my FPS issue by deleting player.json file.
     
    juanchioooo likes this.
  6. bo1210

    bo1210 Registered

    Joined:
    May 6, 2018
    Messages:
    58
    Likes Received:
    15
    Ran the update for dedi server, and while it is now an executable dated June 10, client PCs still see it as 1124.
     
  7. justposted

    justposted Registered

    Joined:
    Oct 14, 2020
    Messages:
    57
    Likes Received:
    36
    The wet road effect is certainly massively improved now. Much more convincing to see reflections rather than an apparantly dry road with spray from the wheels, like before. Just need a few more puddles on the track to give it that final tweak to realism. Dry line and dry streaks behind moving cars are great.

    Nice work S397.
     
  8. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,261
    Likes Received:
    1,209
    remove player json has solved all the problems:)
     
  9. bo1210

    bo1210 Registered

    Joined:
    May 6, 2018
    Messages:
    58
    Likes Received:
    15
    Not mine. Deleted it and the box that allows you to select the car/track combo pops up for about 2 seconds, then disappears.
     
    juanchioooo likes this.
  10. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,059
    Likes Received:
    736
    What was the command you used to update the server?
     
  11. bo1210

    bo1210 Registered

    Joined:
    May 6, 2018
    Messages:
    58
    Likes Received:
    15
    "steamcmd +login anonymous +force_install_dir ../rFactor2-Dedicated +app_update 400300 +quit"

    For the record, now I don't even get the box to select the car/track combo. Now it says rFactor 2 UI missing:

    "Core component rFactor2 UI v1.0 is missing, invalid, or damaged. Unable to continue. Please reinstall rFactor 2."
     
    Last edited: Jun 11, 2021
  12. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,059
    Likes Received:
    736
    That'll get you the stable build ie v1124, if you want the release candidate build ie v1125 then use;
    Code:
    "steamcmd +login anonymous +force_install_dir ../rFactor2-Dedicated +app_update 400300 -beta release-candidate validate +quit"
     
    Peter Stefani and bo1210 like this.
  13. Bernat

    Bernat Registered

    Joined:
    Jun 15, 2020
    Messages:
    26
    Likes Received:
    17
    Is it completely gone or can you still compare the old and the new one to see which settings cause the problems?
     
  14. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,261
    Likes Received:
    1,209
    I was referring to the intermittent audio interruption, the FPS is not doing so well, I was doing better before but I still have to continue testing
     
  15. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,530
    Likes Received:
    7,382
    Agree, if you have any old files that caused an issue we'd like to see those :)
     
  16. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,530
    Likes Received:
    7,382
    How high do you have reflections set?
     
    juanchioooo likes this.
  17. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,261
    Likes Received:
    1,209
    I use an I5 8600k without OC, a 1080ti and a pimax 9k plus, I go around 80, 85 fps after having eliminated the json player, in a high graphics configuration
    Thank you very much for the notice to delete the json, which helped me in the sound corruption of the intermittent engine, all the other sounds were heard well except the engine
    Once again, thank you very much:);)
     
  18. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,261
    Likes Received:
    1,209
    It was high by default and I have set it to low, and shadows to low, to gain some fps, with parallel projection activated for the Pimax 8k plus
    I was using the previous candidate so the fps loss I did not understand, in any case we continue to fight in the tests:);)

    eye, I was comparing at the Lemans circuit, the officer evidently
    remove json player has resolved all sound issues
     
    Last edited: Jun 11, 2021
  19. Luprosx

    Luprosx Registered

    Joined:
    Apr 6, 2013
    Messages:
    97
    Likes Received:
    54
    @Elliott
    We're you joining a server?
    ... I drive offline
    Reloaded today
    -Steam
    -rF2 start
    -488GT3 and GT3 and Sebring
    -no customize used
    Load first: 2.08 min
    2. load: 1.52
    Is just okay!
     
  20. leseb64

    leseb64 Registered

    Joined:
    Jul 6, 2020
    Messages:
    143
    Likes Received:
    397
    Now that the graphics are more than correct (not the best but still very good) I would like to see, like many others, real innovation in a simulation worthy of the name, namely the minimum:
    track temperature with an impact on the tyres, air temperature with an impact on the tyres, rain with an impact on the track and tyre temperature, transmission, engine protection, functional clutch, damage, more realistic mechanics, flat tire, sound and steering wheel redesign, cocpit, dash...in short, there's a lot of work to do and I'm forgetting!
     
    Rony1984, Pawel44, Hazi and 3 others like this.

Share This Page