IS NVIDIA Image Quality A Joke, Or Is It Just Me

Discussion in 'General Discussion' started by Spinelli, Mar 8, 2014.

  1. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    In my recent experience vSync induced latency is far, far lower on nVidia than AMD and can be minimised by setting max pre-rendered frames to 1.

    Sent from my GT-I9300 using Tapatalk
     
  2. Barf Factor

    Barf Factor Registered

    Joined:
    Nov 2, 2012
    Messages:
    397
    Likes Received:
    2
    Thanks for this info, I have also switched to nvidia and this has saved the day.
     
  3. YoLolo69

    YoLolo69 Registered

    Joined:
    May 28, 2012
    Messages:
    978
    Likes Received:
    6
    I'm not sensitive to input lag when a game run at least at 60fps, I guess each person have different feeling about this. For me the game reacting at least 60 time per second to my inputs is enough, and I guess my human configuration (brain, muscle, etc.) automatically adapt to this ;) No effort to make.

    Without Vsync, the fps fluctuate too much, and that induce lot of screen tearings, because the game want to display E.g. 140 frame in a monitor which can only handle 60 (in my case). This is not a problem when going straight, but as soon as you are in a curve, so the background is scrolling from a side to another, not be capped to monitor induce too much stuttering and irregular movement of the background.

    Smoothing the screen is really important for me, and another big advantage of Vsync is avoiding overheating of my system. Capping to 60fps and my CPU and GPU can take some rest waiting for the next frame to compute/display. My CPU and GPU don't run at maximum speed and stay a lot cooler. Having CPU and GPU computing 140 time per second a picture I will not really see (at least not entirely) cause my screen can't display at that speed is useless for me (as I'm not sensitive to 60Hz input lag or adapt myself naturally) and overheat them.
     
  4. Spinelli

    Spinelli Banned

    Joined:
    Jan 28, 2012
    Messages:
    5,290
    Likes Received:
    31
    YoLolo69, have you tried disabling vsync all together but using a framerate limiter to stop the fps from going over 60? You can set it to 60 in you RFactor PLR file. You can also use your nvidia driver control panel, nvidia inspector (same as control panel), dxtory, afterburner, and I believe precision x as well.
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,004
    Likes Received:
    4,131
    After battling with settings trying to get smooth 60fps I've resorted to limiting the framerate to 30 in the PLR. Doesn't look as smooth of course, purely because at 30fps each frame is more visible, but it holds steady and makes speed easier to judge. My ageing PC trying to do 60 was at times giving me inconsistent frame rates, which more than anything else actually made it hard to judge speed. So now it looks 'worse' but drives better.

    As far as lag/delay goes, I'm probably at least as reliant on sound and FFB as I am on visuals, so it makes little difference. The game still runs the physics, sound, and FFB at full speed regardless.
     
  6. YoLolo69

    YoLolo69 Registered

    Joined:
    May 28, 2012
    Messages:
    978
    Likes Received:
    6
    Never tried, I will.

    BTW, how the frequency will be synchronized with the raster of my monitor without a vsync call? I mean: if I say limit to 60fps, it will be synchronized with my 60Hz? Vsync do this, and if nothing do the link between the raster of my monitor at 60Hz and the game display loop 60 time per second it could induce a permanent tearing on my screen if both are "shifted", no? I'm just asking, I'm not aware what will happen, need to try ;)

    Edit: Ok, it took 5 minutes to test this: With Max Framerate set to 60 and removed vsync, fps displayed to verify it's capped to 60, I have a constant tearing, always at the same place on the screen, it was nearly at the middle, I guess position will vary each time I enter a race. Sound logical to me, my screen run at 60Hz, the game run at 60 loop, and nothing make the link not even at the start, so it's bad. At least I tried ;)

    Edit2: I'll try with other program as I just tried with the .PLR, perhaps other are smarter? ;)
     
    Last edited by a moderator: Mar 13, 2014
  7. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    409
    Likes Received:
    11
    Have you tried setting the Sync option of rFactor 2's Config Program to "Video"? I have no tearing problems anymore, no performance issues and virtually no input lag. I'm using a 120Hz monitor though.
     
  8. smbrm

    smbrm Registered

    Joined:
    Nov 11, 2010
    Messages:
    430
    Likes Received:
    47
    Sounds like the discussion of appropriate settings for 60hz monitors vs. >= 120hz might be of value?

    Which is more appropriate for Rf2 and how does one maximize the performance with each?
     
  9. YoLolo69

    YoLolo69 Registered

    Joined:
    May 28, 2012
    Messages:
    978
    Likes Received:
    6

    Just tested Vsync set to Video: it works, fps are capped to 60, and no tearing. Now the one million question: what is the advantage of using Vsync set to video versus usual Vsync? I don't see any difference on screen or on input lag? That's sound like the game is only displayed 60 times per second in both case, and my input is also take in account at the same rate, so what could be the advantage? And in other words: what this setting do exactly? I Advanced Searched a thread explaining this without success (I'm pretty sure I saw one long time ago). If Vsync GPU (I guess the usual method) and Vsync Video exist it should act differently, even if result seems the same...

    Now with a 120Hz monitor and if you can feedit it at that rate (cpu and gpu power enough) I understand you should have a better experience regarding smoothing and input lag, lucky guy! :)

    Edit: Oopps, we are OT, sorry about that
     
  10. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    VSync set to video is normal vSync.

    Sent from my GT-I9300 using Tapatalk
     
  11. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    409
    Likes Received:
    11
    I think it's more like adaptive VSync, no?

    With regular VSync, using a, let's say, 60Hz monitor, you would cap your framerate at 60fps if possible. When your framerate is below 60, it will instantly drop to 30 (because VSync makes the graphics card send the last frame to the monitor again because the next frame wasn't completely rendered/ready yet -> doubled rendertime per frame). So your framerate is cut in half as soon as your graphics card can't churn out 60fps. If it's even below 30, it'll drop to 20 (a third of 60), then to 15(a fourth of 60), 12, 10 and so on. Adaptive VSync simply gets "disabled" as soon as you drop below your monitor's refresh rate.

    If the "Video" Sync option would be identical to regular VSync, I shouldn't get framerates like 100 or 110, which I do when using it. :)
    What's strange though is that I get no tearing even when I don't have 120fps capped. Unlike using no Sync at all, where I get lots of tearing.
     
  12. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    Video sync is normal vSync, I think if adaptive is enabled in nV CP then it'll be adaptive, if not then it won't.

    Sent from my GT-I9300 using Tapatalk
     
  13. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    409
    Likes Received:
    11
    I haven't set adaptive VSync in the control panel, but I'm definitely getting unusual framerates which are not possible with regular VSync.
     
  14. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    What are you monitoring frame rates with? It's possible even with standard vSync to see what looks like non even divisors of refresh rate, to be sure you need to look at a log of individual frame times. Most onscreen frame rate monitoring mechanisms are reporting the average frame rate over x number of frames.

    Edit: not sure divisors is the right word, I'm in bed and minutes away from sleep. Night all!

    Sent from my GT-I9300 using Tapatalk
     
  15. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    541
    Likes Received:
    63
    Well alt + m is the answer I was looking for.
    No more messing about with inspector.
    I just set graphics up in RF2 and press alt + m and everything looks fantastic even in triple screens :)

    Really need to be able to set this either in game or plr file.

    Thank you

    Sent from my SM-N9005 using Tapatalk
     
  16. Spinelli

    Spinelli Banned

    Joined:
    Jan 28, 2012
    Messages:
    5,290
    Likes Received:
    31
    Maybe try a number between 50 and 70, sometimes it takes a few fps from your refresh rate to minimize tearing.

    With 3 displayport adapters plugged into my matrix 7970 I never had tearing no matter my framerate. I dont understand what made this card/drivers so special that made all tearing completely 100% disappear.
     
    Last edited by a moderator: Mar 14, 2014
  17. simRAYcing

    simRAYcing Registered

    Joined:
    Sep 14, 2013
    Messages:
    21
    Likes Received:
    0
    Can u guys please stop talking chinese and explain that **** to me? :DD
     
  18. kimikaze

    kimikaze Registered

    Joined:
    Feb 17, 2011
    Messages:
    650
    Likes Received:
    23
    Leave Max framerate to 60, and try set "Steady Framerate Thresh" to 0.00000(default is 0.00100).
    Also try first both parameter without vsync and then with.
     
  19. Spinelli

    Spinelli Banned

    Joined:
    Jan 28, 2012
    Messages:
    5,290
    Likes Received:
    31
    AMD or NVidia?
     
  20. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    409
    Likes Received:
    11
    Nvidia of course -> CLICKY

    It's the exact same issue as in rFactor 2. Wrong, oversharpened LOD settings. The AA works perfectly fine, but it can't correct wrong texture filtering.
    And setting the "Negative LOD-Bias" to "Clamp" (which would prevent using negative LOD values for texture filtering and replace them with 0.0) in the control panel doesn't work anymore with newer GPUs apparently. See the screenshots in my link for reference.
     

Share This Page