Surround sound messed up

Discussion in 'Technical & Support' started by shushkata, Jul 3, 2021.

  1. shushkata

    shushkata Registered

    Joined:
    Jul 7, 2020
    Messages:
    39
    Likes Received:
    8
    Hi there, i newly got me a sound Blaster Z card and installed 4 speakers on my rig. I have configured them as 4.0 speakers in the Sound Card's control settings and in RF I put the same. Initially, when i start the car i hear sound from all speakers, as it's normal to be. But as soon as i start driving i start loosing the rear speakers - they go on and off. I found out, that running the new BWM Class 1 car on Monza, hitting a curb makes the sound disappear momentarily. Than after several second (it's totally random) it reappears.

    I know that my setup is working fine, as i have tested it with other sims (ACC and RaceRoom). Can someone help me with it. I have tried the stable and the latest RC builds, but the problem stays the same. I have only one MOD installed, a telemetry one, that exports data to a file (have not tried removing it, as it sound unlikely to be related )

    Add:
    I have narrowed the problem to engine sound. It's on and off, but somehow persistent trough a lap at Monza. Every track is different of course.
     
    Last edited: Jul 3, 2021
  2. justposted

    justposted Registered

    Joined:
    Oct 14, 2020
    Messages:
    60
    Likes Received:
    38
  3. shushkata

    shushkata Registered

    Joined:
    Jul 7, 2020
    Messages:
    39
    Likes Received:
    8
    Unfortunately no, I have tested all sound related in the latest posts, deleted the player file, changed the max effects, even messed up in the json file itself, adding more buffer. Rear sound is just dropping off.
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,449
    Likes Received:
    4,470
    Haha :D

    For future reference and to avoid confusion, that's a plugin. A mod would normally refer to a car (in rF2).

    I haven't checked recently, but surround support has long been lacking in rF2. I'm nearly surprised you're hearing anything at all in the rear speakers.
     
  5. shushkata

    shushkata Registered

    Joined:
    Jul 7, 2020
    Messages:
    39
    Likes Received:
    8
    For a game that supports up to 8.1 speakers, my setup should work like a breeze:D
     
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,600
    Likes Received:
    2,549
    if it's engine noise from AI cars, that is actually performing correctly at this time. The AI jab and lift repeatedly through many corners. A well known and long running issue but that is how they are currently programed to navigate slower corners.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,449
    Likes Received:
    4,470
    It's listed those options in the settings for a long time, but last time I tried on my 4.0 setup I only had occasional sounds in the rear speakers, and that may only have been reverb off walls. That was several years ago so I probably need to test again to confirm, but what you're describing suggests nothing has changed.

    @davehenrie sorry to correct you, but that's an entirely different thing. We're talking specifically about sound from rear speakers here. I know "on and off" and "engine sound" were mentioned, which obviously matched one of your search filters, but this isn't about the AI throttle.
     
    Last edited: Jul 4, 2021
  8. shushkata

    shushkata Registered

    Joined:
    Jul 7, 2020
    Messages:
    39
    Likes Received:
    8
    Exactly as Lazza said, the broken is surround related, all the above mentioned problems also exist. It’s fascinating that the issue with surround dates so long back… It looks to me that the sound engine cannot process all the info it needs to output , like it’s buffer is constantly not enough and any other effect overload that system.
     
  9. shushkata

    shushkata Registered

    Joined:
    Jul 7, 2020
    Messages:
    39
    Likes Received:
    8
    Support is not really active around here, with all forums. Do we get real Dev support or i will need to write somewhere else. Will be really happy to report this problem. Funny enough in the actual Support Questions Thread you need special permission to post ? how stupid is this ...
     
  10. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,390
    Likes Received:
    1,455
    Or you could ask the reason and then it's possible that it wouldn't be so stupid ;)
     
  11. shushkata

    shushkata Registered

    Joined:
    Jul 7, 2020
    Messages:
    39
    Likes Received:
    8
    Don't quite follow what you mean by that ? Why is it reasonable to put the only real thing one can use, support, behind a wall ? I don't want to spam or something, i am even there to perform tests, give back data and so, so the devs can sort a problem in the game. I have searched trough the net and the surround sound support for this game is actually not exactly there (or working). I am not very amused by the fact that it's broken ....
     
    Last edited: Jul 5, 2021
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,449
    Likes Received:
    4,470
    @shushkata The Support subforum isn't magical - the same people see it. You'll see very few dev responses in there, same as here. There should be something in the game to contact support - used to be in the game launcher, but that's gone now. I've never looked for the support button in the new UI.

    Surround sound isn't broken as such. It was just never there. You could sit down in a room with the devs and give a PowerPoint presentation on your findings and I still wouldn't expect any movement on this in the next year or two. It's just not a focus; and there are many areas that need attention.

    I'd seriously suggest just throwing headphones on and do your best to ignore it.
     
    RaceNut and lagg like this.
  13. RaceNut

    RaceNut Registered

    Joined:
    May 21, 2013
    Messages:
    421
    Likes Received:
    371
    Surround sound has never worked properly in rF2 as far as I can recall. It's best to use the basic Stereo or Head-Phones profile. :(

    The Miles Sound Engine in rF2 may be an older version but, could benefit from some customization or complete replacement. In either case, it's not an easy task for developers and audio tends to lag far behind other issues with most game development.
    I suspect it's really a matter of priorities and having a very long to-do list for developers.
     

Share This Page