Software Wheel Rotation : not working ?

Discussion in 'General Discussion' started by Yzangard, Dec 6, 2018.

  1. Yzangard

    Yzangard Registered

    Joined:
    Dec 6, 2018
    Messages:
    37
    Likes Received:
    13
    Hello,

    I followed exactly the steps from https://www.studio-397.com/2018/11/roadmap-update-november-2018/ publication but it doesn't seem to work, at all. The default rotation reverts to some false value every time despite I save the modifications (game and launcher closed).

    Can someone explain very precisely how to use it ? Because right now I see no difference at all...
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,929
    Likes Received:
    3,424
    1. Go to your wheel configuration software, or the control panel -> controllers -> your wheel -> properties, and set the lock to its maximum value (you haven't said what your wheel is, but this is often 900 degrees).
    2. In your rF2 folder, go to UserData\player\ and open up the Controller.JSON file*
    3. Find "Steering Wheel Maximum Rotation Default” and set it to the same number of degrees as you set in step 1.
    4. Find “Steering Wheel Software Rotation" and set it to true.
    5. Find “Steering Wheel Maximum Rotation from Driver” and set it to false.
    6. Consider changing “Steering Wheel Bump Stop Harshness” to a higher value, like 50, so you can feel it better (the 'stop').
    Be sure to check which option you're changing - they all look quite similar so it's easy to change the wrong ones.

    *If you originally detected your wheel, or loaded a profile, and now you just load the game and play and sometimes make changes to the Controller.JSON, this will work fine. If you change wheels/controllers and detect/load different profiles each time, save those profiles to your own custom-named files and make the above changes to those files. Then when you load the profile those settings will already be there.

    If the above doesn't work still, please give more info (wheel type especially), and show a screenshot of the relevant part of your controller.JSON file. Also note the above regarding the profiles and files; try changing another obvious parameter in your controller.JSON to check that you're editing the right one.
     
  3. Yzangard

    Yzangard Registered

    Joined:
    Dec 6, 2018
    Messages:
    37
    Likes Received:
    13
    Oh, the point 5 was my mistake then, I set it to true

    I own a SimuCube Mige 30 to reply your question, so I don't have a precise maximum range, I set it to 900 or 1080 usually.

    Will test with the settings you gave and will report back.
     
  4. Yzangard

    Yzangard Registered

    Joined:
    Dec 6, 2018
    Messages:
    37
    Likes Received:
    13
    Ok, reporting back, it is working correctly now, thanks.
     

  5. Thank you, this seem to have solved my issue with the returning wheel rotation issue! :)
     
  6. Narrowbackwing

    Narrowbackwing Registered

    Joined:
    Jan 12, 2012
    Messages:
    425
    Likes Received:
    155
    Nice , that help me also .
     
  7. f14tmodding

    f14tmodding Registered

    Joined:
    May 17, 2016
    Messages:
    19
    Likes Received:
    1
    Hi everyone, sorry to come back here after such a long time without any message. Should it be the wrong place it to write and ask don't hesitate to tell me.

    I had troubles with my G29 wheel after downloading the complete game (the demo was perfect) as the steering wheel in game was not synchronized to mine, I had to turn much more, for example a LMP car steered like a real road car. I used this trick, it seemed to work but maybe even too much ! Now, the wheel in game turns more than my G29 wheel. It's not making it much more difficult to drive, but it's just not very realistic. Could someone help me to adjust this perfectly ? I must precise that's it's my first installation of the paid game after 2-3 days of testing the demo and not having any trouble (on a brand new Win 10 desktop with the latest Logitech software installed).

    Thanks in advance and have a nice day !
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,929
    Likes Received:
    3,424
    @f14tmodding If you set your wheel rotation in the profiler, and it's correct, and set the same degrees in the .json file (and it's the correct one), and you tick 'vehicle set' you should get the correct rotation matching the car. Beware of steering assistance (F1 in game I think), off the top of my head I'm not sure what other settings there are that can interfere but those are some to check first.
     
  9. f14tmodding

    f14tmodding Registered

    Joined:
    May 17, 2016
    Messages:
    19
    Likes Received:
    1
    In my profiler the rotation is set to 900° (default value so) and "vehcile set" is also ticked so I don't know what's going on. I also don't have any driving aid except autoclutch, but I"ll check again to be sure...
     
  10. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    365
    Likes Received:
    1,161
    Make sure you have the sensitivity set to 50% in the Logitech software otherwise it will never match the on screen wheel, it's an error I made by not having it set to 50%. 50% is the default setting. Hope this may be of help.
     
  11. f14tmodding

    f14tmodding Registered

    Joined:
    May 17, 2016
    Messages:
    19
    Likes Received:
    1
    You were right ! Indeed I was at 70% sensitivity in the profiler...but on the default settings ! I decreased it to 50, and now it's as it must be. But that surely means that rFactor 2 and the Logitech software don't work well together :D
     
    Emery likes this.
  12. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    365
    Likes Received:
    1,161
    Glad you got it sorted.
     
  13. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    127
    Likes Received:
    53
    @Lazza - thanks made a big difference for me using a G29.
     
  14. GameOne

    GameOne Registered

    Joined:
    Mar 26, 2014
    Messages:
    21
    Likes Received:
    0
    I have a Logitech G27 and the same problem when setting the values from the first post. The steering is simply way too fast, but I have no setting for sensitivity in the profiler. Please help
     
  15. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,929
    Likes Received:
    3,424
    Tell us exactly what all your settings are, if you want help.
     
  16. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    127
    Likes Received:
    53
    After update 1121 I have since reverted back to my original controller profiler. Prior to 1121, the tip that @Lazza suggested worked perfectly and solved my problems. But post 1121 I have gone back to my original controller profile and its now great.
     
  17. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,929
    Likes Received:
    3,424
    @buzz hornet there are various reasons for using this feature. In my case the game adjusts the rotation perfectly but also leaves the rotation changed in the control panel afterwards. For others it doesn't work properly at all, and that can vary between users (of the same wheel) and at different times. I would hope wheel support continually improves to reduce the need for this, but I link to my post in this thread when advising people to try it as the original instructions were not so clear.
     
  18. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    127
    Likes Received:
    53
    Understand, prior to the 1121 your settings where perfect for me - the best the wheel has ever felt. Then after the changes (1121) they made your settings just didn't work - it felt like the car was controlled and had some strange effects. I reverted back to my original settings and its now working nicely. But it gives people options for sure.
     
  19. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,929
    Likes Received:
    3,424
    It sounds like you had some other settings interfering - this is purely about your wheel rotation, doesn't affect feeling in any other way.
     
  20. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    127
    Likes Received:
    53
    For sure, it’s working wheel now and that’s what matters.
     

Share This Page