Single Large Freeze about 35/40 Minutes after joining a Server

Discussion in 'Bug Reports' started by MarcoSaupe, Apr 28, 2020.

  1. MarcoSaupe

    MarcoSaupe Registered

    Joined:
    Feb 11, 2012
    Messages:
    39
    Likes Received:
    10
    Hi

    as the title says, since about late 2019/early 2020 I get a single large freeze when racing online, and it always (well, at least I know that about the last couple of times) happens about 35-40 minutes after joining the server and it also seems to happen every single time. It's the kind of freeze, where your screen is frozen, but after a few seconds, when it moves again, your car has traveled further along the road, so on a straight you are fine. I usually join the servers for our league races early, so it mostly happens in practise, but 2 weeks ago I had the 3rd stint in a long distance race with driver swap, and so it happened in the race (on a straight fortunately). Also one time I was on the server early, left end rejoined after changing a graphic setting, and then it happend about 35 minutes after I rejoined. But it's only that one freeze, after that, it's fine even though I'm on the server for 4 more hours for some long distance events.
    The length of the freeze seems to depend on the number of cars and/or size of the track. Last week we had a Nordschleife race with 50 cars, there the freeze was the biggest I ever had at about 3-5 seconds, on other tracks with less cars it's shorter, 1-2 seconds. All the races I currently drive are with only S397 cars (GT3, LMP2, Tatuus for me, also GTE, M2 or Porsche Cup on the server). Tracks are some original, some 3rd party, I happens on all of them).
    In 2018 I regularly had similar freezes, though there I'm pretty sure it was not at that time interval since it happend in races a couple of times, but after one update late 18/early 19 they were gone, and I had no such freezes in 2019. But a while ago something must have changed...

    Win 10, Ryzen 2700X, GF1080, 16GB RAM, rF on SSD, Old UI
     
  2. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,565
    Likes Received:
    994
  3. RoWo

    RoWo Registered

    Joined:
    Jul 16, 2014
    Messages:
    313
    Likes Received:
    364
    I can confirm.
     
  4. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    571
    Likes Received:
    158
    Never had this problem before, suddenly it is a big problem...don't know what has changed (steam up? windows update? rf2 update?)...completely lost on this one...made a race unplayable. I thought it was network lag but it seems much more similar to this.
     
  5. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,565
    Likes Received:
    994
    In my case, this "35 minutes" freezing is happening from time to time for several months. It has happened with different NVidia drivers and versions of SteamVR.
    The rest has always been the same. I formatted my PC in december and only use it for rF2. The specs are fine (I7 7700, 2080TI, 16GB RAM, SSD disk for OS Steam and rF2). The accessories are the same as in recent years (Valve Index, OSW, HE Pedals, F1S Simulation). My Internet connection is 100 Mbs symmetric fiber optic, I don't use Wi-Fi and when I play there are no downloads or TV.
    I am the administrator of the rF2 servers and have verified the resources and those are fine. For example, yesterday we had a race with 33 drivers without lag, but this can happen to me with only two people in the server. Only a few people on our website have this error.
    In my case, freezing takes "only" a second or less. It is not as big as others have.
     
  6. MarcoSaupe

    MarcoSaupe Registered

    Joined:
    Feb 11, 2012
    Messages:
    39
    Likes Received:
    10
    Now that is interesting, I also found those steam dump files mentioned in the other thread and the timestamp matches the freezes exactly, e.g. assert_steam.exe_20200428193703_1.dmp
     
  7. Raynald

    Raynald Registered

    Joined:
    Jan 27, 2016
    Messages:
    6
    Likes Received:
    3
    I confirm me too ... :(:mad:
     
  8. M Lynn

    M Lynn Registered

    Joined:
    Aug 2, 2017
    Messages:
    45
    Likes Received:
    11
    Same for me, but it happens offline, I haven't tested enough online yet. Happens most commonly 30-35 minutes into a session, and it isn't car or track specific. I've had this problem at least since the end of last year, maybe longer. It usually isn't visible on a replay, but the screen freezes for a few seconds while the car carries on, usually into a barrier. I had one in January that lasted 44 seconds!
     
  9. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,565
    Likes Received:
    994
    Yes i think that for me is the same.
    :eek:
     
  10. M Lynn

    M Lynn Registered

    Joined:
    Aug 2, 2017
    Messages:
    45
    Likes Received:
    11
    Yeah, the difference on that occasion was it was actually visible in the replay as well, the car actually froze in place that long.
     
  11. FrC

    FrC Registered

    Joined:
    May 1, 2017
    Messages:
    12
    Likes Received:
    12
    yes same problem for me (1st freeze mid December 19)
    it's a real problem
    I do tests by lowering the CPU and GPU load (1st tests are good, we cross our fingers)
    if that does not solve the problem, I will uninstall this excellent simulation, because it is not possible to make a championship seriously under these conditions
     
  12. M Lynn

    M Lynn Registered

    Joined:
    Aug 2, 2017
    Messages:
    45
    Likes Received:
    11
    I've lowered CPU and GPU loads by using RTSS to limit FPS to 60. My monitor is 60 Hz anyway so I'm not losing anything by doing that. Still get the freezes.
     
  13. Stefan_L_01

    Stefan_L_01 Registered

    Joined:
    Nov 18, 2012
    Messages:
    425
    Likes Received:
    244
    lagg likes this.
  14. M Lynn

    M Lynn Registered

    Joined:
    Aug 2, 2017
    Messages:
    45
    Likes Received:
    11
    You could well be right there Stefan, sounds like it was fixed for some people but not for others, or fixed for some and created for others.
     
  15. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    393
    Likes Received:
    114
    +1
    I get it too
     
  16. MarcoSaupe

    MarcoSaupe Registered

    Joined:
    Feb 11, 2012
    Messages:
    39
    Likes Received:
    10
    After our league race today we had a little chat about this, and almost everyone had such a freeze with a steam dump at the appropriate time...
     
  17. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    130
    Likes Received:
    46
    Same problem for one my friend. With old UI there freeze around 33-minute but it is fine with beta UI.
     
  18. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,459
    Likes Received:
    1,289
    Turn real time logging on, and if it happens, zip the log files, your player and multiplayer jsons, and config.ini, and post a link to it here.
     
  19. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,995
    Likes Received:
    1,340
    In the last two weeks I have started getting 1 to 2 seconds of having no control of car and the steam dump files matched time wise.
    Tonight I used the beta UI and I had some very tiny, minute freezes (1/10th sec maybe) at the same two parts of a 3rd party track in the Porsche Cup car.
    No steam dump file either and I was on the server for 1 1/2 hours. :)
    So a big thank you @Alexandr Meshkov.
     

Share This Page