rFactor2 - LiveMonitor and Hotlaps Released

Discussion in 'Plugins' started by vyrush, Feb 18, 2012.

  1. vyrush

    vyrush Registered

    Joined:
    Jan 9, 2012
    Messages:
    210
    Likes Received:
    3
    Ah thats great Juan!
    Yes, that is right you need to have 3 instance LiveMonitor.exe to be running
     
  2. juan_fr

    juan_fr Registered

    Joined:
    Mar 28, 2012
    Messages:
    10
    Likes Received:
    0
    Ok !

    And is there any way to automate the start up? Start as a service? And every instance start his LM data listening and open his database?

    If not, no problem. Only remember to start them every time we reboot. But this options will be nice ... ;)

    Thanks for all !
     
  3. vyrush

    vyrush Registered

    Joined:
    Jan 9, 2012
    Messages:
    210
    Likes Received:
    3
    I working on making the LiveMonitor as service. So that should solve the problem.. But for the time being, you need to manually start it..
     
  4. juan_fr

    juan_fr Registered

    Joined:
    Mar 28, 2012
    Messages:
    10
    Likes Received:
    0
    Hy vyrush !

    I have send you an email to the @malaysiansimracers address, with a few ideas and things we advice. So big to talk it here ;)

    Thanks !
     
  5. vyrush

    vyrush Registered

    Joined:
    Jan 9, 2012
    Messages:
    210
    Likes Received:
    3
    alright mate.. let me go through and have a look at the suggestions..
     
  6. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    Any chance this will work for a Linux based server?

    I've done everything as you say, but when I go to install and enter the database name (the one in the live.php file) and click create it does nothing.

    I'm assuming it's because my web host gave me a Linux server not Windows
     
  7. B1gch0pper

    B1gch0pper Registered

    Joined:
    Jan 11, 2012
    Messages:
    32
    Likes Received:
    0
    Hi Nick, yes this works on Linux based webservers as mine is also...
    AFAIK the web page installer may or may not work for everyone, it didn't for me but you can add them manually, see THIS post :)
     
  8. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    Thank you. But which three files? My install folder contains 2 php files and 3 sql ones.
     
  9. B1gch0pper

    B1gch0pper Registered

    Joined:
    Jan 11, 2012
    Messages:
    32
    Likes Received:
    0
    You just need to import the 3x sql ones into your already created 'livetiming' database buddy
     
  10. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    Cool. Ok, getting somewhere. I am now having an issue with the Livemonitor.exe

    I just get told that 'Unable to connect to any of the specified MySQL host' even though the information is correct.
     
  11. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    Please any ideas?
     
  12. B1gch0pper

    B1gch0pper Registered

    Joined:
    Jan 11, 2012
    Messages:
    32
    Likes Received:
    0
    Just a few ideas to check...

    1) Make sure you have copied the MySQLData.dll to the same local folder as LiveMonitor.exe...
    2) Hostname in LiveMonitor is the root URL to your site (www.whatever.com) not (www.whatever.com/livemonitor)
    3) Sometimes database names and usernames can have a prefix (yourname_dbname) and (yourname_dbusername), might be worth checking up on...
    4) Make sure your access username has full privileges to access and ammend the database
     
  13. steeve

    steeve Registered

    Joined:
    Jan 9, 2012
    Messages:
    87
    Likes Received:
    0
    Hello,
    I installed the livetiming on our server and it starts after clicked on connect in the livemonitor.exe, I activate the session id and then I start on CLIKE.
    Until the all goes well, we see on the page dulivemonitor that the server is running, duréee session, session type, but when a person enters the game online, an error occurs in the livemonitor.exe, the page remains active but it is not in attendance.
    Here is my error report.

    Error Log Entry : 22:19:07 samedi 31 mars 2012
    System.FormatException: Le format de la chaîne d'entrée est incorrect.
    à System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
    à System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
    à System.Double.Parse(String s, NumberStyles style, NumberFormatInfo info)
    à System.Convert.ToDouble(String value)
    à LiveMonitor.Form1.backgroundWorker1_DoWork(Object sender, DoWorkEventArgs e)

    An idea?? Thank you in advance

    System windows and xampp
     
  14. vyrush

    vyrush Registered

    Joined:
    Jan 9, 2012
    Messages:
    210
    Likes Received:
    3
    Hi Nickbalti, i see bigchopper has already answered the questions for you.
    Thanks Biggie..

    @Steeve, there's a possibility that you missed out on updates after 1.0.4.0
    this might be the cause of your problem

    Please download the full version 1.0.4.0 and then
    update to 1.0.4.1 -> 1.0.4.2 -> 1.0.4.3

    http://malaysiansimracers.com/fahad/rF2/LiveMonitor/setup/LMDataLoggerFull1040.zip
    http://malaysiansimracers.com/fahad/rF2/LiveMonitor/updates/LMDataLogger1041.zip
    http://malaysiansimracers.com/fahad/rF2/LiveMonitor/updates/LMDataLogger1042.zip
    http://malaysiansimracers.com/fahad/rF2/LiveMonitor/updates/LMDataLogger1043.zip

    I am currently working a new full package with added feature. Will provide it as soon as its ready till then here are the download links
     
  15. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    Thanks for the replies but still nothing.

    When I get home from work later I'll pm you guys if you don't mind :)
     
  16. juan_fr

    juan_fr Registered

    Joined:
    Mar 28, 2012
    Messages:
    10
    Likes Received:
    0
    Hello,

    I have seen this before ... and what is the problem ? , the problem its perhaps you have just created before the database. DONT CREATE IT, let the installer create the database with the user right permissions.

    I do this with my linux server, whith ssh access:

    ---> Connect to mysql server:
    mysql -u root -p
    ---> create 2 users, one for remote(windows rF2 server) and one for localhost(php website):
    GRANT ALL ON LM.* TO LMremote@'1.1.1.1' IDENTIFIED BY 'my_passww';
    GRANT ALL ON LM.* TO LMuser@'localhost' IDENTIFIED BY 'my_passww';


    (*) 1.1.1.1 is my windows server IP
    (*) LM will be the database name
    (*) LMuser the user in the webserver
    (*) LMremote the user in windows server


    Then, just set up live.php, go to /install and everything ok !

    remember ... dont create before the database manually, ... ;)
     
  17. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    I will delete the database files later and try again, where do I enter those commands? Thanks again.
     
  18. juan_fr

    juan_fr Registered

    Joined:
    Mar 28, 2012
    Messages:
    10
    Likes Received:
    0
    In the ssh terminal console if you have it. If its a shared hosting without ssh, then create the users and grant permissions to the database. If its needed, create too the database. But when you´re going to install hotlaps, delete the database first, having only the user (users) with all the permissions. Then the install must compete ... because the install CREATE the database, not create the tables inside a database.

    @vyrush ... another idea, is to make the install.php file with two options:
    a) create database (like is it)
    b) create tables in a manually created database
     
  19. vyrush

    vyrush Registered

    Joined:
    Jan 9, 2012
    Messages:
    210
    Likes Received:
    3
    yup sure will do that..
     
  20. nickbalti

    nickbalti Registered

    Joined:
    Jan 12, 2012
    Messages:
    380
    Likes Received:
    8
    Thank you so much for your help. But I am a noob. How do I find out if I have the ssh terminal console. My hosting is with 1and1
     

Share This Page