Only run in Forced32b, BUT ... I'm on W10 64b, I5proc is x64

Discussion in 'Technical & Support' started by ajt60, May 1, 2019.

  1. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    Dear MARRS

    I look for your help ....
    Hope my language is correct sufficient ;)
    Im French ....

    For more 3 years I often played offline on DX9 in forced 32b with no real matters.
    but I stopped playing RF2 for 1 year and I restarted this WE, and now on DX11.

    BUT :
    I cannot start game from launcher if forced32 is unflagged.
    Thats strange as my config is I5 intel 6600K 3.50Ghz, Windows 10 Family x64 ( v1803 / 17134-706 )

    If I launch in 32b :
    Now RF2 & mods are on DX11, most of mods/races I run with >10 IA ,
    I always have this error message because RAM required is over 3.0G .... and Im blocked ( by 32b) to 3.0G

    If I launch in 64b :
    When I start from launcher, in 1 second I'm back on launcher screen. Nothing else happening.
    When I start from folder Bin64/rfactor2.exe, I have this error message : 0xc000007b

    This morning,
    > I deleted all Game files, via Steam and manually on HD, I cleaned everything,
    and I reinstalled, and I also run all Windows 10 and DirectX last updates too.
    > I tried to update some 4 files ".dll" in Windows/System32 ( found on Forum on 0xc000007b error )
    > I updtade Visual Studio 2017

    One contact told me to track with : +trace=3 in launcher command line
    I did this, I had a file in userdata/Log named : auto-subscribe.text" inside there is indicated 1556738407

    Im really lost ....
    What should be done please to run the game in 64b and enjoy full capacity of mods ?

    I really thnak you for your support
     
  2. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    here is file I dont know which one inside ...
     

    Attached Files:

  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,180
    Likes Received:
    1,330
    32 bit limits the amount of RAM to 3GB, as you stated, the last line of the trace file shows the memory footprint was 3.15GB. That might explain why 32bit is not working. Choose one car in a private solo practice session. Then if that is sucessful, start adding a few more and reloading the track again. I must add that S397 announced with then new news letter that they will soon change over to 64bit only, so finding a solution to this will be critical. Good luck.
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    @ajt60 Run the 4 files in the Support/Runtimes folder as well. I don't think you've done that.
     
  5. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    Hi Dave, yes, according the selection "track+mod", I define the IA value by "incrementing tests" ... ;)

    > is there other ( manual ) way to increase the 3GB limit ?

    @ All : do you think my Steam (profile,installation) could "freeze" only on the 32b versions ?
     
  6. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    @Lazza : in Windows ? the same dll ?

    i did in RF2 : no success. I will restart machine ...

    restarted : no success in 64b, and crash in 32b on Silverstone GT+GTE mod (Enduseries ) with 20IA ...

    EDIT : I can increase IA by decreasing all video/resolution setups ( ugly but efficient ... )

    Hope some/your help to join the 64 environment soon ... ;)
     
    Last edited: May 1, 2019
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    @ajt60 There are 4 files in that folder, you just run each one. Don't play with dll files, that can break things.

    You can't increase the 3-4 GB limit with 32 bit applications, and as mentioned the game will soon be 64 bit only, so need to sort out what's going on. There are other threads in this forum with similar issues, you may find clues in there too.
     
  8. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    640
    Likes Received:
    412
    It may also pay to run the setup.exe file in your ...rfactor 2/support/directx folder as well.
     
  9. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    564
    Likes Received:
    312
    Make sure you are not opted in to any betas as well.
     
  10. Denys

    Denys Registered

    Joined:
    Dec 11, 2016
    Messages:
    1
    Likes Received:
    0
    Hi
    I stop to play Rfactor2 while six months ago. And i decide to play again.
    I launch the game by steam. I choose my car and my track. The track is working and then crash. Return on the desktop and the game is running. So i must to kill the processus.

    I had delete the directory Bin32 and Bin64 in the directory of the game and downloading the files. I lauch the game and it's ok.

    This is my solution for me.

    Grég
     
  11. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    Hi, deleted both folders, reloaded via Steam
    Nothing new happened ...
    @JimmyT : I have NO BETA
    @Lazza : what do you mean by "run each dll" ?
    @Goanna : sorry, nothing happened

    Still crashed in x64 launching
     
    JimmyT likes this.
  12. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    640
    Likes Received:
    412
    The 4 files @Lazza mentioned in the .../support/runtimes folder are exe files, you need to run all 4
     
  13. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,097
    Likes Received:
    1,224
    If you played rF2 in DX9 for three years it's likely that you have some old plugins left that are interfering. Any plugin that draws to graphics is no longer supported in DX11 and may cause crashes. Check the rFactor 2\Bin64\Plugins folder and make sure you only have default plugins provided with the game (knockout qualifying, steam plugin, stock car rules, track IR).
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    @stonec the first post says everything was deleted and reinstalled, so shouldn't be old plugins. The talk of dll files is concerning though.

    @ajt60 don't copy or put any dll files anywhere (game or windows). A .dll file gets installed as part of some package or update; finding and copying in ones you find online can create problems.

    As above, the 4 files I'm talking about are .exe. If you have put any .dll files in your game take them out. If you put some in windows folders run sfc to fix them.
     
  15. Akela_DE

    Akela_DE Registered

    Joined:
    Jan 23, 2018
    Messages:
    297
    Likes Received:
    178
  16. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    morning all
    I will check this tonight ( run and/or fix the x4 .exe files ) and ( fix the error code )
    Thanks to all to support/follow me ;)
     
  17. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    Forgot about rivatuner, it's caused startup issues. Any chance you're using it?

    @Marcel Offermans I wonder if processes could be listed in trace files? In the absence of better error messages.
     
  18. Davvid

    Davvid Registered

    Joined:
    Feb 11, 2012
    Messages:
    142
    Likes Received:
    22
    Current RTSS is flawless for rF2.
     
  19. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    @Davvid : hi not understood. what do u mean ?
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    He's talking about Rivatuner. In the past it has sometimes caused startup issues. He's saying the current version works fine, but it's still worth checking. Do you run it?

    Try disabling your antivirus or its 'deep scan' option (or similar) as well, could be doing something.
     
    Davvid likes this.

Share This Page