Linux / Wine hosting test

Discussion in 'General Discussion' started by hoover, Aug 31, 2014.

  1. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    Would be possible to update components at the server?
    In my case, I don't feel like installing former versions just for one test ;)

    Thanks

    byyyyyyyye
     
  2. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,131
    Likes Received:
    162
    Hm, are you saying the contentbuild contains old components? Thanks for the heads-up!

    Uwe
     
  3. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,351
    Likes Received:
    6,782
    It's Malaysia I believe, it was released shortly after Build 946.
     
  4. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    It's Malaysia, Lime Rock and Renault Clio (I wish it was also the Marussia, because that would mean that it would have been updated ;), but not, MR01 at the server is current version)

    byyyyyyyye
     
  5. nultweezes

    nultweezes Registered

    Joined:
    Jun 27, 2014
    Messages:
    83
    Likes Received:
    0
    Is there a chance that rF2 will support Linux in the future? Then I'll have no reason to have this horrible OS called windows on my pc anymore.
     
  6. possi

    possi Registered

    Joined:
    Nov 26, 2014
    Messages:
    5
    Likes Received:
    0
    OK guys i've managed to run the full 946 version on linux, it's a little bit long, but works fine.

    You need to install the lastest version of playonLinux
    install RF2 lite from there
    when finished click on the shortcut created on PlayonLinux, from wine->install components and install
    vcrun2008
    vcrun2010
    vcrun2012
    vcrun2013

    after that, follow this guide and install orignin client (the will crash otherwise)
    http://forums.bodhilinux.com/index.php?/topic/10322-providing-support-for-unsupported-linux-games/

    After this use this flag to start the launcher
    LIBGL_ALWAYS_SOFTWARE=0

    and you are done

    View attachment 16458

    hope it helps, bye
     
  7. possi

    possi Registered

    Joined:
    Nov 26, 2014
    Messages:
    5
    Likes Received:
    0
    OK guys i've managed to run the full 946 version on linux, it's a little bit long, but works fine.

    You need to install the lastest version of playonLinux
    install RF2 lite from there
    when finished click on the shortcut created on PlayonLinux, from wine->install components and install
    vcrun2008
    vcrun2010
    vcrun2012
    vcrun2013

    after that, follow this guide and install orignin client (the will crash otherwise)
    http://forums.bodhilinux.com/index.php?/topic/10322-providing-support-for-unsupported-linux-games/

    After this use this flag to start the launcher
    LIBGL_ALWAYS_SOFTWARE=0

    and you are done

    View attachment 16459

    hope it helps, bye
     
  8. ralphluthor

    ralphluthor Registered

    Joined:
    Apr 22, 2015
    Messages:
    20
    Likes Received:
    1
    Hi guys i've managed a fresh full install of rf2 build 946.

    i've installed on a debian 7.8 32bit.
    Installed lastest version of wine 1.7.41 (recompiled)
    on playonlinux, after install rfactor2 lite, you need to install vcrun2008 to vcrun2013 and origin pkg, on wine section inside launcher shortcut that you have created

    on the shortcut created for the launcher put this

    View attachment 16465
    View attachment 16466

    Thats all...

    View attachment 16467
     
    Last edited by a moderator: Apr 22, 2015
  9. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,131
    Likes Received:
    162
    Thanks, I'll give it a try soon.

    Uwe
     
  10. ralphluthor

    ralphluthor Registered

    Joined:
    Apr 22, 2015
    Messages:
    20
    Likes Received:
    1
    ok i've a problem actually, when start the server all seems fine, client download the vmod and is all fine.

    If i perform a "next session", and the client dont have the content vmod downloaded, when he try to connect the mod download fail.

    Now, the strange thing is, if i attach a strace to the server pid, (and problably slow down a little bit it), the mod download works fine ... o_O someone got problmes with th automatic mod download from server with wine?

    edit: the problem is related to the password protected server, if i start a server with no password it works perfectly and download the mod also if i skip a session or whatever.

    the problem seem related the "time" taken to insert the password, sometimes work sometimes not, and the fact that with a strace attached to the pid works, is indicative that the strace "slow down" the communication a little bit, enough to finish the auth and download the mod....

    thx
     
    Last edited by a moderator: Apr 22, 2015
  11. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,131
    Likes Received:
    162
    Hm, the strace hint is a great one. I've also noted that auto-updating never works because the individual downloads time out after 80%, so I've always had to install a new litebuild in-place over the old one.

    As far as i'm concerned though vmod d/l usually works fine, even when making several attempts (usually it's only a 700kb file).

    Are you using the "classic dedicated" interface?

    Uwe
     
  12. ralphluthor

    ralphluthor Registered

    Joined:
    Apr 22, 2015
    Messages:
    20
    Likes Received:
    1
    There's no problem if i put the server as public with no password, and there is no problem if i just start the server for the first time, the problem will begin when the server o i manually go to next session...

    I use the standard dedicated server, the classic wine rFactor2 Dedicated.exe +path=..

    with a strace attached to the pid works perfect every time o_O
     
  13. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,131
    Likes Received:
    162
    Very weird. That function has been working for me fine ever since I did the first wine rf2 experiments. I compiled wine from source, but that's most likely not the culprit...

    Uwe
     
  14. ralphluthor

    ralphluthor Registered

    Joined:
    Apr 22, 2015
    Messages:
    20
    Likes Received:
    1
    i've also compiled wine 1.7.41 is not related to that btw... (the source or binary i meen)

    from 2 day until now the server is running with several AI ... no problems...
    is not a big issue the mod download only when is password protected.. really... i've also attached to liveracers and all run smooth...

    for now the server will remain open for test, who wonna came and test is welcome... the name of the server is "Monkey-Drivers-Linux"...
     
    Last edited by a moderator: Apr 24, 2015
  15. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,131
    Likes Received:
    162
    Hi folks,

    I've updated the server with the new DW12 and Atlanta Motorsports Park (Road Course).

    Enjoy,

    Uwe
     
  16. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,131
    Likes Received:
    162
    Hi folks,

    the wine server has been updated to build 982, using the DW12 @ Silverstone, Atlanta MP and Indy.

    All the best

    Uwe
     

Share This Page