Issue with new GT3 skins in sessions

Discussion in 'Technical & Support' started by fsuarez79, Feb 3, 2019.

  1. fsuarez79

    fsuarez79 Registered

    Joined:
    Nov 23, 2016
    Messages:
    542
    Likes Received:
    574
    After this last update I've been having issues with virtual ride skins with the GT3 challengers pack. It looks as if the the .veh file is now linked to the skin
    I'm creating a virtual ride from the tuning menu as usual without any problems. Then I go to the Car folder in the settings menu and replace the dds, go to the Tuning menu again and the new skin shows just fine and as expected.
    However when joining any session (practice/race) the car shows the original S397 skin linked to the veh filename specified in the rcd file.

    As an example, the rcd file for the Montaplast Audi in Racedepartment is like this.

    //[[gMa1.002f (c)2016 ]] [[ ]]
    GT3
    {
    Daniel Morad
    {
    Team = Montaplast by Land Motorsport
    Component = Audi_R8LMS_GT3_2018
    Skin = altMPlast.dds
    VehFile = WARPAINTAL21502DA4.VEH
    Description = 2019 Land Motorsport Audi R8 #29
    Number = 29
    }
    }


    The Montaplast skin shows perfectly fine in Tuning menu. But when adding the car in any session, it will show the original S397 Black/Red skin, which is linked to VehFile = WARPAINTAL21502DA4.VEH.

    BTW, this isn't happening only with 3rd party skins, even if I try to use one of the new released skins, the car will still show whichever skin is linked to the veh file.

    Anyone else having this issue?
     
  2. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    235
    Likes Received:
    870
    It happens with Aston Martin and the Audi, if you select the car to drive it works ok but the AI use the original S397 skin. I do not think I will be doing any skin for these car until all the bugs are sorted.
     
  3. fsuarez79

    fsuarez79 Registered

    Joined:
    Nov 23, 2016
    Messages:
    542
    Likes Received:
    574
    Ok, thanks for confirming, but as far as I can tell it happens with all the GT3 Challengers, not only the Audi and the AM. And yes, I forgot to say that.....it works if you drive it but not for the AI.

    @Christopher Elliott I haven't seen anyone reporting this bug. Can you please make sure @Marcel Offermans and whoever needs to is aware of this?
    At this point it's useless to skin the new cars.
     
  4. Audere est facere

    Audere est facere Registered

    Joined:
    Mar 26, 2018
    Messages:
    56
    Likes Received:
    93
    I mentioned this bud approx a couple of hours after material was released ... I am the fast man... Not just on the track ;)

    Have a look for my postings AND threads you will see
     
    fsuarez79 likes this.
  5. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,264
    Likes Received:
    5,745
    I will try to confirm that.
     
    fsuarez79 likes this.
  6. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    332
    Likes Received:
    75
    your not doing it properly.
    The virtual ride ALT skin is for yours/yours alone personal skin, not for the ai.
    For it to work for a completely separate ai, you need to change the skin reference in the rcd to a non ALT prefix livery, and have subfolder of the same name, and put the skins inside without a ALT prefix.
     
  7. fsuarez79

    fsuarez79 Registered

    Joined:
    Nov 23, 2016
    Messages:
    542
    Likes Received:
    574
    I'm not in front of my PC atm but I can test this later.
    Are you talking about the GT3 Challengers pack? Have you been able to test your theory with cars in that pack specifically?
    I've been creating virtual rides for couple of years without any issues and never had to change the alt prefix. It has always worked fine with AI regardless of the skin name as long as it's referenced correctly in the rcd file.
     
  8. Audere est facere

    Audere est facere Registered

    Joined:
    Mar 26, 2018
    Messages:
    56
    Likes Received:
    93
    I donĀ“t get it. Sorry but I really do not understand. Can somebody please provide me with the correct syntax of the rcd and maybe an working example of the file structure....fighting with this now today for 5 hours and yesterday for about 6 ... next step would be a bullet in my head. I am really done....
     
  9. fsuarez79

    fsuarez79 Registered

    Joined:
    Nov 23, 2016
    Messages:
    542
    Likes Received:
    574
    Removing the "alt" prefix didn't make a difference. Tbh I don't think syntax has anything to do with it and it's rather a bug affecting skins of AI that needs to be addressed by the devs.
    Again, this is specific to the GT3 challengers and the new skinning system after the last update. I had no issues whatsoever with virtual rides before this.
     
    Audere est facere likes this.
  10. Audere est facere

    Audere est facere Registered

    Joined:
    Mar 26, 2018
    Messages:
    56
    Likes Received:
    93
    Thx for validating this. I really thought I am that stupid not understanding a quite simple task. Makes my day ! :D
     
    fsuarez79 likes this.
  11. TCLF

    TCLF Registered

    Joined:
    Apr 22, 2014
    Messages:
    123
    Likes Received:
    99
    I've got pretty much the same issue. I create the skin, create the new team, and it looks good in the showroom. When I enter a session (tested on SP practice) it makes my skin the default original one.

    I also tried removing the alt prefix (which it makes automaticly when creating a new team) and then it also shows the original skin in the showroom.

    [edit] I'm using the porsche gt3
     
    Last edited: Feb 5, 2019
    fsuarez79 likes this.
  12. Copef1

    Copef1 Registered

    Joined:
    Jan 15, 2012
    Messages:
    36
    Likes Received:
    9
    I'm having the same problem that everyone in this thread is having with the skins not showing up on AI cars. I am also having a problem with any skins I do for Audi not showing up in the menu, or the game at all.
     
  13. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    332
    Likes Received:
    75
    I tested this on the s397 gt3 challenge pack last night, yes I can confirm you are correct, the wildcards are not functioning for Ai. Works fine on my 3rd party mods. I need more time to see what's in the new json file, as it links to default textures.
     
    fsuarez79 likes this.
  14. TCLF

    TCLF Registered

    Joined:
    Apr 22, 2014
    Messages:
    123
    Likes Received:
    99
    Is there any update on this? Kind of eagered to finish my skin for the dutch nationals :p
     
  15. fsuarez79

    fsuarez79 Registered

    Joined:
    Nov 23, 2016
    Messages:
    542
    Likes Received:
    574
    I don't know. @Christopher Elliott said he'd confirm but he's been very quiet since
     
  16. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,286
    Likes Received:
    1,212
    In the json file, it has a path to the dds file, change that to your skin, and see if it works.
     
  17. fsuarez79

    fsuarez79 Registered

    Joined:
    Nov 23, 2016
    Messages:
    542
    Likes Received:
    574
    Thanks Coutie, hopefully somebody else will be able to confirm if that works or not. I'm leaving on a trip tomorrow and won't have time to test it.
     
  18. TCLF

    TCLF Registered

    Joined:
    Apr 22, 2014
    Messages:
    123
    Likes Received:
    99
    I'll test it now
     
  19. TCLF

    TCLF Registered

    Joined:
    Apr 22, 2014
    Messages:
    123
    Likes Received:
    99
    This actually works. These 2 need to be changed if you have this problem. After that it chose my alt skin. When I made a new team, it did it automatically correct. Not sure if this was an incident or from now on right, but it works.

    upload_2019-2-8_21-35-5.png
     
  20. TCLF

    TCLF Registered

    Joined:
    Apr 22, 2014
    Messages:
    123
    Likes Received:
    99
    @Christopher Elliott maybe this can help
     

Share This Page