Full Course Yellows AI fix, on the roadmap?

Discussion in 'General Discussion' started by marvelharvey, Feb 4, 2018.

  1. mschreiner

    mschreiner Registered

    Joined:
    Oct 5, 2010
    Messages:
    369
    Likes Received:
    202
    I agree it was around the Stockcar release. I think they tried to improve things and putting rules in to a plugin. The problem is ISI started it and s397 then took over before it was finished. The problems with the AI you can see in online racing by how the game tells you to do things that are not correct. If the AI are confused in the game, think how us Humans are confused when the game is telling us to do things that are wrong and we do not want to listen, then it breaks a race for the evening. Very frustrating for everyone. I have faith that they will get it right! I just challenge them to get it right soon. A lot of feedback has been passed along and hopefully it helps them out.
     
    atomed likes this.
  2. marvelharvey

    marvelharvey Registered

    Joined:
    Apr 25, 2013
    Messages:
    409
    Likes Received:
    280
    Daaaamn. This fixed it for me too! You've made me a happy man tonight!

    Please, everyone, update that line in your player.json file!
     
    atomed and rubennaatje like this.
  3. Mike Tobin

    Mike Tobin Registered

    Joined:
    Jan 2, 2017
    Messages:
    11
    Likes Received:
    9
    So Should this be true or false?
     
  4. Shadak

    Shadak Registered

    Joined:
    May 29, 2020
    Messages:
    43
    Likes Received:
    16
    It should be true, I have just tested this change and AI lines up behind the pace car nicely, this is so amazing! :)
     
  5. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,212
    So s397 couldn't of done this ?
     
  6. Ariff

    Ariff Registered

    Joined:
    Aug 20, 2016
    Messages:
    56
    Likes Received:
    39
    So this problem was still here since 2018? ouch...
    I'll give this a try, thanks for the bump.
     
  7. Shadak

    Shadak Registered

    Joined:
    May 29, 2020
    Messages:
    43
    Likes Received:
    16
    I've not tested this while being on the track though .. not sure what AI will do when you are among them in the safety car train :)
     
  8. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,731
    Likes Received:
    2,078
    Yes same "ouch" with me! Never knew this option was in the player.json at all, I'll give it try at some point.

    Edit: not sure if this was brought in specifically for Oval Racing or not, either way deserves a test on Road course.
     
  9. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,731
    Likes Received:
    2,078
    Ok I've just tested with 'AI Formation false & true' and I see no difference on a Road Course, in fact with it on false (default) I don't see any major issues with the AI and FCY as it is. Apart from their speed being a bit sporadic and moving about the track they all line up and the race goes back to Green fairly quickly, that's with both a same class field and multi class with a lapped field.

    If anyone is having any specific issues with AI & FCY please give me as much information as possible so I can try and reproduce (preferably with Official S397 Content not 3rd party); The Track, the Car/s, the AI Strength/Aggression, your Race Settings etc and attach your player.json (or say if you used a Fresh/Default one).

    I'll report what I've found with the above and will from now on race with Full Flags when racing the AI, thanks all. :)
     
    atomed likes this.
  10. Shadak

    Shadak Registered

    Joined:
    May 29, 2020
    Messages:
    43
    Likes Received:
    16
    I havent seen FCY on many tracks but every time I have seen it, when it was set to default formation, AI just dragged on for number of laps before they even starte catching up to safety car, like going really slow when they were half a lap behind it, then speeding up for 2 seconds then going slow again. This was on modded tracks I admit, but switching this in the file made it suddenly work as expected :)
     

Share This Page