DX11 - Incorrect graphics card used

Discussion in 'Bug Reports' started by 64r, May 9, 2017.

  1. 64r

    64r Registered

    Joined:
    Jan 16, 2012
    Messages:
    188
    Likes Received:
    14
    I have 2 graphics cards and 4 monitors connected to my main dev machine.

    I use my GTX graphics card for RF2 that is only connected to a single screen (Screen 4), and I have another Quadro card connected to 3 other monitors (my main dev screens 1, 2 and 3).

    In the RF2 Video configuration dialog I can see both cards correctly and can select the GTX card, however when rf2 starts the Quadro card is used and the main monitor (identified as monitor 1 in Windows) is used to show rf2.

    It appears that RF2 is using the first video card detected on the first screen instead of the user selected card and screen.

    This is not a high priority bug, but I thought it worth reporting in case it leads you to help solving other related issues.

    This configuration worked correctly in the last DX9 main release but is broken in the current DX11 beta, I am now rolling back to the latest DX9 release and will let you know if I see the same issues.

    Let me know if you require more details.
     
    SPASKIS likes this.
  2. Gijs van Elderen

    Gijs van Elderen Member

    Joined:
    May 1, 2014
    Messages:
    1,399
    Likes Received:
    469
    Workaround:
    - First launche rF2
    - select the GTX card ingame
    - set the resolution.
    - click apply.

    This should the job until the issue is fixed.

    If you go back to the video setup via the launcher and want to change the Post Effect.
    Ignore the wrong video card selection and video resolution ( = "video mode").

    Issue in the video setup via the launcher:
    - If you select the GTX: the Quadro is used with the GTX's "video mode".
    - If you select the Quadro: the GTX is used with the Quadro's "video mode".
     
  3. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    686
    Likes Received:
    60
    I have the same problem, however mine is a user created nVidia Surround. In DX9 it would show as NVIDIA GeForce GTX 980 Ti Secondary, but for DX11 I do get the option of Secondary. Without the Secondary option I can only play on the single screen 1920 x 1200, not 5760 x 1080.

    DX9
    upload_2017-5-10_16-18-15.png

    DX11
    upload_2017-5-10_16-18-35.png

    I tried the above mentioned workaround launching rF2 etc, but it still does not display the Secondary option.

    Workaround:
    - First launch rF2
    - select the GTX card in-game
    - set the resolution.
    - click apply.
     
  4. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    686
    Likes Received:
    60
    OK, so the workaround for my problem is to make the 3 x screens my primary screens. Not ideal but it will have to do for the time being..

    I don't use my 3 x screens all the time hence why they are set to Secondary. They are often Disabled in Windows / Turned off and only used when running rF2.

    Hopefully a fix is on the way for this.
     
  5. Drathuu

    Drathuu Registered

    Joined:
    Oct 14, 2010
    Messages:
    350
    Likes Received:
    98
    I know this was a logged bug in closed beta.. its on their list im sure , but likely a lower priority - workaround as per above - pain as i have to do it too, but thats life
     

Share This Page