Desperate for help

Discussion in 'Hosting Help' started by slimsymeat, Feb 16, 2018.

  1. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    Over the last week I've tried everything I can think off. I can host and can be seen outside my home network but cannot log onto or be seen on my local network. I have a talk talk super router. Opened ports 52497 (UDP/TCP), 64297(TCP), 64298(UDP), 64299(UDP). Enabled DMZ. Hosted on 2 different machines. Disabled windows firewall. Tried static IP. Setup servers using steamcmd. Edited the shortcuts with local and external IP addresses. Even tethered to my phone and still can't be seen. Please can someone help.
     
  2. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,436
    Likes Received:
    2,896
    Try adding all those ports in Windows firewall, instead of just disabling it.
     
  3. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    Hi, thanks for the swift response. Sorry I did try that 1st before just turnng it off. When I used resource manager it shows those ports listening and the loopback giving the local IP address.
     
  4. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    471
    Likes Received:
    150
    What security software is installed ? (and was installed ?)
     
  5. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,436
    Likes Received:
    2,896
    Did you do that for both inbound and outbound?
     
  6. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    No other security software installed, and yes rules for inbound and outbound. Both machines are running win10 home with latest updates.
     
  7. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    471
    Likes Received:
    150
    Have you had security software installed on this installation of the computers in the past ?
    If so, what security software was it ?
     
  8. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    I never have.. the laptop is a fresh install too.
     
  9. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    471
    Likes Received:
    150
    Ok, needed to know that because old security software corrupts files.
    The problem with troubleshooting is one moves away too far from the original settings, not good with networks.
    Try resetting your network settings on the computers and restart and try again.
    When you reopen rFactor 2, keep an eye out for a window to popup requesting network access.
    Here are a couple of links to help reset.
    https://www.howtogeek.com/265870/ho...network-in-windows-10-and-start-from-scratch/
    https://www.digitalcitizen.life/how-reset-all-your-windows-10-network-adapters-just-6-clicks
     
  10. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    Ok will give that a try. Thanks. And will post back tomorrow as at work at the moment.
     
  11. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    471
    Likes Received:
    150
    Ok, good luck !
    Networking is quite complex when problems arise.
    In the second link, at the end make sure you finish this part "This is also includes setting whether you want your Windows 10 device to be discoverable by other devices on your network."
    This can also be done if you install a networked/wifi printer on both computers.
     
  12. Fuzzmutt

    Fuzzmutt Registered

    Joined:
    Feb 28, 2017
    Messages:
    3
    Likes Received:
    0
    I've got the same issue concerning hosting servers for rF2, found a workaround for this somewhere on the forums a while ago so I can connect to my own server.
    So what you do is, in the \rFactor 2\Launcher\ folder, create a shortcut of "Launch rFactor.exe". Go into the properties of the shortcut and add +connect [your IP]:[Port] +password [your password]. Apply and once the server is up you just connect via the shortcut. Hope that works
     
  13. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    173
    Likes Received:
    38
    LoopBack is blocked on TalkTalk Super routers, won't work through LAN.
     
  14. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    396
    Likes Received:
    225
    Change TCP port 64297 to 27013 and change UDP ports 64298/99 to 27014 and 27015... you can leave the TCP/UDP port 54297 as is......the server will then show in the LAN tab of the lobby for you. Don't forget to change port forwarding.
     
  15. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
     
  16. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    Is that change on the router? And windows firewall? I reset the network settings and no luck.
     
  17. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    396
    Likes Received:
    225
    In you multiplayer.json change the 64297 to 27013( look for line that starts with http port), also check that the line that starts with simulation port says 54297. Port forward on your router TCP 27013, UDP 27014, 27015, TCP/UDP 54297 to the host machine. As far as Windows firewall is concerned I'd delete all rF2 related stuff, that way the next time you fire up the server you should get the firewall permissions screen.
     
  18. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    Ok will give that a try. Thanks for the advice.
     
  19. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    35
    Likes Received:
    2
    Ok so I've edited the multiplayer.json and added the rules to the router, re-set all the networking and windows firewall. But still no luck ..
     
  20. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    471
    Likes Received:
    150

Share This Page