Car specific FFB Multi always at 1.00

Discussion in 'Bug Reports' started by Ernie, Oct 13, 2020.

  1. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    357
    Likes Received:
    213
    I have saved my own controller profile with a FFB Multi at 0.55. I have loaded this controlset in prior session. After entering the track again in the same car, my controller profile is loaded and is working properly, but the FFB Multi is at default value 1.00. Which means my FFB is way to strong. I always have to reload my controller profile manually.

    Here's a video of this issue:
     
  2. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    357
    Likes Received:
    213
    Just an additional info:
    I think i know where this problem come from. If you select a new car (or new version or livery of that car), an entry in "all_vehicles.ini" will be created or updated. The entry for this car has a default parameter "FFBSteeringTorqueMult=1.000".
    It seems, that this parameter won't be updated, when loading an own controller profile with a specific FFB Multi. (In my case "FFBSteeringTorqueMult=0.550")

    After re-entering the track with this car the previously used controller profile is loaded and is working. But the FFB Multi parameter gets loaded from "all_vehicles.ini" (which is 1.00) and not from my own controller profile.

    PS: If i manually change the value of "FFBSteeringTorqueMult" in "all_vehicles.ini" with an Editor it is working properly. But that shouldn't be a solution.
     
  3. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    444
    Likes Received:
    1,420
    The multiplier is specific to each car and skin even in the same mod, it is not a global setting because some cars need a different setting to others. This setting is not saved in your wheel profile, it is saved in the profile for that particular car and skin, so if you go back to the same car and skin it should be set to your setting. Just go to the settings while your in the pits and set it then, if you have driven that car before and set it then it should have the correct setting the next time you drive it should be correct. I always check the setting at the beginning of each session. Hope the explanation of help.
     
  4. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    357
    Likes Received:
    213
    Did you've seen my video in first post? Yes, it should be like that, but it isn't.
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,569
    Likes Received:
    3,852
    I think you'll have to adjust the value for the current car for the game to recognise it and save the new setting to the vehicles ini. I'm actually surprised the wheel profile changes that value at all - the whole point is it's vehicle specific...
     
  6. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    357
    Likes Received:
    213
    Yes that's the trick.

    Just to quote myself:
    But manually editing the file is just a workaround, and not a real solution.

    Is there a "global" FFB Multi parameter, which i can set as a new default value? Instead of 1.00
     
  7. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,639
    Likes Received:
    1,077
    Ernie likes this.
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,569
    Likes Received:
    3,852
    Just to be clear, I'm saying that adjusting the FFB Mult in the game (click down to 0.54, back up to 0.55) should initiate the code that saves that value to memory and the file (not sure when it actually gets saved, haven't tested). Loading the profile and having the displayed value change obviously doesn't have the same effect.

    It's interesting that it's a semi-implementation of what has been asked for by @DrivingFast and others as far as a global default, but yeah - currently it's not very practical either way.
     
  9. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    357
    Likes Received:
    213
    Aaaah .... got it. :)
    Have to test this.
     

Share This Page