Can't launch rfactor 2(need help)!

Discussion in 'Technical & Support' started by GTClub_wajdi, Apr 16, 2014.

  1. gkz

    gkz Registered

    Joined:
    Apr 10, 2013
    Messages:
    219
    Likes Received:
    0
    The launcher is just broken and I guess we can't fix it from our side.
    So we, for now, rolled back to the 770 build until this is fixed...
     
  2. Sparkiy

    Sparkiy Registered

    Joined:
    Jan 24, 2012
    Messages:
    14
    Likes Received:
    0
    Ok, thanks, I'm going to keep trying to find a solution.
    Keep you posted if I find one.

    Hoping I might get response from someone at ISI
     
  3. gkz

    gkz Registered

    Joined:
    Apr 10, 2013
    Messages:
    219
    Likes Received:
    0
    seems like hope is whats left .... was really looking forward testing this build.
    any kind of response by ISI would be appreciated though.
     
  4. Jeremy Miller

    Jeremy Miller Former ISI Senior Programmer

    Joined:
    Oct 5, 2010
    Messages:
    276
    Likes Received:
    3
    Dont shut the launcher down until you are done using rFactor2. Otherwise I have it on my list todo and will get to when I can.
     
  5. gkz

    gkz Registered

    Joined:
    Apr 10, 2013
    Messages:
    219
    Likes Received:
    0
    the only problem is that sometimes the launcher won't work even after a fresh pc start/reboot.
     
  6. mart280

    mart280 Registered

    Joined:
    Dec 3, 2013
    Messages:
    18
    Likes Received:
    0
    I'm having identical problems to gkz, very annoying.
     
  7. dradecki

    dradecki Registered

    Joined:
    Jan 14, 2012
    Messages:
    300
    Likes Received:
    26
    I thought I was going nuts when after a fresh install of 798 the Launcher window wasn't coming up even though it was in the task manager. Is there a link to 770 that I can install with?
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,298
    Likes Received:
    35
    Go to THIS site an click on Previous versions
     
  9. dradecki

    dradecki Registered

    Joined:
    Jan 14, 2012
    Messages:
    300
    Likes Received:
    26
    Redapg, thank you very much.
     
  10. bbel

    bbel Registered

    Joined:
    Dec 7, 2011
    Messages:
    31
    Likes Received:
    0
    Same problem here.
    Launcher don't start. I use Radeonpro and when i close it, the launcher start and RF2 798 is ok. (always)
    So i can't use Radeonpro with the new build. (I don't use CCC, not instaled).
    Without Radeon pro i try AA from RF2 level8, not bad but with Radeonpro it's better with "supersample".....
     
  11. Ricknau

    Ricknau Registered

    Joined:
    Nov 12, 2011
    Messages:
    751
    Likes Received:
    30
    Me too. Same problems as gkz and the rest.

    Here's a weird thing for me. When I can get the launcher to work is says I have the latest version. If I click "verify" EVERY SINGLE LINE in the list says "failed". It did this after my miserable experience at doing an auto install. Does it after a miserable attempt at a clean install. Reading the forums and dicking with this has eaten up my entire f'ing Saturday afternoon. God ISI makes it hard to love this game. It really baffles me how there can be such a wide range of experiences and results.

    One other issue... when I can get it to launch I can't get any old 60's cars to load. Mod Manager says I'm missing bunches of virtual mods for the cars, talent, VFR (or something like that). All this used to work. I copied my entire old "packages" folder into the new install. Then in Mod manager installed every component that was installable. Why can't rF2 find these things that used to be there? Where could they be? Where can I download them anew if need be?

    Edit: found most missing files in the Mlt tab. But still looking for virtual cmp Belguim1966 v1.43. Will do HDD search for it tomorrow. Passing out at the keyboard right now... zzzzzzzzz
     
    Last edited by a moderator: Jul 27, 2014
  12. gkz

    gkz Registered

    Joined:
    Apr 10, 2013
    Messages:
    219
    Likes Received:
    0
    and how long are we supposed to wait? c'mon...
     
  13. scalino

    scalino Registered

    Joined:
    Oct 21, 2013
    Messages:
    48
    Likes Received:
    2
    m'yeah I mean, that's heavy... it's been several days I'm playing with the 798 build, didn't install anything on my pc, today launcher doesn't start anymore...

    several questions need answers:

    - do the following keys in windows registry are used by ANYTHING else than windows itself (that means: launcher, core engine, plugins)?
    HKLM\SOFTWARE\Wow6432Node\rFactor2\CorePath & DataPath, HKCURRENTUSER\Software\rFactor2\Start Path (which doesn't include the disk letter)

    - is it still possible to have several _working_ installation instances of rFactor2, all in build 798, as expected? (and the question above is crucial for this one)

    - does the line '.\' in the Core\data.path file is still interpreted as the root installation folder or should it always says the full path of the data folder (cause that's not what the installations and updates are actually doing)?

    I've already made a launcher starts again (in a same windows session) after reinstalling a lite installer unchecking Data and directX, and updating manually the above line in data.path folder. Is it logical or was it just a f*** hell of a lucky day?

    i'm gonna do that again, live, right now...
    and it doesn't work either...
    reboot... (i come back lads...)

    EDIT: well, reboot done, registry keys and data.path file checked (file has been closed)
    new attempt...
    FAILED

    and I was going to test my new TSS brake on the G25...
    what a day start...!

    thanks a lot...
     
    Last edited by a moderator: Jul 30, 2014
  14. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    562
    Likes Received:
    215
    Thats the biggest issue with RF2 IMO. No small fixes are released only builds every 2 months or so. This means that theres always something wrong with RF2 because surely this issue will be fixed with the next build but then something else is broken. Thats the story of RF2 so far. In AC they release builds more often but most importantly - if a bug is reported in forum they fix it right away and steam updates the game for you. Thats brilliant and you feel they care about their product being as flawless as possible. I certainly dont get that feeling with RF2.

    ISI could at least release small hotfixes when there are obvious bugs instead of waiting 2 months and then something else is most likely broken.
     
  15. scalino

    scalino Registered

    Joined:
    Oct 21, 2013
    Messages:
    48
    Likes Received:
    2
    Last question: do ISI programmers ever read this forum...?
     
  16. Jeremy Miller

    Jeremy Miller Former ISI Senior Programmer

    Joined:
    Oct 5, 2010
    Messages:
    276
    Likes Received:
    3
    Yes. I get instant emails and am subscribed to this thread.
     
  17. gkz

    gkz Registered

    Joined:
    Apr 10, 2013
    Messages:
    219
    Likes Received:
    0
    as a customer that doesnt make me happy to be honest, quite the contrary. From our point of view, we see that ISI reads everything we complain about or have issues with and that's it. I know you can't do magic tricks and come up with fixes from nowhere but those shouldn't be things we have to wait for months :(
     
  18. Jeremy Miller

    Jeremy Miller Former ISI Senior Programmer

    Joined:
    Oct 5, 2010
    Messages:
    276
    Likes Received:
    3
    I don't read everything. I read what I can.

    Please PM Gjon Camaj (my boss) if you feel I am have inadequately prioritized this issue.

    As for "wait for months": This thread starts with issue of improper installation or missing plugins. The problem you are having is one of deadlock or hanging to the launcher application which began with build 798. Build 798 is a couple of weeks old.
     
  19. alpha-bravo

    alpha-bravo Registered

    Joined:
    Dec 22, 2012
    Messages:
    1,379
    Likes Received:
    31
    try to disable the OSD panel features in RadeOnPro. My system can run rF2 with RadeOnPro in eyefinity but I remember there was something to change in the OSD features.
    If you use profiles in RadeOnPro tray to add the rF2 launcher to RadeOnPro Launcher launcher executable.
     
    Last edited by a moderator: Jul 30, 2014
  20. bbel

    bbel Registered

    Joined:
    Dec 7, 2011
    Messages:
    31
    Likes Received:
    0
    Thanks alpha-bravo, i will try to disable OSD.
    For launcher i use "custom launcher" and point rF2 launcher in the profile. Ok ? It works perfectly with 770 build.
     

Share This Page