What am I doing wrong - RIFT in theater mode

Discussion in 'Technical & Support' started by fleming23, Feb 9, 2018.

  1. fleming23

    fleming23 Registered

    Joined:
    Feb 8, 2018
    Messages:
    5
    Likes Received:
    0
    Not sure what I am missing trying to play RF2 with my Oculus Rift. I installed the DX11 Beta, unchecked the "Use Desktop Game Theatre while StreamVR is active" but I cannot get my Oculus Rift to display anything from the game but rather I’m in the House lobby/living room thing. If I check the Desktop Game Theatre I can play the game but am in the movie theater looking room, which is pointless. I have yet to figure out how to actually get in-car VR with the Rift. In game, I have VR set to HMD + Mirror, but also tried just HMD and nothing changed.

    Oh, I also checked my third party files in that JSON user file, and there are none enabled other than the necessary/required ones.
     
    Last edited: Feb 9, 2018
  2. fleming23

    fleming23 Registered

    Joined:
    Feb 8, 2018
    Messages:
    5
    Likes Received:
    0
    Any ideas? Looking for any help here.
     
  3. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    3,423
    Likes Received:
    2,881
    Can you send me your Config_DX11.ini?
    Located in ....Steam\steamapps\common\rFactor 2\UserData
     
  4. fleming23

    fleming23 Registered

    Joined:
    Feb 8, 2018
    Messages:
    5
    Likes Received:
    0
    //[[gMa1.002f (c)2016 ]] [[ ]]
    [COMPONENTS]
    LanguagesFile=GAME.DIC
    ObjDetail=3
    TexDetail=2
    VideoGUID=00001B06-0000-0000-0000-000000000000
    VideoDriver=0
    VideoMode=50
    VrSettings=2
    AggressiveThread=0
    EPostProcessingSettings=1
    VideoRefresh=2
    WindowedMode=0
    Borderless=0
    RunBenchmarks=0
    FSAA=32
    VSync=0
    UsePostFX=0
    ShaderLevel=0
    SubViews=0
    UseSubViewParams=1
    WorkaroundFlags=0
    ViewParams=(0.540, 0.340, 0.600, 15.000, 0.037) // screen width (m), screen height (m), eye distance (m), side angle (deg), bezel gap (m)
    LeftView=(0.540, 0.340, 0.600, 15.000, 0.037)
    RightView=(0.540, 0.340, 0.600, 15.000, 0.037)
    PreferredGPU=-1
    WidescreenUI=0
    WidescreenUIWidth=-1
    WidescreenHUD=1
    CustomVidRes=(0, 0)
    VRMirrorWindowVidRes=(1920, 1080)
    VRUIScale=(1.000, 1.000, 1.000)
    MinimumVidRes=(800, 600)
    MaximumVidRes=(99999, 99999)

    [INSTALL]
    InstallFrom=
    InstallTo=

    [VERSION]
    Version=-1.000000
     
  5. Gijs van Elderen

    Gijs van Elderen Member

    Joined:
    May 1, 2014
    Messages:
    1,391
    Likes Received:
    440
    I had that issue too.

    Don’t start Steam VR before you open the rF2 launcher. :)

    If you see the rF2 launcher in steam theater, close the Launcher and close Steam VR. If you start rF2 that way, rF2 will start in the theater too. That’s not what you want.

    To start rF2 in the Rift:
    - Start the rF2 launcher
    - Check video settings:
    —> Choose HMD or HMD + mirror
    —> Choose 1920x1080 resolution.
    - Start rF2 single player or multi player.

    Then it’s time to put on you rift... :)

    Steam VR will start automaticly. ;)

    1 thingy if you close rF2 and the rF2 launcher, you’ll need to manually close Steam VR aswell, before you can start an other game.
     
  6. fleming23

    fleming23 Registered

    Joined:
    Feb 8, 2018
    Messages:
    5
    Likes Received:
    0
    Thanks, I'll give that a shot! I thought I tried at at some point yesterday but it seems like when I would put on the rift nothing would happen on the HMD.

    Edit - in the Steam Properties, should I go back and check the Desktop Game Theater setting or leave that unchecked?

    I just tried both ways and I am still in the outside house lobby place looking at all the Oculus home screen stuff not RF2 related (I'm sure it has a name, I just don't know what it is called.) I confirmed Steam was closed before opening RF2 and when I put the Oculus on. I'll reboot the PC and try again in a little while.
     
    Last edited: Feb 9, 2018
  7. albert39

    albert39 Registered

    Joined:
    Jan 30, 2014
    Messages:
    64
    Likes Received:
    7
    It looks like you don't have installed SteamVr
     
  8. fleming23

    fleming23 Registered

    Joined:
    Feb 8, 2018
    Messages:
    5
    Likes Received:
    0
    Okay, after a reboot and recalibration it works. I'm not sure what was done differently but opening RF2 and not touching Steam must have done the trick.

    Thanks all! I felt technologically incompetent last night!
     
  9. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,092
    Likes Received:
    1,336
    In some cases, depending the sequence I use to launch things, it won't work. However, I usually figure out the right combination after a while...
     
  10. dan_e10

    dan_e10 Registered

    Joined:
    Feb 17, 2018
    Messages:
    1
    Likes Received:
    0
    I see the VR options in Rfactor 2 settings. I just bought and downloaded Rfactor 2 from Steam yesterday. Is it still necessary to install the Directx 11 beta to use the Rift in Rfactor 2 or is it VR supported in the default load at this point? In Steam, my current Rfactor 2 properties beta tab had: opt out of all betas or something to that effect. I'm currently downloading the Directx 11 beta as I haven't been able to get the Rift to work with Rfactor 2 so far.
    Dan
     
    Last edited: Feb 17, 2018
  11. Bruce0440

    Bruce0440 Registered

    Joined:
    Apr 26, 2017
    Messages:
    68
    Likes Received:
    17
    Direct X11 is now default
     

Share This Page