VR stuttering problem

Discussion in 'General Discussion' started by elbo, Jun 25, 2018.

  1. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    580
    Likes Received:
    162
    Just got back from a rather lengthy work trip.
    Upon my arrival, I had a windows update and an oculus update. I also downloaded the new endurance pack.
    Now when I start a race with more than 1 AI I have these massive stutters rendering the game unplayable.
    When I exit rF2 back to the steam or oculus home the stutters remain in the HMD.
    I have to reboot in order to get rid of them.
    The work around is to enter rF2 with no AI and then add them progressively...doing this everything works as it did before.
    -Win 10, gtx 980, oculus rift.
     
  2. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,692
    Likes Received:
    1,057
    Thats an intersting workaround ! May have to give that a go .
     
  3. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    313
    Likes Received:
    96
    Consider background services/apps. I experienced a similar issue recently and by chance found that it was my AV [Bullguard] that was running a Game Booster. Had not caused any issues before the last Windows/Oculus updates. I switched off the Boost and rF2 ran normally in VR and screen only.
     
  4. Andregee

    Andregee Registered

    Joined:
    Jun 23, 2012
    Messages:
    815
    Likes Received:
    319
    I have the same problem since the latest oculus Update. My workaround is using the oculus tray tool on a separate screen, switch ASW from auto or 45fps to off than clicking with the mouse back into the game. After that its possible to activate ASW without that issue the same way.
     
  5. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    854
    Likes Received:
    523
    Don't run oculus software with steam vr running. To do that you give the Oculus software executable Administration Wright in the property settings. Then make sure you are opted out of the beta for Oculus and steamvr. Once you've done all that that restart the computer and fire up steam VR and open rfactor 2. Stutters should be gone.
     
  6. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    580
    Likes Received:
    162
    Ok Depco I will give that a shot.
    Where is the oculus executable located and what is the file name?
     
  7. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,692
    Likes Received:
    1,057
    How do I run steam and not Oculus ? If i run the rift ,Oculus always runs in the background !
     
  8. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    580
    Likes Received:
    162
    I changed oculusclient.exe to run as admin, this stops it from launching when I run steamvr. I opted out of beta for both steamvr and oculus. The steamvr window says that the headset is on and detected but the headset stays black.
    Interestingly I cannot toggle core 2.0 to off and revert to the original home in oculus because this too results in an black screen in the hmd.
     

Share This Page