vr, game always on top

Discussion in 'Bug Reports' started by C-Dric, Jan 20, 2021.

  1. C-Dric

    C-Dric Registered

    Joined:
    Jul 27, 2020
    Messages:
    8
    Likes Received:
    4
    Hello, the game preview is "always on top" when i play on VR. If i chose any option (window, borderless, no render, hmd only etc.) It's impossible to have another application on top of rf2 in vr mode.

    I use steam vr with pimax 5k+

    The only way i found to switch on another app while running the sim is to run rf2 on another virtual desktop. somone have a better solution ?

    Thanks for your help
     
    Max Melamed likes this.
  2. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    358
    Likes Received:
    213
    Agree. It's really annoying that you can't Alt-tab to another app, because rF2 is always on top.
    You can do this in every other sim (in VR), but not in rF2.
    The only workaround is to minimize all apps by pressing Win+D and then switching to the desired app. But that's quite cumbersome.
     
  3. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,716
    Likes Received:
    2,041
    This happens to me both with RF2 and MSF2020 (Microsoft Flight Sim) with VR so it's not a specific RF2 issue, what I do it make the Mirror Windowed so it's easy to move out of the way, that way there's no alt-tabbing needed, just the continual press of the Windows Key to allow Mouse movement away from the Sim in question.
     
    Woodee likes this.
  4. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,353
    Likes Received:
    529
    Remember that you can set your monitor window to windowed and less than the resolution of your monitor which makes it easier to navigate around, move or minimise if you need to. Just be aware that the window needs to be visible and fully on screen for the mouse pointer to work.
     
  5. Douglas Osterkamp

    Douglas Osterkamp Registered

    Joined:
    Dec 26, 2020
    Messages:
    2
    Likes Received:
    3
    You can use Win+D to minimize everything (RFactor included).
    This is the only way I found to remove the focus from RFactor and FS2020 when running in VR...
     
    juanchioooo likes this.
  6. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,353
    Likes Received:
    529
    Does the windows key not do it? As it does for me.
     
  7. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,208
    Likes Received:
    1,168
    :);) perfect:D
     
    Douglas Osterkamp likes this.
  8. Douglas Osterkamp

    Douglas Osterkamp Registered

    Joined:
    Dec 26, 2020
    Messages:
    2
    Likes Received:
    3
    In my case when I use only the Win key, I will see the taskbar temporarily but I am not able to change the focus even if I try to click anything else.

    With the Win + D, it will move the focus to the desktop (I think) and everything is minimized...
     
    atomed and juanchioooo like this.
  9. C-Dric

    C-Dric Registered

    Joined:
    Jul 27, 2020
    Messages:
    8
    Likes Received:
    4
    Yes i have this problème on rf2 and Automobilista 2.

    How do you windowed? It's a steam vr setting?
     
  10. C-Dric

    C-Dric Registered

    Joined:
    Jul 27, 2020
    Messages:
    8
    Likes Received:
    4
    Windows key works,you see the taskbar but whaterver you chose rf2 will be always on the top
     
  11. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,716
    Likes Received:
    2,041
    You click Play in Steam for RF2 you'll see an option to open up the Settings, go into that and you'll see a drop-down box to select Fullscreen, Windowed and Borderless
     
  12. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,353
    Likes Received:
    529
    That is why I make it smaller than my desktop size so I can access the minimise button or move the window to the side.
     
  13. C-Dric

    C-Dric Registered

    Joined:
    Jul 27, 2020
    Messages:
    8
    Likes Received:
    4
    Yes i've already tried this but it's seams like the game run always at full screen mod. I've just tried the solution of Woodee to change the resolution it works after restarting the computeur but even if the window is smaller i have to alt+tab to move the mouse out of the window game, and this window stay above averything :(

    I'm going to use the windows+D tips seams to be the better way to deal with this pb at the moment. Hope devs will make some adjustments for vr users
     
  14. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,353
    Likes Received:
    529
    It only works for me if I set to a lower resolution and windowed mode. Is your game not showing in windowed mode even after selecting it in the config?
     
  15. C-Dric

    C-Dric Registered

    Joined:
    Jul 27, 2020
    Messages:
    8
    Likes Received:
    4
    yes i've test several lower resolutions, but on each the little window is still at the top of everything.
     
  16. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,716
    Likes Received:
    2,041
    Yes and the answer is to move it out the way, then you can see stuff underneath :)
     
  17. C-Dric

    C-Dric Registered

    Joined:
    Jul 27, 2020
    Messages:
    8
    Likes Received:
    4
    Ahah of course MarcG that what i did :) wanted explain that the "always on top" problem still exist even on windowed mode.

    I do the windows+D tips now it's easier to use for me. Thanks for your help everybody !
     
    MarcG and Douglas Osterkamp like this.

Share This Page