Stuttering/Lags

Discussion in 'Technical & Support' started by Sid1968, Sep 3, 2019.

  1. Sid1968

    Sid1968 Registered

    Joined:
    Jul 31, 2018
    Messages:
    27
    Likes Received:
    7
    Hello,
    i have stuttering/lags in rFactor 2.

    Problem Description:
    I run the game with 19 other cars. FPS is good most of the time between 80 and more than 100. I drive mostly in Driverview. Most of the time no problem. With CTRL+C i start the little perfomance tool. The green bar shows the graficload and is always at 100%. Thats good. The violet bar shows the physics. While the physics stays under 100% i have no lags at all. When i drive together with the other cars i have no problem.

    But.... if i stop or have had an accident so that the other cars get out of sight... the violet bars goes up and up and up.. Now i go in the outside view and drive... the bar goes over 100% and the lags are starting. Why??? Normally it should be vice versa. The less cars are there the worser gets the perfomance... Thats crazy. Is it a bug?

    Help would be nice.

    You find my dxdiag.txt in the attachment.
    System: Windows 10 64 Bit, 32 GB Ram, Ryzen 7 1700 at 3800 MHz, ASUS STRIX Radeon RX Vega 64, SSD, AOC C32G1 Full-HD 1800R curved Display with 144Hz.

    AMD Driver Settings:
    Bildruckler - Grafikkarten Einstellungen.jpg

    rFactor 2 Settings:
    Bildruckler - rFactor 2 - Video Settings.jpg


    Kind Regards from Germany
    Sid1968
     

    Attached Files:

    Last edited: Sep 3, 2019
  2. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    209
    Likes Received:
    723
    Try this it worked for me. I have had no issues of any kind with this setting. have been running this for nearly a year now. You have 32gb so it shouldn't cause any problem. If you have a look at my profile you will see what my system consists of. If it doesn't work just change it back to false. Best of luck.

    I use to have similar stuttering to you, my solution was to set Record to memory to true in the player json. I have never had any stuttering since, runs silky smooth and have had no problems with memory usage.
    Open player json in notepad.
    Scroll down to the Game Options section and scroll down to.
    "Record To Memory":true,
    "Record To Memory#":"record replays to memory rather than disk (may possibly reduce stuttering, but at your own risk because memory usage will be significant for long races)",
    Hope this cures your problem
     
  3. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,062
    Likes Received:
    1,190
    I'd first try turning off GPU synchronisation from rFactor 2 config. I had bad experiences with GPU and Software sync, the only sync option that seems to work consistently well is Video, but it adds some input lag as well, so best is to test with sync off first.
     
  4. Tobias Pitzer

    Tobias Pitzer Registered

    Joined:
    Jul 6, 2018
    Messages:
    72
    Likes Received:
    15
    The video sync synonymous, if I put on video. I have set None there. Maybe even the post effects lower or switch off and see if there are any improvements.
     
  5. Sid1968

    Sid1968 Registered

    Joined:
    Jul 31, 2018
    Messages:
    27
    Likes Received:
    7
    Thank you Mates for you kind help. This is what i did to make rFactor 2 run without lags. I will try this a few days to test if it really works.

    At first i tried: "Record To Memory":true without success. On my Computer rFactor 2 runs from SSD so obvisiously it is fast enough.

    I) The Sync Options:
    1. "Video" makes rFactor 2 run with 60 FPS. I do not want this. My Monitor should run with more than this.
    2. "GPU" and "None" makes rFactor 2 run with sometimes more than 144 FPS... My Monitor runs at max with 144, so i dont nead more. Thats wasting resources.
    3. "Software" uses my Driversettings. I limited the FPS in Driver at 141 FPS (Read that in driver 3 Frames less than the Maximum of the monitor should be used.").

    So "Software" is what i take.

    II) I could recognize that the option "Fullscreen" causes more lags, so i changed it to "Borderless".

    III) Setting "Post Effects" to "None" makes the violet bar of the perfomance tool (CTRL+C) looks better.

    Bildruckler - rFactor 2 - Video Settings.jpg

    The violet bar shows problems with the Physics. So i set in the Ingamesettings "Shadows" from "Maximum" to "High" and the "Blur Effect" from "Max CPU Load" to "Min CPU Load".
    Bildruckler - rFactor 2 Ingame Anzeigeeinstellungen.jpg

    Since a few houres it runs fine. As i said above, i will test it a few days. If you read till then nothing more from me, this settings run fine

    Kind Regards
    Sid1968
     
  6. Sid1968

    Sid1968 Registered

    Joined:
    Jul 31, 2018
    Messages:
    27
    Likes Received:
    7
    Mmhhhh..... while ingame everything is fine... The Replayvideo sometime lags. "Record To Memory":true, didnt changed that...
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,342
    Likes Received:
    2,250
    There have been some reports of replay issues with the latest builds, so give it some time as it may not be something you can fix yourself.
     
  8. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    307
    Likes Received:
    148
    I've been getting one or two bad issues per session. Trying these settings and will report back later.
     
  9. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    307
    Likes Received:
    148
    Unfortunately no change for me with these. I have however also had nVidia's Low Latency thingy on Ultra. Will turn off and do some more testing.
     
  10. dylbie

    dylbie Registered

    Joined:
    Oct 25, 2012
    Messages:
    286
    Likes Received:
    281
    Guys I recently mentioned a bug to Marcel where the replays seem to be causing issues with certain HDV (physics) files I was working on.

    If I load a certain HDV file to a car, it runs fine in game, but then in the replay it maxes out the CPU bar, and everything runs in slow motion. I believe there's something major going on with the replays. They surely shouldn't be running physics or HDV, but they are, and are causing serious issues.

    Maybe I'll make a new thread with this. I wonder if it is some way linked to all the other stuttering and real time physics issues?
     
  11. Filip

    Filip Registered

    Joined:
    Feb 9, 2017
    Messages:
    780
    Likes Received:
    572
    Just an uneducated guess: could it be that the game records inputs and uses vehicle physics to recreate replay?
    Or am I talking nonsense?
     
  12. Tobias Pitzer

    Tobias Pitzer Registered

    Joined:
    Jul 6, 2018
    Messages:
    72
    Likes Received:
    15
    After trying a few things today to reduce the lags, I have now stayed with the following settings.

    In the Launcher at the video settings:
    Synchronization: Video
    Post Effects: None
    Mode: Fullscreen
    Anti Aliasing: Level 4

    In the graphics settings in the game:
    Antialiasing: Level 4
    VSync: Monitor
    FXAA: An

    In my graphics card settings (nVidia GTX960M) I have made the following adjustments for Rfactor2:
    Antistropic filtering: 8x
    Power management mode: Maximum power
    Texture Filtering - Antistrope Scan Optimization: On
    Texture Filtering - Negative LOD Bias: Clamp
    Texture Filtering - Quality: High Performance
    Vertical Sync: setting for 3D applications
    Pre-rendered Virtual Reality single images: 3
    Everything else left at global settings.

    The game runs to about 98% at a constant 60FPS (on my 60Hz monitor). Lags and also tearing I could not determine now.
     
  13. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    263
    Likes Received:
    79
    OK, I'm going to ask as no-one else has. Which version of rF2 is this? I do not have Max or Min CPU Load in my settings menu and I am currently on 1115.
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,342
    Likes Received:
    2,250
    Well spotted :)

    Looks like the game translation has changed from Off - Fast - Optimal - Quality to more straightforward descriptions of CPU load.
     
  15. Sid1968

    Sid1968 Registered

    Joined:
    Jul 31, 2018
    Messages:
    27
    Likes Received:
    7
    The Germans translation file is "DeutschCoU". On my first screen of ingamesettings you see where "Geringe CPU Auslastung" stand at BLUR. Look in your settings its the eights setting from above. Turn Blur OFF or take the next value.
     
  16. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    307
    Likes Received:
    148
    Tried all this but still the same for me. Just have to wait for S397 to fix. Thanks for the tips.
     
  17. Sid1968

    Sid1968 Registered

    Joined:
    Jul 31, 2018
    Messages:
    27
    Likes Received:
    7
    My settings are not for the Replayvideo-Lag-Bug! We have to wait for a fix.

    If you have lags/stuttering ingame and my settings do not work, just press ingame CTRL+C to start the perfomance tool. Look at the purple bar. Lower graficingame settings so that the purple bar stay under 100%...Thats all. ;-)
     
  18. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    307
    Likes Received:
    148
    Yeah, I'm getting it in game and my cpu bar is only at a third. No FPS issues either. It has only started happening on the last couple of builds so I will be patient.
     

Share This Page