Strange lag even though FRAPS shows 90 FPS?

Discussion in 'Technical & Support' started by Racefreak1976, Oct 18, 2015.

  1. Boldaussie

    Boldaussie Registered

    Joined:
    Aug 16, 2015
    Messages:
    127
    Likes Received:
    22
    One quick question, may be obvious but the obvious is also easily overlooked. What sync is everyone that is having these problems, using in the rfactor video prefs? video, gpu or software?
     
  2. whitmore

    whitmore Registered

    Joined:
    Feb 26, 2012
    Messages:
    552
    Likes Received:
    142
    Tried them all. No difference
     
  3. matf1

    matf1 Registered

    Joined:
    Dec 27, 2011
    Messages:
    671
    Likes Received:
    2
    I know this issue is not a one size fit's all, however I had similar behaviour with Shadowplay running. It's not outside the realms of possibilities that some have this auto loading on startup.
     
  4. bernds

    bernds Registered

    Joined:
    Dec 23, 2015
    Messages:
    2
    Likes Received:
    0
    Hard to say whether this is the same issue, since the OP deleted his video. Here's my problem description: although the frame rate as shown by fraps seems to be reasonably even (but not great), movement of the world around me is very uneven/stuttering. In some cases the car seems to move very slowly for almost a second, followed by a very brief period where everything moves very rapidly to "catch up" so to speak. The effect is more pronounced on some tracks such as Spa 1966. I also suspect that this affects not just the graphical display but also the physics engine, since a lot of the cars are behaving unpredictably (no such effect occurs in other programs such as GTL, GTR 2, AC, GSCE). Basically, the game is unplayable. I tried to record the effect with fraps, but the video playback seems a lot smoother than what showed up during gameplay.

    My system:
    Westmere 6-core Xeon 3.3GHz
    12G RAM
    nvidia GTX 650
    DFGT

    I tried turning down all sorts of graphical effects and also played with the sync option. No real change. Changing precomputed frames to 1 in the nvidia driver seems to have caused a small improvement but the problem is still there.
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,438
    Likes Received:
    6,625
    Press Ctrl-C and see what the purple part of the graph is doing. If the bar is shooting across to the right it's your CPU causing it (that's what it sounds like). Your CPU has hyperthreading, speedstep, and turbo boost. Try disabling those.
     
  6. Boldaussie

    Boldaussie Registered

    Joined:
    Aug 16, 2015
    Messages:
    127
    Likes Received:
    22
    This one has been going on for a very long time, especially those attempting to run sli or crossfire setups with multiview where it is an unsurprisingly common issue. I run a fairly low end single AMD card (270x)and an AMD 8350 processor. I use multiview, I run max 55 fps (capped at 58) and a low of 44 fps with 10 AI, shadows and reflections off, triple buffering with rfactor2 vsync OFF and dynamic vsync via radeonpro. I have turned AUTODETAIL fps = OFF. I don't get any tearing because of the max frame rate my card will handle at the settings I am comfortable with. ANY excessive heat will cause throttling of your CPU and/or GPU (stuttering) and if your PSU is not up to par, low wattage/voltages can cause the same. Ensure all your temps are staying COOL under extreme loads before and only then stuff about with the software/player.json settings, beginning conservatively and working up. If you run a multigpu setup with multiview...you deserve the headaches...LOL I thought my system ran way cool under loads, I was VERY wrong when trying triple screen fallout4, that's a damned good stress test....be careful if using crimson drivers, fan may not auto boost under loads and cause overheating/gpu failures

    Merry Christmas to all
     
    Last edited by a moderator: Dec 23, 2015
  7. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,084
    Likes Received:
    2,933
    I would have liked to compare my problem with that from Racefreak1976, also.

    My problem is/was, that i had a lag as if the Car was attached to an elastic band.
    The Car slowed down and accelerated alternately (no it wasn't me :)).

    What did solve it for me, was again adding the +procmask=X ( i have 4 Cores and use X=2 to use just 1 Core) in the Launchers Command-Line.
    And... the Game runs normal, as it does before.

    Maybe that can help others too, that have similar Problems.
    But it seems as if an already solved Bug came back.
     
  8. bernds

    bernds Registered

    Joined:
    Dec 23, 2015
    Messages:
    2
    Likes Received:
    0
    Ok, I tried all sorts of things now. Using the "maximum performance" plan in Windows, using the +procmask trick, setting "skip Updates" to 3, setting "Monitor Auto Replay" to false. I think I'm imagining that performance has gotten a little better and the cars maybe seem a little more driveable, but the disconcerting stutter effect is still there, especially at low speeds, and framerates still tank occasionally. This isn't something I'm seeing in any other sim, past or present - they all work much better out of the box than rF2 does after an hour of tweaking. At the moment this means I'll be recommending against rF2 whenever someone asks.
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,438
    Likes Received:
    6,625
    Did you disable the CPU features I mentioned above?
     
  10. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    That would be unfair, as for 99% of the people it works perfectly out of the box.
     

Share This Page