Stop VSYNC to avoid latency OK, but how to have a smooth game ?

Discussion in 'Technical & Support' started by dadaboomda, Aug 20, 2017.

  1. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Hello everybody.

    I was told to avoid using the VSYNC to avoid latency in a simulation.

    So I wanted to avoid the vsync but the image tears and seems not fluid.
    [Also I have a bug by activating vsync: it seems to only activate when I do CTRL + F (to see the FPS).]

    I tried to fix the max framerate a 60 in the unsuccessful player.json with vsync disabled in the game and in the control panel nvidia.

    TECHNICAL DETAILS :
    - gtx 780 asus dcu II: overclocked to 1114 for the gpu and 6430 for the gpu memory (I insist that the overcloking is totally stable).
    - i5 2500k overclocked 15% associated with 16GB of ram blocked by motherboard has 1376 mhz.
    - full hd monitor and 60 hz, in game mode (52 ")

    In-game graphics settings:
    * Post process on ultra
    * Full hd
    * 60 hz
    * Anti aliasing on level 5 BUT enhanced in nvidia settings (i come)
    * Game settings = all the way except special effects has high and low car reflections.
    * FOV has 36
    * Activated mirrors
    * Accelerations time off and other accelerations to normal to help the processor
    * The player.json has NOT been modified (except for auto cluch and auto lift)

    - Settings nvidia:
    * Fxxa = no
    * Gamma correction = yes
    * Aa = improve the application parameter
    * 8x csaa
    * Aa transparency: multiple sampling
    * Shade cache: active
    * Anisotropic: x16
    * Distortion lod negative = fixation
    * High quality texture, no trilinear optimization or anisotropic sample
    * Maximum performance
    * Threadee optimization on auto
    * Maximum pre-defined frames on 1

    * For now I have the nvidia vsync enabled associated with the triple buffer.

    For information in vsync I am a 95% of the time has 60fps and I use almost as mods in "directx 11". By cons the only circuit on which I play is in "directx 9".

    I thank you in advance !
     
  2. patchedupdemon

    patchedupdemon Registered

    Joined:
    Jan 3, 2017
    Messages:
    1,602
    Likes Received:
    1,151
    Turn off vsync,run a race with as many ai you will be wanting to usually race against,keep an eye on your fps over a few laps,note down mentally what the lowest fps was,then set it too that number in the files,if it's a number that is a multiple of 60 then change it to an uneven number,so 61,81,91,or what ever,this way you will not get the tear in the same place every time,if tearing and stuttering continue.
    Disable superfetch and user comparability telemetry,in windows services too.

    Post processing is a waste of resources imho at the moment so turn it off or put it on low,put shadows on low too,shadows kills fps,for not much improvement from Low to high.
    If you turn these two settings down your fps should greatly improve and you can run with no vsync or fps limit at all and be butter smooth,as I do,the higher fps you run,the better for latency/lag,it's a myth that there's no benefit to running more fps than the monitors refresh rate.


    Hope this helps
     
  3. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,864
    Likes Received:
    1,475
    Pick a prime number, not just odd (or "uneven", LOL). Avoid being near multiples of the halfframe number (e.g. avoid being near 30, 60, 90, etc if you use 60 Hz refresh; for 75 Hz refresh, that would be 37.5, 75, 112.5, etc.).
     
  4. patchedupdemon

    patchedupdemon Registered

    Joined:
    Jan 3, 2017
    Messages:
    1,602
    Likes Received:
    1,151
    That's the words I was looking for,I was drunk earlier when I wrote that as I'm on holiday lol

    Thanks for putting my foolishness right
     
  5. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,214
    what gets me is input lag with vsync.///!!! placebo or what?

    I want to know exactly how much of a difference, if any - you can see of lag on screen. Ive ran with it vsync on, since ive started and my wheel pretty much always matched up to my movements on screen. If theres any lag its not visible to the eye and not effecting my steering.

    I have a 144hz benq know and even with vsync off theres ever so slight tearing (no where as bad as on my 60hz before ( that was distracting to say the least). I also read that without any sync there will be a tear of frames whether your under youe displays refresh rate or not? Even though my rf2 doesn't go over 144 fps at all (hovers around the 80-120 fps) I'm considering putting vsync on to stop ALL tearing, no matter how slight.

    I'm just a bit confused right now with refresh rates and sync etc - and the notorious input lag that I cant actually see?!
     
    Last edited: Aug 21, 2017
  6. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Thank you very much !

    - I understood that it is necessary to deactivate vsync and triple buffering
    - watch the minimum fps in non-ideal conditions (large and numerous shadows, sunrise or sunset)
    - identify that my monitor is 60 hz

    On the other hand I'm sorry, I would need some examples ... I'm not sure I understood the following 100%.
    In addition I have a hard time understanding English and Google translation is bad.

    For example if my minimum fps is 40 (assumption), what should I put in max framerate?

    - Knowing that the prime numbers above: 37, 41, 43, 47, 53, 59, 61, 67, 71, 73, 79, 83, 89, 97 ......
    - Half the frequency of my monitor is 30 hz :
    so if my minimum fps is 40, should I choose 37 or 41 or even 43, 47.

    Could you explain the reasons for this choice please? I do not want to abuse too much ...

    Knowing that the vast majority of the time I have 60 FPS.

    Thank you very much, it's nice!
     
  7. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,864
    Likes Received:
    1,475
    For your 60 Hz TV in game mode, set max framerate to one of: 67, 71, 73, 79, 83, 97. The prime number means that if there's a frame tear, it takes (67, 71, 73, 79, 83, 97) frames before it can ever repeat in the same spot, thus it will be many frames until the screen tear can repeat in the same place. Max framerates of 89 and 61 are too close to the halfframe rate, so a screen tear will gradually scroll up/down the display. If you occasionally drop below 60 fps, you might notice a screen tear if it stays below 60 fps more than a second.

    With the newer NVidia cards (I think the 780 qualifies), you can also choose Fast vertical sync and not bother with in-game Vsync. Fast vertical sync works best if you can have 120+ fps for a 60 Hz monitor; at a minimum, your fps should never drop below about 63 fps, so if you're seeing the occasional 45 fps, then it's probably not a good choice for you. Definitely try it out if it is available for you because you may find it is "good enough".

    upload_2017-8-20_15-46-51.png
     
    patchedupdemon likes this.
  8. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,214
    ive been reading up on the fast sync thing.. and cam across this that actually suggest you can use fast for even when your frames are below refresh rate.

    http://www.overclock.net/t/1601321/fast-sync-howto

    I can notice the slight tearing - but only when I train my eye on certain straight objects, but I found below the 144hz of my displ, that fast is perfectly ok no stutter no tearing and unnoticeable lag.. Tried on Rf2 and AC.
     
    Last edited: Aug 21, 2017
  9. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Thank you all.

    But I have a problem, I can not try to apply the Emery method ... There is a big bug.

    (When I called you my settings were:
    - max framerate in player.json = 60
    - vsync enabled in nvidia control panel)

    Since I have :
    - disabled the vsync in the game, the settings of the game and in the control panel nvidia
    - deactivated the triple buffering
    - AND ESPECIALLY: tried several values of prime numbers above 60 (monitor 60 hz) = 73 and 83.

    RESULTS?
    The fps appear set to max 62 (ctrl + F). Why ???!
    Unfortunately, I can not test this. I spent a week finding the best compromise to have with my little machine very good graphics, for that ........

    Please help me !!!!!!!
     
  10. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Sorry, I didn't said : with gt 780, I have not fast vsync.
     
  11. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    828
  12. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    I downloaded nvidia inspector yesterday. In the vsync part I set a max framerate to 60, activity vsync and triple buffering.

    I did not find the QUICK SYNCHRONIZATION option.
    Can you tell me or has it and what is the name of this option in nvidia inspector?

    TO NOTE :
    I had a max framerate in the player.json was 60. When starting a game had jerked without ANY reason. It's as if the max framerate was blocked at 62 FPS. It became fluid and vsync seemed to really activate ONLY *** when I activated the view of the FPS by doing CTRL + F ***.
    With nvidia inspector this seems oddly resolved ......

    What a pity that this formidable simulation is:

    - so hard to set when you have a moderately powerful PC (not enough intermediate settings in the graphics)
    - No official tutorial (to adjust graphic options intelligently, but also other options affect performance [example: acceleration time, no intermediate adjustments on the mirrors in the interface, etc.], a minimum option fps framerate which in my opinion not optimized and no tutorial to define it intelligently, etc.
    - a beta version from 5 ****** 5 ****** years (this is not the 397 studio fault, OK.
    - There are a lot of bugs when I read that the beta version would become official in 1 or 2 months ...

    Like many of you, I am "fidele" a rf2 for 5 years ... only for three reasons:
    - physics are the best
    - the FFB is the best
    - Content is good (especially ISI content and I hope the future studio content 397).

    Well here I have a little off topic, but it is necessary to say it. I am not sure that the guys who have gtx 980, gtx 980 ti or gtx 1080 realize how hard it is to configure rfactor 2.

    The performance problems are more and more unacceptable: we actually spend more Of time to try to find a good compromise quality / performance WHAT TO PLAY REALLY ....

    Apart from rf1 and rf2 but also wii and wii U, I have not played any video games for 15 years. Unbelievable !! I saw a friend's graphics playstation 4 the other day. I've alluded. It is magnificent and ultra fidele: it is possible because it is ultra optimized .... why not optimize as much rf2 !! And I checked, this is a console and not a computer, on a 52" screen there was virtually no aliasing : ***aliasing, shadows (aliasing and LOD depending on the distance of the" Shadow) are the biggest graphic problems of rf2 ET ... oddly what kills the most FPS despite the shadow blur in quality and the details of the shadows to the maximum*** ::::::::::::::: }}}} OPTIZATION PRIORITY ??????

    Well I stop my off topic !!
     
  13. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,321
    Likes Received:
    1,443
    You should not be tweaking any settings from Nvidia Inspector and use defaults only with rF2, this is the last official word I heard from the developer. Use in-game settings to enable vsync or simply add frame limiter (max framerate in player.JSON), frame limiter is better than vsync because it adds less input lag.
     
    patchedupdemon likes this.
  14. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,321
    Likes Received:
    1,443
    Since you listed your CPU as i5-2500k, then I presume you have PCI-Express 2.0 only. rF2 has massive performance loss on PCI-E 2.0 with modern GPU's, see this thread. So if you want good performance with high shadows, the only way is to get a motherboard with PCI-E 3.0.
     
  15. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,214
    or just use fast sync in the nvidia profile. Thats proven to have faster latency then sync on. With sync off on my 144hz 2560 display, rf2 is the only game that that tears and stutters horrendously and runs crap at over 100fps?! . Activate fast sync and its smooth again.

    Doom and AMS i can run sync off and its pretty much tearless!

    I think rf2 struggles at higher fps, it has done in the past with portugal and that was fixed. Maybe other tracks need looking at too?
     
  16. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Hello Stonec, thank you for your answer.

    In fact, I spent a gigantic time these last 15 days to get the best graphics with great performance despite my small gtx 780 overclocked not bad but stable.

    My problem is no longer the graphics settings in the game and in the nvidia control panel.

    My problem is to try to decrease the latency due to the use of vsync.

    For this, I want to block the maximum framerate in the game (player.json). BUT I HAVE A BIG BUG (again ...) :

    ----- >>> even when I try a number like 83 or other prime numbers above my TV refresh rate (60 hz).
    The max framerate is blocked at 62 FPS : so there are enormous screen tears.

    NOTE If I set a max framerate below 62, it seems to work.

    I did a test and I actually with the vsync a lot of latency.
     
  17. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    828
    Nvidia Control Panel don`t have fast sync as option if you have 780 card but Nvidia Inspector has (Vertical Sync) fast sync.
    NV inspector.jpg
     
    Emery likes this.
  18. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,864
    Likes Received:
    1,475
    Remember to turn off VSYNC in-game if you're using Fast Sync.
     
  19. TravisRoe666

    TravisRoe666 Registered

    Joined:
    Jan 31, 2012
    Messages:
    40
    Likes Received:
    3
    the sad thing about all of this is setting rf2 up to be smooth was usually no issue.
    Sync: Video
    AA: Level 4
    Res: 1920x1080 or max you think reasonable
    FXAA / MSAA start with FXAA work upwards to using only MSAA levels if / when your card can handle it. some ppl prefer FXAA + MSAA or just FXAA.

    Regardless, is this situation due to dx11? Rfactor2's engine usually runs over 80fps in almost every situation
     
  20. muz_j

    muz_j Registered

    Joined:
    Aug 20, 2014
    Messages:
    264
    Likes Received:
    187
    Personally I use NVidia's Adapative vsync option in my GPU drivers and override the game

    Description from Nvidia:
    Nothing is more distracting than frame rate stuttering and screen tearing. The first tends to occur when frame rates are low, the second when frame rates are high. Adaptive VSync is a smarter way to render frames using NVIDIA Control Panel software. At high framerates, VSync is enabled to eliminate tearing. At low frame rates, it's disabled to minimize stuttering. For a superior solution, which eliminates stuttering, tearing and the addition of VSync-related input lag, see our G-SYNC technology page.

    List of supported GPU's (does not include 10xx series cards, but does include supported GPU's up to the 9xx series): https://www.geforce.com/hardware/technology/adaptive-vsync/supported-gpus?field_gpu_type_value=All

    ...in short, as per nvidia's comments, it's the best of both worlds with vsync.
    And if your monitor supports gsync, then you should using that (mine doesn't, so I run adaptive).
    My comments aren't definitive though - the best thing is to try the settings out and test the game, then choose whatever works best for you.

    Info on enabling gsync is nicely covered here:
    https://www.howtogeek.com/270672/how-to-enable-optimize-and-tweak-nvidia-g-sync/
     

Share This Page