Steering Wheel Problem

Discussion in 'Technical & Support' started by Harry Chanter, Jan 27, 2017.

  1. Harry Chanter

    Harry Chanter Registered

    Joined:
    Dec 28, 2016
    Messages:
    16
    Likes Received:
    1
    So the other day i got onto rfactor 2 and it was all good until my friend crashed the car then the steering wheel turned way too sensitive, what i mean by that is that if i turned the wheel 90 degrees it would turn 180 degrees on the game so i looked everything up and found nothing so i deleted and reinstalled the game. When it was complete i went back on to the game it was all good did a couple laps made sure everything was good then let my friend drive again and i watched him the whole time so no settings where changed but when he crashed the same thing happened again although the complete opposite now when i turn my wheel 180 degrees it only turns 90 degrees on screen so i restarted the session nothing restarted the weekend still the same quit the game completely relaunched it and it was still happening and it is happening right now and it is really slowing down my lap times and pissing me off so someone please help me .
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,295
    Likes Received:
    6,543
    What wheel? What settings?
     
  3. Moiker

    Moiker Registered

    Joined:
    Jan 31, 2017
    Messages:
    3
    Likes Received:
    0
    Hello,
    I'm having the same kind of issue which Logitec G27. I'm trying to solve this reinstalling my drivers, but which no success.

    Looks like a specific problem with Windows 10, G27 Logitec Profiler and rF2, at least in my machine.

    Please help me to clarify this:
    I realize that in Logitech Profiler, for me, doesn't matter what degree rotation I've selected in "Global device Settings" or "profile settings", in "G27 properties" the "steering wheel motion" animations only rotates to max 180 degrees (90 for each side). Physically the wheel rotates correctly but the animation stay in the same range. This is normal for any OS or is it a win10 glitch?
    See image below:
    Logitech Profiler:
    [​IMG]


    G27 Properties:
    [​IMG]

    If I setup the G27 to 900 degrees in the Logitech Profiler, the "G27 properties" shows Steering wheel movement"always rotates to max 180 degrees (90 for each side). But physically the wheel rotates at 900 (450 for each side), that means I get a wheel factor of 180: 900 = 1/5. So rF2 does not seem to adjust proper the rotation and keeps this weird factor in game, even if check "allow the game to adjust settings".
    I figure out that if I set the angle to 180 in Logitech Profiler, the wheel will synchronize to the game wheel, but limiting to this rotation angle its impossible to play.

    Sorry about the English. Please let me know if you guys figures out.
     
  4. Gijs van Elderen

    Gijs van Elderen Registered

    Joined:
    May 1, 2014
    Messages:
    1,393
    Likes Received:
    469
    [​IMG]

    Most have spring and damper effects at 0% and use the ingame "smoothing".

    But the most important thing is to "Allow Game To Adjust Settings".
    rF2 sends the car specific Degree of Rotation to your wheel if "Vehicle set" is enabled.


    In this case rF2 will send 540 degrees to your wheel.
    [​IMG]
     
    Moiker likes this.
  5. Skan

    Skan Registered

    Joined:
    Dec 14, 2014
    Messages:
    333
    Likes Received:
    135
    Put Your Logitech settings back to default. Put Your rFactor 2 settings back to default. Allow game settings as was said above me. You should then calibrate the wheel in rFactor 2. Here is a video that shows what to press to calibrate the wheel. When You are done the wheel will match the wheel on the screen and all driving will be fun again.



    There is no audio on purpose. That way the video needs no translation.
     
    Moiker likes this.
  6. Moiker

    Moiker Registered

    Joined:
    Jan 31, 2017
    Messages:
    3
    Likes Received:
    0
    I really appreciate the help guys.

    I did this steps below and successfully fix the rotation problem:

    1. Uninstall all G27 Drivers and rF2, restart machine.
    2. Reinstall Logitec G27 drivers and profile using a different USB port.
    3. Reinstall rFactor 2 and mods.
    4. Setup the Logitec profile as Gijs Van Elderen suggested.
    5 Start rFator 2 and configure the game options as the Skan videos shows, setting "vehicle set" off and define "steering wheel range" as 270 degree.

    Works greatly well, thanks for the help !
     
    Last edited: Feb 2, 2017

Share This Page