[SOLVED] Solved! Devmode wont start up

Discussion in 'Technical & Support' started by peterchen, Apr 23, 2018.

  1. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Hi everyone,
    after years I decided to work on an AIW again for a certain track which is a wonderful track (Paulmarcs Zolder), but has no usable AI. Just because I have time and feel like it.
    However, I used to use an old non-steam installation and it´s devmode. But it seems it has bugs or flaws that got me to stuck at some point.
    Long story short: tried the devmode in actual build and it doesn´t fire up!
    Just a black screen and PC is hanging,- have to do a hard-reset. (video settings in launcher done!)
    I swear, I´ve read in this very forum about same problem one time, but yeah..... as you all know search-function is useless.
    Thanks in advance,
    Pete
     
  2. Daniele Vidimari

    Daniele Vidimari Registered

    Joined:
    Apr 20, 2016
    Messages:
    650
    Likes Received:
    576
    As i wrote in the official 1.1100 thread, i have issue with devmode too. My rF2 crash right after the loading bar is full, no matter which car/track i load, always "rFactor 2 has stopped working".
    Steam plugin is the only one activated, video settings are the same i use in single/multiplayer and with the prevoius build, HUD is the original one.

    EDIT!
    I just moved off all the cars i had in the vehicles folder (i left only the Skip Barber) and now it works o_O
     
  3. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Mhh, removing all content one will work with out of Devmode doesn´t make much sense, so....
     
  4. Daniele Vidimari

    Daniele Vidimari Registered

    Joined:
    Apr 20, 2016
    Messages:
    650
    Likes Received:
    576
    Of course is not the ideal situation, but in my case was only one content which made rf2 crash, i've restored everything except this one.
     
  5. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    286
    Aaaaaah! Solved! Was my anti-BS-gadget.
    Sorry guys, could have thought of it earlyer...:rolleyes:
    Always the same with this kind of programs....
     
  6. jpalesi

    jpalesi Registered

    Joined:
    Sep 15, 2011
    Messages:
    367
    Likes Received:
    231
    I also have the problem. I removed other cars besides the Skip Barber, and it still crashes for every track.

    gJed is gone, and my viewer looks like this. Or crashes.
    [​IMG]

    Any idea please ?
    rF2 is so tiring... :(
     
  7. Leonardo Nogueira

    Leonardo Nogueira Registered

    Joined:
    Apr 1, 2016
    Messages:
    238
    Likes Received:
    286
    My dev mode is crashing when finish loading... then returns to desktop. The normal game works fine.
    I tried to reinstall the DX and nothing... try to full reinstall rF2 from zero and nothing... deleted all unoficial content in devmode and nothing!
    I don't know what can I do. If somebody have any clue I will be thankfull!
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,930
    Likes Received:
    3,424
    You should really start a new thread, as this one says Solved and people tend to reply to previous posts when you dig up an old thread. Try posting your trace file, devmode should create them automatically. Any antivirus software? What plugins do you have installed? (devmode will use the same as your normal game)
     
  9. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    679
    Hello Leo.
    I would suggest to rename your current ModDev folder and then to verify the game by steam.
    It will download a fresh ModDev folder.
    Don't put something into it and try to start it.
    If it crashes, post the trace file, as @Lazza has said.
    If it works, you can put your own content into it, folder after folder, until it crashes again, to find out which content causes the crash.
     
  10. Leonardo Nogueira

    Leonardo Nogueira Registered

    Joined:
    Apr 1, 2016
    Messages:
    238
    Likes Received:
    286
    Thanks mates, I will try!
     

Share This Page