Slowing Down

Discussion in 'Technical & Support' started by adamb, Jul 5, 2017.

  1. adamb

    adamb Registered

    Joined:
    Jul 5, 2017
    Messages:
    2
    Likes Received:
    0
    So in the summer sale i bought rf2 but i got an issue with the sim.
    The sim slows down at random moments, like once or twice per 4 minutes. I'm on a DFGT in a low end PC but my bro got the same and he's running smooth. Only difference is he's running on a G27.
    When i press CTRL-C, the purple bar is maxed out if anyone wants to know and my graphics are at the lowest and i think that means my CPU is overloaded so if anyone got solutions, hit me up.
    (I can run AC and iRacing with no issue)
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,088
    Likes Received:
    2,871
    Don't know your system specs (like CPU type), but if you really have identical specs to your bro and he is fine then check for background processes. You might have something that's occasionally taking more CPU time than the game can afford. Regarding the CPU itself, if it has power saving or clock-altering features (speedstep, turbo, etc) try disabling those (usually in the BIOS).

    rF2 isn't AC or iRacing, so unfortunately you can't judge them against each other like that. rF2 needs consistent timing (at 100Hz, I believe) or it will fall out of realtime.
     
  3. Ozzy

    Ozzy Registered

    Joined:
    Dec 18, 2013
    Messages:
    277
    Likes Received:
    26
    Look into your rfactor2/UserData/player/Controller.json. There is an option "UseThread" or something like that. Make sure it is enabled.
    Some drivers can't handle the high FFB update rate, which in turn leads to blocking of the main physics thread.
     
  4. BluesAdam

    BluesAdam Registered

    Joined:
    Apr 18, 2017
    Messages:
    55
    Likes Received:
    31
    Edit: UseThread command worked like a charm. There is no stutter at all. Thanks a lot Ozzy!

    I am having a similar issue lately. In silverstone, right before the entrance of Farm corner, the game stutters for one tenth of a second. Does this each lap but for the rest of the track there is no problem. Validating game files didn't help either. This is with Nissan GTR GT500 on Silverstone GP layout.

    @Ozzy I will try this setting and let you know if it helps. Thanks for the advice.
     
    Last edited: Jul 5, 2017
  5. adamb

    adamb Registered

    Joined:
    Jul 5, 2017
    Messages:
    2
    Likes Received:
    0
    worked for a little bit, but I came to the conclusion that my PC is overheating, but thanks for the advice!
     

Share This Page