Single player- practice session : AI stop running after 20 minutes

Discussion in 'Technical Archives' started by Mydriaz, Oct 21, 2012.

  1. Mydriaz

    Mydriaz Registered

    Joined:
    Jan 16, 2012
    Messages:
    953
    Likes Received:
    42
    I don't know if it's a bug but I've noticed that in single player- practice session with default session setup (Time session = 120 mns and time acceleration set to X5) all AI cars go to garage after about 20 minutes.
    Whatever time session settings (1 or 2 hours), AI cars seem to run out of petrol and stop on track while racing.
    Then they will stay in pits during all the remainder of the session...
    Maybe I found that it's due to time acceleration (here set to X5 by default).
    If you set time acceleration to "normal" all is ok, AI cars stay on track during all practice session !!
    So actually this is the only way to race with other cars all session long without having graphical benefit of this nice option :(
     
  2. Christian Rosén

    Christian Rosén Registered

    Joined:
    Feb 7, 2012
    Messages:
    137
    Likes Received:
    1
    Same for me...
     
  3. Flaux

    Flaux Registered

    Joined:
    Oct 5, 2010
    Messages:
    948
    Likes Received:
    379
    Same here...
     
  4. MrDarceh

    MrDarceh Registered

    Joined:
    Dec 23, 2011
    Messages:
    59
    Likes Received:
    1
    I have the same issue
     
  5. tjc

    tjc Member

    Joined:
    Jun 4, 2012
    Messages:
    5,849
    Likes Received:
    335
    I have had a similar issue although not quite the same as my problem was in an offline race at Monaco with the 60`s F2`s...

    6 lap race that I crashed out of after a lap and half but I let the AI carry on. They got to lap 5 and just slowed right down to walking pace and continued like this for lap after lap, even going over the 6 lap limit. I think they`d just have gone on and on if I`d let them but I stopped them after they done nearly 8 laps...

    :confused:
     
  6. Mydriaz

    Mydriaz Registered

    Joined:
    Jan 16, 2012
    Messages:
    953
    Likes Received:
    42
    :::EDIT:::
    I've made a mistake : This is wrong : If you set time acceleration to "normal" all is ok, AI cars stay on track during all practice session !!
    Unfortunately, time acceleration seems not to be the problem. All AI cars still stop on track and stay in pit after 20 minutes of practise session...
     
  7. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,197
    Likes Received:
    269
    AI do that in multi-player rooms too. We had 60s F3, they did 5 or 6 laps, run out of fuel, then stay in the pit for the rest of the session.
     
  8. Flaux

    Flaux Registered

    Joined:
    Oct 5, 2010
    Messages:
    948
    Likes Received:
    379
    I always use time-accl. @ normal and have the issue that the AI runs out of fuel, stop on track, port back to pits and never start again...
     
  9. F1Fan07

    F1Fan07 Member

    Joined:
    Jan 11, 2012
    Messages:
    626
    Likes Received:
    46
    Also offline. I ran a 50 lap offline race at Palm Beach with 30 AI to test my PC. I pulled into the pits after one lap and parked the car... when I came back to the PC an hour later only 9 of the AI had finished. I watched a few of them earlier in the race and they just drove until the fuel ran out. At one point I saw a full course yellow due to the cars that were parking on the side of the road and I suspect the 9 finishing cars were the ones that pitted on yellow.
     
  10. Minibull

    Minibull Member

    Joined:
    Sep 28, 2012
    Messages:
    1,559
    Likes Received:
    19
    Same problem here too, thought I may as well mention it. Seems for most tracks and cars, the AI run 5-6 laps. At Mid-Ohio with the F2's, they all manage 7 laps. At Spa with the 60's F1's, they manage 4 odd.

    This has been quite annoying for me, as in NZ with the time zone diff, i can never find anyone to race with online. That leaves me with singleplayer only. With what seems to be the reduction in the speed of rubber buildup in the new build, I now have to sit and fast forward time, wait till the AI stop, boot them all, add them back into the game, let them run till they stop, etc etc.
    I can't go and do a long stint, as they all finish in a few laps, leaving me on my own.
     
  11. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    126
    Thanks.
     
  12. Wheelzpin

    Wheelzpin Registered

    Joined:
    Feb 16, 2012
    Messages:
    35
    Likes Received:
    10
    I've also noticed that the AI never pit. Even if they have enough fuel for the race, they continue after the checkered flag, until they run out of fuel.

    In the release notes for 118 it mentions work on the AI to make them pull over when they run out of fuel. Perhaps while working on this, the devs disabled pitting for the AI and simply forgot to enable it before 118 went out?
     
  13. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,197
    Likes Received:
    269
    That is what I think too.
    A temp solution for now is to set 'Fuel Usage' to Off works for me. I also set 'Mech failures' to off too as I found half of the AI's engines pop or their gears brake in races, too.
    View attachment 4522

    DJC
     
  14. MikeZ

    MikeZ Member

    Joined:
    Oct 11, 2010
    Messages:
    94
    Likes Received:
    1
    This will be fixed next build. All AI pit logic was accidently disabled some time in the past few weeks.
     
  15. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    Great news; thank you :)

    byyyyyyyyye
     

Share This Page