SOLVED Server not visible on the Public Lobby

Discussion in 'Hosting Help' started by MaD_King, May 16, 2019.

  1. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,827
    Likes Received:
    611
    Hello, I need some help. I try to have a dedicated server for rF2 on a dedicated PC, but my internet provider block the port over 64000.

    So I changed my port in Multiplayer.json like this: "HTTP Server Port":55297 & "Simulation Port":54297

    Following this tutorial I opened my Router NAT ports: https://docs.studio-397.com/users-guide/setting-up-a-dedicated-server
    The open ports are:
    UDP+TCP 54297
    TCP 55297
    UDP 55298
    UDP 55299

    But the server is not visible in the Lobby. Any idea?

    When I try to connect with a direct connection (using +connect on a Client) I can connect to the server.
    @Marcel Offermans
     
    Last edited: May 16, 2019
  2. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    755
    No idea and no tip from my side, sorry.
    I sometimes have the same problem, but it is not understandable for me.
    Sometimes the server appears in the list, sometimes it doesn't.
    And i always use the same server and settings.
    Sometimes i have the suspicion, that a kind of invisible filter is applied to the list.

    In rfactor 1, that problem could be solved by raising the number of shown servers, in the plr file.
    But this option is not present in rfactor 2 as it seems.
     
  3. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,827
    Likes Received:
    611
  4. Christopher Elliott

    Christopher Elliott Registered

    Joined:
    Jul 31, 2014
    Messages:
    4,551
    Likes Received:
    7,538
    Did you add the ports to the windows firewall as well?
     
  5. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,827
    Likes Received:
    611
    Just checked, all is open in input/output for the ...\rfactor2-dedicated\Bin64\rFactor2 Dedicated.exe file.
     
  6. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,417
    Likes Received:
    964
    Use Ctrl+Alt+Del to check how many instances of rfactor 2 dedicated.exe you have running on the dedicated PC compared to servers you have running.
     
  7. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,827
    Likes Received:
    611
    Only one.

    I made a test now with the ports
    TCP 63297
    UDP 63298
    UDP 63299
    No change :(

    If I test with this tool the TCP 54297 & 63297 ports from an another PC, they are indicated as Opened !!
    https://www.yougetsignal.com/tools/open-ports/
     
  8. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,417
    Likes Received:
    964
    This dedicated PC is on your local network or on a remote server?
     
  9. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,827
    Likes Received:
    611
    Is it solved,
    So a summary about the updates I done (thank you to your support on rF2 Discord).

    First point, the server was not visible from rF2 Steam Lobby because the C++ Runtimes was not installed.
    So on a PC with a rF2 dedicated SteamCMD server, you need to run the 4 exe files available in the following folder:
    rfactor2-dedicated\Support\Runtimes\vcredist_2012* & vcredist_2013*

    So @Christopher Elliott we need an update on the official tutorial https://docs.studio-397.com/users-guide/setting-up-a-dedicated-server to add the runtime installation after SteamCMD dedicated installation.

    But it's not all, because my server is hosted in the same local network of my rF2 Client I need to change the HTTP port to 27013 to be able to see in the lobby on my rF2 client too.

    So the configuration in the Multiplayer.json is: "HTTP Server Port":27013 & "Simulation Port":54297
    So in my router I opened these ports:
    UDP+TCP 54297
    TCP 27013
    UDP 27014
    UDP 27015


    With that the server is visible on the rF2 lobby for me and other player over internet.

    Thank you all for your support !!!
     
    Last edited: May 20, 2019
  10. Aldo Martinello

    Aldo Martinello Registered

    Joined:
    May 5, 2020
    Messages:
    6
    Likes Received:
    1
    Hi, ciao,
    i've followed step by step, your indications, and now i can see in lobby LAN the server up
    But internet NO.

    Any tips ??
    Thank you.
     
  11. Aldo Martinello

    Aldo Martinello Registered

    Joined:
    May 5, 2020
    Messages:
    6
    Likes Received:
    1
    Solved..
     
  12. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    3,043
    Likes Received:
    1,959
    What was the problem?
     
  13. Aldo Martinello

    Aldo Martinello Registered

    Joined:
    May 5, 2020
    Messages:
    6
    Likes Received:
    1
    I've used original ports of the guide of RF2 + your indication ports

    tks
     
    lagg likes this.
  14. RicoF

    RicoF Registered

    Joined:
    Nov 13, 2012
    Messages:
    6
    Likes Received:
    0
    Hi, I have laptop running server and my friends see it in the public lobby, however I cannot see it from the same location. If I use port 27013, I see it on LAN but then my friends do not see it in public... any idea? Thanks!
     
  15. Diogo Tenan

    Diogo Tenan Registered

    Joined:
    Mar 19, 2022
    Messages:
    1
    Likes Received:
    0
    Aldo, How you setup the other ports on the Multiplayer.JSON? Because on that, only appears The HTTP and Simulation Ports.
     
  16. Validamar

    Validamar Registered

    Joined:
    Jan 30, 2022
    Messages:
    21
    Likes Received:
    0
    The server is on the same home network
    11111111.jpg

    2222222222222.jpg
    Hello everyone, set everything up as in the description, but in the public room my server is not available
     
  17. LikeMike

    LikeMike Registered

    Joined:
    Dec 18, 2021
    Messages:
    14
    Likes Received:
    0
    check LAN, if your game/server is the same PC
     
  18. Validamar

    Validamar Registered

    Joined:
    Jan 30, 2022
    Messages:
    21
    Likes Received:
    0
    I see the server on the LAN, but the rest of the users don't see it in the ENTERNET list
     
    Last edited: May 19, 2022
  19. Validamar

    Validamar Registered

    Joined:
    Jan 30, 2022
    Messages:
    21
    Likes Received:
    0
    Server on another computer
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,452
    Likes Received:
    6,630
    Why do your UDP ports seem to be pointed to a different IP? 54297, 27014-27015.

    By Mad_King's example you just need
    TCP 54297
    TCP 27013
    UDP 54297
    UDP 27014-27015

    All pointing to your server.
     
    Validamar likes this.

Share This Page