Running more than one dedicated server

Discussion in 'Hosting Help' started by philmcqueen, Jun 14, 2016.

  1. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288
    Hello everyone,

    i´ve post s thread few days ago regardin g a setting problem to start a dedicated server. The problem has been solved ( Thanks to Juergen Muench , Goanna and the guide available on steam ;) )

    Everything is working fine.

    Now i try to run few dedicated at the same time.This is what i´ve got :

    A clean install:

    View attachment 20159

    The right "paste" in the shortcut properties:
    "C:\rFactor2-Dedicated\Bin64\rFactor2 Dedicated.exe" +path=".."

    View attachment 20160

    I have create in the userdata folder a folder named: player_02
    C:\rF2Racing\rfactor2-dedicated\UserData

    View attachment 20161

    In this folder, in the multiplayer.JSON , i have updated and change the port number and open it in the window firewall UDP, and TCP

    LINE 29: 64 297
    LINE 65: 54 297

    "HTTP Server Port":64297,(UDP: 54297, 64298, 64299,)
    "Simulation Port":54297 (TCP: 54297, 64297,)


    The right "paste" at the end of the shortcut:
    +profile=player_02
    View attachment 20162


    The Dedicated.EXE of the second server start
    View attachment 20163

    But i only can choose the profile "player" and not "player_02" (maybe there is nothig to do )
    View attachment 20164

    So i keep on the process ans at the end i have this message:
    View attachment 20165

    But i confirm ports are correcly open the the firewall .This is what i´ve done

    UDP:
    "HTTP Server Port":64297
    "Simulation Port":54297
    GSR_01: 54297, 64298, 64299,


    "HTTP Server Port":64297
    "Simulation Port":54297
    GSR_02: 54397, 64398, 64399,


    "HTTP Server Port":64397
    "Simulation Port":54397
    GSR_03: 54497, 64498, 64499,


    "HTTP Server Port":64497
    "Simulation Port":54497
    GSR_04: 54597, 64598, 64599,


    "HTTP Server Port":64597
    "Simulation Port":54597
    GSR_05: 54697, 64698, 64699,




    TCP:
    GSR_01: 54297, 64297,
    GSR_02: 54397, 64397,
    GSR_03: 54497, 64497,
    GSR_04: 54597, 64597,
    GSR_05: 54697, 64697,

    Any suggestion are welcome ;)
     
  2. floreacalin

    floreacalin Registered

    Joined:
    May 9, 2014
    Messages:
    137
    Likes Received:
    2
    Nothing to do just with the ini file, make shure you triple check the ports in the ini and router

    Sent from my Nexus 5X using Tapatalk
     
  3. floreacalin

    floreacalin Registered

    Joined:
    May 9, 2014
    Messages:
    137
    Likes Received:
    2
    Make shure the ports are different for the servers also, obviously :)

    Sent from my Nexus 5X using Tapatalk
     
  4. Christopher Elliott

    Christopher Elliott Registered

    Joined:
    Jul 31, 2014
    Messages:
    4,551
    Likes Received:
    7,538
    Did you also rename your player.JSON -> inside the player_02 folder?

    You need to rename it player_02.JSON
     
  5. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288
    Okay after a triple check ;)

    Ports numbers series:

    "HTTP Server Port":64297
    "Simulation Port":54297


    UDP+TCP 54297
    TCP 64297
    UDP 64298
    UDP 64299

    So here it is:

    TCP: player: 54297,64297, player_02: 54397,64397, player_03: 54497,64497, player_04: 54597,64597, player_05: 54697,64697

    UDP: player: 54297,64298,64299, player_02: 54397,64398,64399, player_03: 54497,64498,64499, player_04: 54597,64598,64599, player_05: 54697,64698,64699

    Yes player.JSON is renamed has player_02.JSON :)

    View attachment 20167
     
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,288
    Likes Received:
    6,538
    Is it still only showing you the 'player' profile when you run each different shortcut? It sounds like that's where the issue could be?
     
  7. Christopher Elliott

    Christopher Elliott Registered

    Joined:
    Jul 31, 2014
    Messages:
    4,551
    Likes Received:
    7,538
    The target field (or "cible" in your case) for your shortcut should be like this:

    "C:\....\rFactor2 Dedicated.exe" +profile=player_02
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,288
    Likes Received:
    6,538
    Yeah, it's actually not clear what the target is finally set to. Make sure it has the +profile in it, plus the +path if you want to go that way (I think you can change the working folder ("Demarrer dans"?) up one level with the same effect)

    *The shortcut name, as shown on the desktop, makes no difference to anything
     
  9. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,987
    Likes Received:
    1,023
    It's useful to use Noel's "Dedi Manager" for these settings?
     
  10. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288
    This is what i have: rFactor2 Dedicated.exe +profile=player_02
     
  11. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288

    You mean this:

    View attachment 20171

    Yes
     
  12. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,200
    Likes Received:
    1,295
    Your cible should read like this "C:\rFactor2-Dedicated\Bin64\rFactor2 Dedicated.exe" +path=".." +profile=player_02
     
  13. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288

    Okay i will have a look back home, but i think what i am missing is the : +path=".." before the "+profile=player_02"

    Thanks for the support ;)
     
    Last edited by a moderator: Jun 15, 2016
  14. Wishmaster

    Wishmaster Registered

    Joined:
    Nov 30, 2012
    Messages:
    315
    Likes Received:
    32
  15. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288
    So...............Finally it works !!!!!

    The cible must be : "C:\rF2Racing\rfactor2-dedicated\Bin64\rFactor2 Dedicated.exe" +path=".." +profile=player_02

    Thank you guys for your help...Special thanks to nibiru for the final solution ;)
     
  16. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,987
    Likes Received:
    1,023
    Server manager above makes these shortcuts without typing anything.
     
  17. Christopher Elliott

    Christopher Elliott Registered

    Joined:
    Jul 31, 2014
    Messages:
    4,551
    Likes Received:
    7,538
    In your original screenshot it shows you had +path=".." in there already but the +profile=player_02 is missing, so I was a bit confused.

    It should still work without +path=".." but we recommend still adding it, so that's correct.

    Anyway glad you got it sorted :)
     
  18. philmcqueen

    philmcqueen Registered

    Joined:
    Mar 14, 2011
    Messages:
    695
    Likes Received:
    2,288
    Thanks Christopher
     

Share This Page