[REL] rFactor2 Log Analyzer ver. 2. With offline and league Championship Manager

Discussion in 'Other' started by Nibo, Apr 15, 2015.

  1. Nibo

    Nibo Registered

    Joined:
    Oct 12, 2010
    Messages:
    2,275
    Likes Received:
    1,000
    Ravioli, sorry, no, too much work. This is core concept in r2la: championships have one or more races. One race has only one results report. I would be fighting every system in code that is already built if I would introduce rounds and multiple race results in one report.

    For cases when you need several races on one track, just create several races with indexed names, like "Silverstone1", "Silverstone2" or "Silverstone S", "Silverstone F". You can use manual points correction if points are different for every race. Or there is an option to assign a "Points preset" for a race (this is faster than manually setting points for every second race). Select a race in championship, press "Edit race", then select "Custom points preset" and press "Save changes". Before this you will need to create and save your custom points preset on "Edit Championship" page.
     
    atomed and Corti like this.
  2. Ravioli

    Ravioli Registered

    Joined:
    Jul 7, 2020
    Messages:
    22
    Likes Received:
    8
    @Nibo That's okay, I understand. Thanks for the elaboration, and for the tool again of course :)
     
  3. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    343
    Likes Received:
    251
    Hi Nibo
    I get this error using the latest RC (1132) where no results are being recorded. Tried on 2 x PC's same issue.
    No drivers, no data
     

    Attached Files:

  4. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    744
    Likes Received:
    230
    Hello, you better post the result xml file here ...
    Maybe there is new data that breaks r2la readings.
     
    buzz hornet likes this.
  5. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    343
    Likes Received:
    251
    It won't let me upload xml files or even rar/zip files. Also can't paste - too long.
    I can send via email if you like, I have about a dozen xml from tonight. Also found it is not even recording results in some instances.
    Def seems to be something up with 1132, 1131 was fine.
     
  6. Nibo

    Nibo Registered

    Joined:
    Oct 12, 2010
    Messages:
    2,275
    Likes Received:
    1,000
    buzz hornet likes this.
  7. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    343
    Likes Received:
    251
    https://easyupload.io/moqlrp
    There you go, as stated some xml is not even produced - see attached includes all my stuff I did tonight that was recorded. I ran the 1986 mod just before, and no records of it exist.
     
  8. Nibo

    Nibo Registered

    Joined:
    Oct 12, 2010
    Messages:
    2,275
    Likes Received:
    1,000
    All this logs have no <driver> tags at all. Almost all data for r2la is in those tags. Looks like a bug in rF2 build.
     
    buzz hornet likes this.
  9. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    343
    Likes Received:
    251
    Thanks I’ll roll back to 1131 and just check if everything is fine and not some strange error on my end.
     
  10. Booth_doberman

    Booth_doberman Registered

    Joined:
    Oct 5, 2015
    Messages:
    187
    Likes Received:
    84
    I finished a race at Monaco and wanted to look at the results. Although the log file exists and LogAnalyzer sees it, it is apparently devoid of necessary data. I assumed the version I was running, 2.058.34, was just too old so I downloaded 2.1.013. It still doesn't work. My last "good" log appears to be from Jan 28. I compared a "good" log and at a "bad" log. Both logs were from 45-minute races. The "bad" log has less data than the "good" log. The good log has a section that starts with <Driver> and has info for each driver. That whole Driver section is missing from the bad log.
    EDIT: I just saw your comment above that you know about the missing data.
     
  11. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,409
    Likes Received:
    959
    Yep, current bug with the release candidate. For the time being you can setup a SteamCMD server and join it then the xml files the server writes are all good. PITA I know but if you really want to have correct results, it’s the way to go until S397 fix the problem, or roll back to 1131.
     
    Corti and Nibo like this.
  12. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    744
    Likes Received:
    230
    Hello, just remembering the "multiple driver" case is really annoying. I really need a good workaround ... correcting it manually is really not a good option.
    I often use the Test day mode and it happens a lot ... I was adding manually @<vehicule> for each session, but it's really annoying to do on a full automatic thing ...
    Any clever ideas ?
     
  13. Ravioli

    Ravioli Registered

    Joined:
    Jul 7, 2020
    Messages:
    22
    Likes Received:
    8
    I have the SharedMemory plugin installed and enabled on my server and started the r2la_live_timing.bat file before I booted my server. The Livetiming page on LogAnalyzer keeps polling for sessions though, even when there are people driving on the server. What could I be missing?
     
  14. Nibo

    Nibo Registered

    Joined:
    Oct 12, 2010
    Messages:
    2,275
    Likes Received:
    1,000
  15. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    744
    Likes Received:
    230
    Nibo likes this.
  16. PetSpi77

    PetSpi77 Registered

    Joined:
    Apr 6, 2021
    Messages:
    11
    Likes Received:
    7
    Excuse me new here and I don't know what you mean by RC3. I have the same problem , r2la is giving no drivers, no data at my logs.
    Could you please help? Thanks
     
  17. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    744
    Likes Received:
    230
    RC3 means RC Update 3 or third iteration of last realease candidate.
     
  18. Nibo

    Nibo Registered

    Joined:
    Oct 12, 2010
    Messages:
    2,275
    Likes Received:
    1,000
    I don't know for sure if it is fixed. Some people in that thread were writing that logs still don't have data for them. I have no way to check, I don't host servers.
     
  19. DanRZ

    DanRZ Registered

    Joined:
    Aug 22, 2021
    Messages:
    744
    Likes Received:
    230
    Mine seem to work fine ...
     
  20. Ravioli

    Ravioli Registered

    Joined:
    Jul 7, 2020
    Messages:
    22
    Likes Received:
    8
    Thanks @Nibo, installing the runtimes did the trick. Sorry for the ignorance, should've noticed that help page..
     
    Nibo likes this.

Share This Page