[WIP] rFactor Import/Export Scripts for Blender

Discussion in 'Third Party Content' started by Traveller, Jun 17, 2015.

  1. Chris Lesperance

    Chris Lesperance Registered

    Joined:
    Nov 29, 2012
    Messages:
    1,038
    Likes Received:
    1,150
    The 3dSimEd smoothing fixes most problems, but I've had some situations where it doesn't fix all of them.
     
  2. DiggerHawk

    DiggerHawk Registered

    Joined:
    Jul 29, 2020
    Messages:
    45
    Likes Received:
    27
    Hi,
    I have been playing around trying to improve the look of the CART Factor mod as a learning tool, but I have an issue. My goal is to increase the smoothness of all the different steering wheels included in the mod. I have successfully achieved this for several of the wheels included using Blender 2.79 and the 0.78 script. Unfortunately when it comes to the Ford wheel any change to the mesh results in a complete mess up of what I presume are the normals. My method that worked correctly for the other meshes is to import to blender, clear the blue sharp edges, complete my modifications then apply a split edge modifier to separate the flat areas from the smoother areas. I found that if I leave the sharp edges as they are from the GMT import it results in weird normals. I have the mesh set to Vertex in the output panel. I am also a bit confused whether the script makes use of the auto smoothing setting or if that's just for display purposes in blender.

    Below is a screenshot taken in rFactor 2 of the Ford wheel that has been imported with just the "try to convert triangles to quadrangles" option selected and I believe the sharp edges have been removed and a split modifier applied. The mesh looked correct in blender, unfortunately in rFactor 2 it looks like this.
    [​IMG]

    The issue seems to be specific to this mesh as I haven't had this problem with the others and I even tried repeating the procedure on the same wheel using the lower poly version used for LOD switching and that was successful.

    Any help would be appreciated as this is very frustrating.

    Mark.
     
  3. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    533
    Likes Received:
    335
    My guess would be that it's not the script but your workflow in Blender.

    Please try the following (all in edit mode with all vertices selected):
    - clear the sharp edges (as you did before)
    - recalculate the normals (CTRL + N)
    - remove doubles (CTRL + V, select "Remove Doubles" from the menu)
    - set shade to smooth (left panel, "Shading / UVs" tab, use smooth under "Faces")
    - add "Edge Split" modifier

    Now switch to object mode and
    - duplicate that model
    - apply the modifiers
    - export that copy only

    The idea would be to remove any disturbing or flat normals and even unweld vertices that result in sharp edges.
     
  4. DiggerHawk

    DiggerHawk Registered

    Joined:
    Jul 29, 2020
    Messages:
    45
    Likes Received:
    27
    Thank you FuNK for your assistance. I followed your suggested workflow, unfortunately it didn't solve the issue. Looking back I think the image I posted earlier was with sharp edges un-cleared. I am glad you suggested removing them as I thought I was doing it wrong. The result of your workflow gave me similar results to what I was getting when I remembered to clear the sharps. There wasn't any doubles to remove so that wasn't the issue. In the end I solved the problem by applying a bevel modifier to the edges of the central 'T' shaped section, using the bevel weight function. As you can see from the screenshot below this solved the issue, which I presume was because of it being a large flat area. I also added the Edge Split modifier with a setting of 50 degrees to break up the smooth from the flat areas.

    [​IMG]
    Here is my modified wheel with a less faceted rim. I also scaled up the textures for the wheel and cockpit, re-doing the labels so they looked better. Along with a more accurate dash.

    There are many ways to control the normals in Blender its just about finding which way works best for rFactor 2. I think I have a better understanding of vertex smoothing and how to control it now.

    Mark
     
    FuNK! and Hazi like this.
  5. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    533
    Likes Received:
    335
    Anyway, glad you got it solved. Even more because it seems not an issue that directly relates to the plugin :D
     
  6. DiggerHawk

    DiggerHawk Registered

    Joined:
    Jul 29, 2020
    Messages:
    45
    Likes Received:
    27
    The plugin is great! Blender isn't bad either. I don't really understand why Studio 397 doesn't support Blender instead of 3ds Max. Blender is free so its widely accessible.

    The issue seems to be my own lack of skill.
     
  7. hvamberto

    hvamberto Registered

    Joined:
    Mar 8, 2021
    Messages:
    1
    Likes Received:
    0
    Is there already a version for Blender 2.82?
     
  8. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    533
    Likes Received:
    335

Share This Page