rfactor 2 not working please help

Discussion in 'Technical & Support' started by chris king, Feb 1, 2018.

  1. chris king

    chris king Registered

    Joined:
    Feb 1, 2018
    Messages:
    6
    Likes Received:
    1
    every time i choose a track and car, it loads up to the track and then freezes and kicks me of. ive tried uninstall and reinstall. which has done nothing any ideas??
     
  2. Rujasu

    Rujasu Registered

    Joined:
    Feb 2, 2018
    Messages:
    11
    Likes Received:
    14
    Does it never work at all? This has started happening on my laptop, but trying with fewer AI drivers seems to work.
     
  3. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    1,703
    Likes Received:
    863
    Can you post more information, like system specs, game settings, etc.
     
  4. Rujasu

    Rujasu Registered

    Joined:
    Feb 2, 2018
    Messages:
    11
    Likes Received:
    14
    Well, on my end I have an Asus N56V:
    i7-3630QM @ 2.40GHz
    Nvidia Geforce GT 635M
    8Gb of RAM
    Win10

    It's modest but at least it used to run. I did a small experiment:

    Here's the display settings.
    [​IMG]

    Here's the sessions settings that crash for me. One AI car less started just fine. If I start the session with less than 8 AI in this case, I can freely mash the Add AI button once the session is loaded and the game does not hang.
    [​IMG]
     
    Last edited: Feb 3, 2018
  5. chris king

    chris king Registered

    Joined:
    Feb 1, 2018
    Messages:
    6
    Likes Received:
    1
    Hi
    Right so I click on rfactor2, it connects to my account, I choose single player. It then lets me choose a track and car.
    In the display options I have everything set to low.
    I click race, it loads up the track and when it loads to the pits it then freezes and tells me rfactor2 has stopped working and makes you close the program. It does this with every track and every vechile. Then it sends you back to the beginning every time. The internet cable is plugged directly into the back of the computer and it's a brand new computer with only rfactor2 and steam on it. Any ideas what's wrong?
     
  6. chris king

    chris king Registered

    Joined:
    Feb 1, 2018
    Messages:
    6
    Likes Received:
    1
    Windows 10
    Core 2 duo e8400 @ 3.00ghz
    Hard drive 1tb sata
    Graphics card nvidia Gforce Gt 710
    I have also uninstalled and reinstalled everything and still does exactly the same
     
  7. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    1,703
    Likes Received:
    863
    Do you have any plug-ins running? Do you have riva tuner running?
     
  8. chris king

    chris king Registered

    Joined:
    Feb 1, 2018
    Messages:
    6
    Likes Received:
    1
    What do you mean?
     
  9. chris king

    chris king Registered

    Joined:
    Feb 1, 2018
    Messages:
    6
    Likes Received:
    1
    I don't know what either Is
     
  10. Dave schulz

    Dave schulz Registered

    Joined:
    Feb 8, 2018
    Messages:
    8
    Likes Received:
    1
    Help same issue. no plugin or rivertuner-worked fine 2 days ago now shuts down right away and loads by pop up says stopped working??//
     
  11. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    1,703
    Likes Received:
    863
    Do you have the latest video drivers? Nothing has changed in rf2 in the last two days, so it's most likely your computer.
     
  12. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,389
    Sometimes after major W10 updates the vcredist executables need to be installed again.
     
    bwana likes this.
  13. chris king

    chris king Registered

    Joined:
    Feb 1, 2018
    Messages:
    6
    Likes Received:
    1
    I turned my al drivers to 0 and everything works now. It's a brand new gaming computer but my graphics card needs upgrading.
     
    bwana likes this.
  14. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,010
    Likes Received:
    843
    What Spakis said above re run widows real-time executables . 2 windows updates ago l had my first issues in years. This fixed it
     
  15. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,010
    Likes Received:
    843
    yep not the best of cards for current game demands , glad you found it and accepted it !
     
  16. Dave schulz

    Dave schulz Registered

    Joined:
    Feb 8, 2018
    Messages:
    8
    Likes Received:
    1
    What is this "re run widows real-time executables" mean and how to do it.
     
  17. Dave schulz

    Dave schulz Registered

    Joined:
    Feb 8, 2018
    Messages:
    8
    Likes Received:
    1
    its not my computer, have windows 8, and everything has worked fine in Rfactor2 until 2 days ago. Still get the pop up close. No plugins used.
     
  18. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,389
    You need to install visual c redistributables.
    You have them under rF2/support folder.
    There are 4 exe installation executables.
     
  19. Kaitsu_69

    Kaitsu_69 Registered

    Joined:
    Jan 13, 2012
    Messages:
    73
    Likes Received:
    4
  20. Dave schulz

    Dave schulz Registered

    Joined:
    Feb 8, 2018
    Messages:
    8
    Likes Received:
    1
    and where do I find rF2/support folder.?
     

Share This Page