rFactor 2 1098, why so dark ?

Discussion in 'General Discussion' started by jymp, Oct 20, 2016.

  1. jymp

    jymp Registered

    Joined:
    May 26, 2013
    Messages:
    264
    Likes Received:
    73
    Build 1098 has a overall dark look for me, it looks overcast even when the sun is out, I read folks say it's HDR settings, how do you adjust HDR settings so the sim isn't so dark ?
     
  2. Lgel

    Lgel Registered

    Joined:
    Jun 24, 2014
    Messages:
    1,242
    Likes Received:
    326
    Sorry, I don't share at all your findings.
    When sun is shinning tracks look bright enough on my monitor.
    Cheers.
     
  3. jymp

    jymp Registered

    Joined:
    May 26, 2013
    Messages:
    264
    Likes Received:
    73
    Not for me...
     
  4. Wishmaster

    Wishmaster Registered

    Joined:
    Nov 30, 2012
    Messages:
    309
    Likes Received:
    30
    Maybe a screen shot of what you consider to be dark is helpful?
     
  5. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    Most lightly (no pun intended) because you are used to NOT use HDR, and therefore used to self illuminating objects, when the sun is not high or the sky clear, it will naturally look less bright.
     
  6. jymp

    jymp Registered

    Joined:
    May 26, 2013
    Messages:
    264
    Likes Received:
    73
    How is the HDR adjusted, or can it be ?
     
  7. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,774
    Likes Received:
    1,371
    First make sure your monitor is on "vivid" rather than cinematic.
     
  8. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    854
    Likes Received:
    523
    Well I think the question now is, "How does he adjust the HDR settings?". An answer to that question would be appreciated rather than telling him that his monitor may be the problem. I would answer but I don't know the answer to that question.
     
  9. jjcook

    jjcook Registered

    Joined:
    Apr 12, 2012
    Messages:
    327
    Likes Received:
    58
    there is no HDR adjustment, you used to be able to turn it off but it was removed because the game is meant to run with it on
     
  10. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    854
    Likes Received:
    523
    Thanks Cookie. That was what I think the OP was looking for.
     
  11. F1Fan07

    F1Fan07 Member

    Joined:
    Jan 11, 2012
    Messages:
    626
    Likes Received:
    46
    Vivid is going to make colours look crappy and is a band-aid. OP would be better off to ensure the monitor is in RGB or sRGB colour space, a neutral mode like Normal (or whatever it's called on his monitor) and then set brightness and contrast via any number of Googlable how-tos.
     
  12. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,774
    Likes Received:
    1,371
    Yea, I sorta agree with that. Depends a bit on the monitor. Main thing is to get out of the dim modes some people put their monitors in.
     
  13. Ho3n3r

    Ho3n3r Registered

    Joined:
    Feb 18, 2012
    Messages:
    527
    Likes Received:
    96
    You can still turn it off via setting GFXSafeMode to 1 in config.ini
     
  14. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    And get purple sky and bright nights... RF2 is ment to be HDR ON.
     
  15. Guimengo

    Guimengo Guest

  16. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,774
    Likes Received:
    1,371
    In the config.ini there is:
    GFXSafeMode=0 // 1=fallback to LDR mode, you must manually clear shader cache

    Which suggests that clearing the shader cache might be worthwhile for the OP, but how do you do that?
     
  17. Gijs van Elderen

    Gijs van Elderen Member

    Joined:
    May 1, 2014
    Messages:
    1,396
    Likes Received:
    466
    If you have graphic bugs and want to revert back to default:


    - Set your nvidia control panel for rFactor 2 to default !!! It messes with the Config.ini and shader cache !!!
    - Clean up your "UserData/log/CBash" and "UserData/log/shader" folder (delete al containing files)
    - Remove the player.json and config.ini (cut/past to desktop to keep a back-up)

    - launche rF2 it will create a new clean config.ini and player.json + new shader files (First launche will be longer)
    - Set your graphic settings again: only use settings available in rF2.
    - Set controller again or Load your saved controller file


    Quote from Tuttle (ISI Dev)

    Starting from a clean installation, with a clean player/config file, the best way to proceed with graphics settings is to JUST use ingame settings, pushing on high AA levels and anisotropic filtering x8 or x16 (and of course good track/car quality settings)...and that without overriding anything via inspector and/or CCP.

    (Also HDR must be ON if you want a proper modern lighting.)

    This way you can load the game and check how it looks. If you see trees are looking properly (no alpha jaggies) and texture are sharp enough to see details into it (aniso texture filtering), you can decide to be happy (and stop tweaking)...or start experimenting extra settings, outside the game.

    But this is the time where you can mess with profiles and configs, so you have to check every single step, and every single click you are doing with CCPs and inspectors, to see how things are working. May happen a CCP/Inspector change is going to mess the config.ini and cache... and you can't just roll back from those settings, without cleaning up that file (aka generating a brand new one). Same for the Players.JSON and Transparency AA, or xpaa, using False to make wrong trees looking better and then making correct trees looking wrong.

    Still, the easy way to make the game looking at best, is to go easy peasy, with standard ingame settings. This is where you are working inside our choices, instead playing with a very big mix of variables we can't control.
     

Share This Page