rF2 Crash

Discussion in 'rFactor 2 Support (Supporto Tecnico)' started by Salvuss, Sep 10, 2013.

  1. Salvuss

    Salvuss Registered

    Joined:
    Nov 5, 2010
    Messages:
    171
    Likes Received:
    0
    Salve ragazzi, ciao Max. Apro questo thread perché negli ultimi giorni mi è capitato spesso di riprendere in mano rF2 (notando che mi piace sempre di più) ma allo stesso tempo mi sono capitati tanti, tantissimi crash. Ho scaricato tutto il materiale per accedere ai server ISR con le Megane ma, appunto, mentre talvolta riesco a stare una sera intera senza alcun problema, altre volte (come ad esempio oggi) non riesco proprio a stare dentro il server che vengo buttato sul desktop con l'odiosa scritta "rFactor 2 ha smesso di funzionare".
    Ora, mi rendo conto che non vi sto dando alcuna informazione utile, ma vorrei capire da cosa può dipendere. Qualcuno soffre dei miei stessi problemi? La scheda grafica è una mediocre ATI5750 1GB.
    Se può servire, proprio oggi, che è il giorno in cui ho avuto il picco dei crash (tre in meno di un'ora) ho un po' smanettato con le configurazioni video abbassando un po' i dettagli perché volevo un gioco più fluido specialmente nelle fasi di partenza.
    Sinceramente sono un po' amareggiato per questo problema, visto che giusto oggi mi ero iscritto al campionato endurance su RaceDepartment :(

    PS: chiedo scusa se la sezione è quella sbagliata, in caso spostate pure!
     
  2. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Salvuss, ti posso dire che rF2 è abbastanza stabile e che i rari CTD sono circoscritti al momento del cambio sessione.

    Insomma, capire la ragione del problema non è semplice.

    Per prime ti dico le prove che richiedono meno tempo ...

    disinstalla tutti i plugin addon che eventualmente hai installato.

    Se non risolve vai in Support/Runtimes ed esegui vcredist_x86.exe.

    Prima di inserirlo tra i componenti di installazione la sua assenza, prima della build 49, era causa di CTD apparentemente random, un po' come capitano a te, benche il messaggio di errore di sistema era quello di errore di runtime, quindi differente da quello generico che vedi tu, però è una prova senza controindicazioni e che richiede pochi secondi.

    Se non risolve, prova ad eseguire, in Support/DirectX, DXSETUP.exe.
    Se d3d9.dll o altri files della DirectX fossero corrotti, reinstallare i componenti DX necessari a rF2 potrebbe risolvere.

    Se anche questo non risolve prova a disinstallare F2, a spostare la cartella Packages in una cartella temporanea e buttare tutte le altre che rimangono dopo la disinstallazione (quelle che fanno parte del secondo percorso di installazione ell'intaller), poi a dare una passata al registro con CCleaner

    http://www.piriform.com/ccleaner/download

    e con ogni altro pulitore di registro fidato che hai, poi a reinstallare rF2 in una nuova cartella, copiando dopo l'installazione la vecchia cartella Packages.

    In questo modo dovrai fare anche un nuovo player, ma nel tuo caso è d'obbligo.

    Se i CTD persistono la quinta prova che farei (soprattutto se il driver video non è recente) è quella di installare il driver più recente per la tua scheda.

    Prudenzialmente, disinstalla il driver attuale, poi fai un reboot in modalità provvisoria ed esegui Driver Sweeper

    http://www.guru3d.com/content_page/guru3d_driver_sweeper.html

    (chiaro, fai attenzione a selezionare esclusivanente la rimozione del display ATI).

    A questo punto riavvia il PC in modalità normale e installa il driver aggiornato.

    Se nemmeno questo risolve riposta, cmq se vai in Strumenti di Amministrazione--->Visualizzatore Eventi--->Applicazione
    e selezioni l'errore di rF2 (doppio clic sulla linea dell'errore) quale è il modulo che crasha?
    Ogni crash segnala sempre lo stesso errore?
     
  3. Salvuss

    Salvuss Registered

    Joined:
    Nov 5, 2010
    Messages:
    171
    Likes Received:
    0
    Max intanto grazie per la risposta! Non ho alcun plugin installato quindi la prima prova sostanzialmente salta. Prima di sobbarcarmi questo lavoraccio certamente impegnativo per me che non sono un asso dell'informatica, ti confermo che il messaggio generico è sempre lo stesso. Ho anche notato che dopo aver riattivato l'FXAA ieri sera non ho più subito alcun crash. Possibile che fosse legato a questo aspetto?
     
  4. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ci sono segnalazioni di schermo nero con HDR e FXAA attivati contemporaneamente, non di CTD che io sappia, però non si può escludere. :)

    Che driver grafico hai?
     
  5. Salvuss

    Salvuss Registered

    Joined:
    Nov 5, 2010
    Messages:
    171
    Likes Received:
    0
    Ho i 13.2, provo ad aggiornare Max
     
  6. Carra

    Carra Registered

    Joined:
    Jan 14, 2012
    Messages:
    844
    Likes Received:
    1
    ciao salvo, metti i "13.6 beta 2" ;)
     
  7. Salvuss

    Salvuss Registered

    Joined:
    Nov 5, 2010
    Messages:
    171
    Likes Received:
    0
    Ho messo i 13.4, gli ultimi ufficiali e nessun crash stasera. Tra l'altro ho guadagnato una decina di FPS! Vediamo ancora un po' e speriamo tutto bene.
    PS: ho notato degli scattini (stuttering) quando la gente entra su un server. Questo è normale, vero?
     
  8. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,145
    Likes Received:
    18
    Si per il momento,poi speriamo che la cosa sparisca.

    Babs
     
  9. do71

    do71 Registered

    Joined:
    Apr 1, 2013
    Messages:
    4
    Likes Received:
    0
    Salve, ho un problema con rf2, ho inserito le credenziali sia per l'on line che l'update ma, quando vado a premere il tasto query si collega ad un server, poi premo il download ma, dopo qualche secondo l'applicazione non risponde...è un problema che si può risolvere? o capitato già ad altri? Grazie per l'aiuto.
    View attachment 11301
     
  10. Tuttle

    Tuttle Technical Art Director - Env Lead Staff Member

    Joined:
    Feb 14, 2012
    Messages:
    2,480
    Likes Received:
    773
  11. do71

    do71 Registered

    Joined:
    Apr 1, 2013
    Messages:
    4
    Likes Received:
    0
    grazie
     

Share This Page