New cars in DEV Mod

Discussion in 'Car Modding' started by LoSte7, Aug 20, 2019.

  1. LoSte7

    LoSte7 Registered

    Joined:
    Dec 28, 2018
    Messages:
    22
    Likes Received:
    2
    Hi everybody,
    i have a big question for you all.
    i'm working on a mod of a Porche GTE, the last model, and i was happy when i saw that the same car is in the endurance pack, but i can not open the compressed mas file with the physics of the car.
    there is a solution for this? i'd like to extract it to compare with my model and upgrade it
    also because with the car compressed i can not put in the Dev Mod and test it

    thanks to everybody for the reply
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,547
    Likes Received:
    2,429
    The licensed cars are encrypted, likely at the request of the manufacturers.
     
  3. LoSte7

    LoSte7 Registered

    Joined:
    Dec 28, 2018
    Messages:
    22
    Likes Received:
    2
    understood Lazza, thanks.

    i'd like to see in to them...but if there is no way to do at the moment, it's ok

    thanks again
     
  4. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    446
    Likes Received:
    253
    You can get the latest encrypted cars into ModDev, but actually driving them does not work (maybe the physics are encrypted in a way that limits their use, or there is something that avoids ModDev to load the physics at all!?).
    To at least have them in Showroom, simply copy the mod folder from '.\Installed\Vehicles\' into '.\ModDev\Vehicles\'. Keep that original folder and move all MAS files from the sub-folders (those with the version as name) into it. Now the car should be loaded at least in Showroom, but as stated above, this is where the journey ends.
     
  5. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    913
    Likes Received:
    431
    @Marcel Offermans @Christopher Elliott I also would like to use the DLC cars in the devmode.
    I have seen that the senna gtr has the upgrades.ini included in the unencrypted mas file already, which is a good step to allow some modifications for leagues for example.
    Could you please put the gen files also into the unencrypted mas file?
    I suppose that, if we could set the proper search pathes and mas file links into the gen files, we could get the DLC Cars working in the devmode too.
    Or is there something else needed?
     
    memoNo1 likes this.
  6. JorgeAH

    JorgeAH Registered

    Joined:
    Jan 25, 2018
    Messages:
    47
    Likes Received:
    3
    hi, i have a doubt about new cars in devmod. I created one car (CAR1) from zero based on skipbarber files. I just create new 3d modesl and skin and then change them by the skybarber models and skin. BUT NOW, i wanna create another car (CAR2) from zero. Following the same steps that CAR1, (copy folders, change the name, introduce the new datas) its not appear at the devmod menu.
    The CAR1 and the skipbarber appear but the CAR2 is not, and i did the same and the route of folders at .gen and .veh are the same (with corrects name)

    Help me! its so strange from my point of view because im doing the same but i dont have the same result.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,547
    Likes Received:
    2,429
    @JorgeAH check the latest trace in the ModDev\UserData\Log folder, it might give you some clues as to what's gone wrong (there will generally be a lot of 'errors', but you can usually find something about your own mod pretty quickly).

    Sounds like something is wrong, obviously, as there shouldn't be any reason for another car to not work. Have you changed the name in the .veh?
     
  8. JorgeAH

    JorgeAH Registered

    Joined:
    Jan 25, 2018
    Messages:
    47
    Likes Received:
    3
    i will check these folder at user data. What are these "errors"?

    yes i changed the names in all files inside, outside, MAS and all posible.
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,547
    Likes Received:
    2,429
    Probably something about vehicle already exists.
     
  10. JorgeAH

    JorgeAH Registered

    Joined:
    Jan 25, 2018
    Messages:
    47
    Likes Received:
    3
    YES. I solved. its a file called "trace" in these folder and i discover where it was the problem with it.

    thanks u very much!
     
    Emery likes this.

Share This Page