latest build server started dropping people

Discussion in 'Hosting Help' started by peita, Feb 19, 2015.

  1. peita

    peita Registered

    Joined:
    Feb 19, 2015
    Messages:
    2
    Likes Received:
    0
    Hi guys,

    Me and my fellows over at the featured PrestoGP-league had troubles yesterday in one of our last pre-season test races. We are working on different theories but hope for any kind of external help.

    In short, the server started to reject/drop players after we had skipped sessions several times in a row. We usually do 3 practice starts by skipping through the sessions. After those starts, people started to lose server connection.

    We ran a test race with last build without these problems but with less people ~15 vs. ~25 yesterday.

    Some theories:
    1. Possible new build issue - we were doing fine until the several practice restarts. Logically that says it then less likely matter if 20 players worked at other servers. Maybe we have found a bug that not many will. Maybe a difference in how the application handles connections being made/shut during session switches. Like with memory leakage, the same can be with connections, triggering thresholds for buffer overrun/maximum connection capacity at different application levels (rf being one, windows, router, ...)
    2. Router issue - some explanations could be gotten about whenever a single TCP/UDP connection drops, maybe due to connection overflow as in 1)
    3. Ive got the not so well informed picture that rf2 is rather sensitive when it comes to correctly set up bandwiths. We got help last time as well as this from people with know-how I believe.
    4. Certain drivers' livery or something whole else causing this

    If anyone could help us find an answer, that would be very appreciated. Thanks.
     
  2. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    122
    Likes Received:
    22
    I was hosting the server at the time, I have the dedi launcher set to.....

    15000 upload - 14mb
    156000 download - 152mb

    the per client is at default 9999

    when we had 22 drivers on server before the session skips all was fine, the server reported...

    datarate 45% up, 1% down
    the cpu usage was 3-5% and ram was between 300-350mb

    as said above the problems only started after our last practise start, when i skipped back to restart weekend so we could move on with the qualifying session
    the server crapped out, people were dropped, clones were left which stayed even when the people had rejoined, it was all just a bit crazy afterwards with
    constant drops and rejoins, I tried restarting server several times during this with always the same results, but remembering everything was fine until the
    last session skip of the practise starts.

    Nothing in my instal has changed apart from updating all servers to build 930, before that the servers have ran for weeks without anyone mentioning a problem.

    Hope someone has some info on this, as stated above this shouldve been one of our last practise races before the new season starts.
     
  3. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    Same for us tonight (build 930)

    26drivers, massive lag in Practise, half the field disco'd upon session change, race was laggy as hell.
    server cpu and ram looked good.

    Same server as with build910, larger field, no issues.

    In 930 I have more fps (50/70) today as I reduced all settings, ping is 30, I had to abort race because I could not safely judge other cars.
    In 910 settings maxed out-ish + hdr, 30ping, 40fps, 28 drivers, no problem.
     
  4. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    As posted at build 930 thread:

    A couple of drivers suffered also intermitent lag during our league race tonight, there was few drivers at the server tonight (10) and we suspect it could be build related; their ping was constantly good (40 - 50 ms)

    byyyyyyyyyyye
     
  5. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    Have you tested without skin/team transfer available on the server ?
     
  6. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    It's a good question, and we could try to do the test, in fact I will try to, but most of people is more interested in racing than in "test racing", so it will have to be with a couple of humans and a bunch of AI
    Any findings on your side?

    byyyyyyyye
     
  7. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    I don't host, I just know that our league does not use these transfers since they have caused issues for several builds - maybe it has gottten worse now with virtual vehicles able to be used online (as I understand)
     
  8. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    Ok, it's a good point anyway (and a very suspicious one, if you ask me ;))

    byyyyyyyye
     
  9. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    Worth having a look at perhaps...

    BTW, your "byyyyyyyye" could be interpred as an "end of discussion" (troll thing) - which it prob. isn't ;)
     
  10. canastos

    canastos Registered

    Joined:
    Dec 23, 2011
    Messages:
    483
    Likes Received:
    2
    No, it pretends to be more like seeeeeee you; I hope I haven't been rude each time I posted something :p (maybe any english native could clarify, thanks)
     
  11. Valter Cardoso

    Valter Cardoso Registered

    Joined:
    Nov 4, 2011
    Messages:
    601
    Likes Received:
    1
    We have an endurance race this upcoming saturday. Around 42 registered drivers. Hope we dont have this issue....We will report if any.
    We have 3 rf2 champs running but last rounds are this week and we didnt update that 3 servers so everything still running fine.
    First 930 race will be on 28.02
     
  12. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    I kinda liked your goodbye's :)
     
  13. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    Hahaha. The first time I saw you post like that I thought your were being a smart a$$ too. But then realized it was just your sig. You've been ending your posts that way for years now. But I do see how some could miss read it.
     
  14. MystaMagoo

    MystaMagoo Registered

    Joined:
    Oct 5, 2010
    Messages:
    774
    Likes Received:
    2
    As English native as you can get here,I'm English in England and your byyyyye comes across as seeeee youuuuu.
    nothing wrong with it so get it back in ;)
     
  15. Dream

    Dream Registered

    Joined:
    May 14, 2014
    Messages:
    5
    Likes Received:
    0
    on our portal such method helped to decide this problem for all users who has problem with connection in 930 build:

    1) remove userdata in another place
    2) start rf2
    3) return in new userdata controls.json, multiplayer.json and setups for some tracks and series from old userdata.
     
    Last edited by a moderator: Feb 24, 2015
  16. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    361
    Likes Received:
    2
    I set up a rF2 server in England we just installed a new box there., I had asked a few to test it out....All went well and pings were good.

    I guess one night there were 3 of us from Canada on it...1/2 dozen from the US...and at times 12-13 that just popped in.

    WE never seen any lag..or stuttering...all our pings from North America to the server stayed consistent at around 76and great FPS.

    I think this is the best build yet...and I think they must of tweaked the net code also...not sure..just more stable for us.

    Dave

    NRT
     
  17. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    Well you might think so, but ISI have confirmed that stability issues have been introduced by 930.
     
  18. peita

    peita Registered

    Joined:
    Feb 19, 2015
    Messages:
    2
    Likes Received:
    0
  19. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    125
    It's actually been difficult to do that. There's servers running 40-50 people without issue in leagues like VEC.
     
  20. Freddy3792

    Freddy3792 Registered

    Joined:
    Feb 16, 2014
    Messages:
    275
    Likes Received:
    0
    VEC is using build 910 for the next race.
     

Share This Page