Invisible to other cars in multiplayer

Discussion in 'Bug Reports' started by Bartosz Bińczyk, Feb 21, 2021.

  1. Bartosz Bińczyk

    Bartosz Bińczyk Registered

    Joined:
    Jan 13, 2021
    Messages:
    5
    Likes Received:
    4
    Hello everyone,

    I have an issue that keeps reappearing every now and then over the past year since I fell in love with RF2. I enter a server as a driver, I can go around the track without any problems but other drivers cannot see me and I cant see them. The game still shows the drivers in the players' list but if I want to spectate them, the replay just shows their pit stalls which are empty. This is an issue that keeps reappearing across many versions and is very intermittent. Usually, this problem goes away after relaunching RF2 multiple times. I have this issue now and it doesn't go away at all. I noticed that if I launch RF2 in desktop mode, the issue is solved but, while using VR, I am invisible. As it seems that this bug is impacted by various factors, I am wondering what is the core underlying issue that's causing this problem? Is there a quick solution to this? I know it's not an internet connection issue since I'm using a wired 500Mbps connection. I had DNFs in endurance races because of this issue and would love to know if there is any reliable solution to combat this bug. Any help would be greatly appreciated!

    Cheers to fellow sim racers!
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,144
    Likes Received:
    4,223
    The 3 threads I've found so far suggest:
    • modem/router issues (rebooting the hardware may help)
    • IPv6 address instead of IPv4
    But being linked to screen vs VR... erm... o_O
     
    Bartosz Bińczyk likes this.
  3. Bartosz Bińczyk

    Bartosz Bińczyk Registered

    Joined:
    Jan 13, 2021
    Messages:
    5
    Likes Received:
    4
    Thanks for the suggestion. Disabling IPV6 worked for desktop gameplay (for some reason the problem appeared also while in desktop mode).
    For the future generations, here is what I did: Control Panel -> Network and Sharing Centre -> Connections: Ethernet -> Properties -> uncheck Internet Protocol Version 6 (TCP/IPV6)
    Unfortunately, the problem persists when I'm in VR :( I tried the following:
    - Reset my router to factory settings
    - Run windows update
    - Reinstall RF2
    - Restart computer
     
  4. Bartosz Bińczyk

    Bartosz Bińczyk Registered

    Joined:
    Jan 13, 2021
    Messages:
    5
    Likes Received:
    4
    After a lot of research, I managed to figure out the solution:
    My internet provider by default was assigning me an IPv6 address, and despite turning it off as described in the previous post, the problem still persisted. I had a hunch that it was something to do with IP addresses since most other posts also mentioned IP as the root cause of the problem. So long story short, here is what I did:
    - Called my internet provider and asked them to assign IPv4 address such that I can enable port forwarding on my router.
    - Logged in to my router by typing in web browser my IPv4 Default Gateway. (you can look it up by Control Panel -> Network and Sharing Centre -> Connections: Ethernet -> Details)
    - Depending on your router firmware you need to find the tab called Port Forwarding. For me, it was in Advanced settings -> Security -> Port forwarding.
    - Make a new rule indicating your IPv4 address, not default gateway (you can look it up by Control Panel -> Network and Sharing Centre -> Connections: Ethernet -> Details), and use the values provided by steam for the ports (both internal and external the same). At the time of writing this post these ports are 27000-27100. Also make sure to use UDP protocol and check "Enabled".
    - Click apply and just to be safe turn on and off your router
    My problem went away after that. Hopefully it will not appear every again!
    If my instructions aren't so clear, this video helped me a lot:
     
    SRGP and Lazza like this.

Share This Page