Intel i5 3570k performance?

Discussion in 'General Discussion' started by nurogize, Sep 20, 2018.

  1. nurogize

    nurogize Registered

    Joined:
    Jul 1, 2018
    Messages:
    54
    Likes Received:
    22
    I'd like to be able to play with 47 to 59 AI opponents. I've found out the hardway rFactor & Assetto Corsa are very reliant on single core performance. Even with 28 opponents in rFactor, there's an unbearable amount of stuttering with AI vehicles. Reducing visible cars to 20, doesn't seem to help on Nordschleife. Cpu occupancy was at 90 to 100%

    I'm hoping to get a used processor and mobo in the $150 to $200 bracket, and overclock it, since a ryzen with new mobo and ddr4 ram will cost over $450

    This video seems promising, as 24 car grid in AC on my Phenom II, displays CPU occupancy errors at top of monitor's screen, but still a bit more playable than rFactor 2.
     
    Last edited: Sep 21, 2018
  2. Will Mazeo

    Will Mazeo Registered

    Joined:
    Sep 12, 2015
    Messages:
    2,171
    Likes Received:
    1,542
    In rF2 you have to go to controller.json and set "use thread" to true.
    I can run 40 AI with a core i3 2100 so you should be fine, some bad optimized mods will cause issues and make the physics thread get to 100% tho, like the Audi TT mod for example even with just 20 cars on track, this will cause the game to run bad
     
  3. nurogize

    nurogize Registered

    Joined:
    Jul 1, 2018
    Messages:
    54
    Likes Received:
    22
    No difference on my end
    Code:
        "Type#":"Type of force feedback: 0=off 1=wheel 2=joystick 3=rumble\/gamepad 4=custom",
        "Use thread":true,
        "Use thread#":"Use a separate thread to issue FFB commands which may block with some drivers"
      },
    
     
  4. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,573
    Likes Received:
    1,886
    I have that CPU overclocked a bit to 4.2ghz (I think), Nords is a big track so will use more resources, lower Visible Vehicles to less than 20 as it'll only ever be on Race Starts that you see that many. For a track that size 8-12 should be alright. Lower other settings, in fact lower your expectations then you should find a nice balance.

    I run 29 AI on various tracks and in VR just fine, can't speak for 3rd party Nords though....I'll certainly see when the S397 version is released.
     
  5. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,307
    Likes Received:
    975
    What wizardry is that? What does it do?
     
  6. Narrowbackwing

    Narrowbackwing Registered

    Joined:
    Jan 12, 2012
    Messages:
    425
    Likes Received:
    155
    Marcel posted on Discord .
    ...
    I can explain what you are seeing and I might have a suggestion that will help a bit.

    1
    What you're most likely seeing is that (due to the number of cars on track) the physics calculations on your computer are happening too slow. The result is that the game seems to run in slow motion. First step is to validate that this is indeed the case. For that, while driving, hit Ctrl-C and a horizontal graph will appear. Keep an eye on the purple bar. If that goes to 100% your CPU is not keeping up with the physics.


    Now, the one thing that helps a bit (beyond not having too many cars on the track, or racing on heavily banked ovals) is open your UserData\player\Controller.json file in a text editor, look for a line called "Use Thread" and set the value to true, like this:

    "Use thread": true,

    ...then repeat the test with the purple bar (it should be a bit better). The only other solution I can recommend is to get a CPU with faster cores (it is the speed of a single core that is the limit for the physics engine).
     
  7. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,307
    Likes Received:
    975
    Thanks man. :)
     
    Narrowbackwing likes this.
  8. nurogize

    nurogize Registered

    Joined:
    Jul 1, 2018
    Messages:
    54
    Likes Received:
    22
    Finally got an Intel 4670k, and can say for a fact that the CPU occupancy went from 80-100%, to a constant 50%. It goes up to 100 when I accelerate time (ctrl x).

    I also went ahead and did a race with 31 opponents on the nordscleife as well. At the beginning, FPS was 45, but remained at constant 59 once field was spread out. Visible cars on track was set to 60 as well.

    In a practice session the Phenom 1055t would fluctuate between 25 and 50.

    Also note, I had to go to control panel in windows 7 → In search bar type, power options → change power saving settings → change it from power saver, to high performance. Failure to do this resulted in the 467k performing worse than the 1055t to the point that time was 'slowing down' while driving.

    I even re-assembled the AMD, to make sure this wasn't the culprit, but there wasn't anything worth nothing, except a constant 100% occupancy in the practice session with 24 visible cars.

    Everything is stock, but high performance settings in power saver, results in increased clocking speed of 3.7ghz, rather than 3.4

    The race weekend seemed to load quicker.

    At Sebring with 48 cars, FPS was 20-35 FPS, CPU occupancy was 50-60%. This was the 12-hour configuration, and around 8GB of RAM was utilized; 16GB is definitely needed. Around 400 MB of RAM reduction when using the non-12 hour layout. Draw distance is bad.
     
    Last edited: Oct 28, 2018
  9. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,563
    Likes Received:
    994
    Big mistake here.

    The number of visible cars is one of the main adjustment variables for having correct and above all stable FPS.

    I advise to put between 9 and 15 AI visible. More than enough.
     

Share This Page