[SOLVED] Input lag in rFactor 2 exclusively

Discussion in 'Technical & Support' started by Thrindil, Jun 21, 2017.

  1. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Hello everyone,

    I'm experiencing input lag, which makes the game basically unplayable.
    It only happens in rFactor 2, regardless on what settings I use. (Yes, tried turning off vSync aswell)
    I tried AC, R3E, PCars, Automobilista (highest update rate on ffb) and even Forza Horizon 3. No input lag there.

    So, I'm running a T500RS with a TH8A shifter, windows 10, rx480 8GB, 12GB RAM, I5 3570K@Stock and an SSD.

    I tried to uninstall, reinstall, tried the dx11 beta and dx9, also tried on lowest settings with 200+ fps, but nothing.

    I'm running out of ideas, so that's why I'm here.
    What can I do about it, and what could be the cause of it?

    Thanks in advance!
    Thrindil
     
  2. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Nobody?
    Ideas on how to find the cause, or somebody with similar experiences maybe?
    It's really annoying, as I'd like to enjoy my favorite sim, but I just can't as long as this problem isn't solved.
     
  3. Domino Duhan

    Domino Duhan Member Staff Member

    Joined:
    Sep 6, 2013
    Messages:
    92
    Likes Received:
    122
    Were looking at an improvement, should be deployed soon - let us know if that helps:)
     
    DJCruicky and Slamfunk3 like this.
  4. not_him_59

    not_him_59 Registered

    Joined:
    Jan 20, 2017
    Messages:
    60
    Likes Received:
    31
    I would probably describe it differently to you but I have a T500RS and the FFB is basically a mess. A massive dead area in the centre and steering weirdness at the edges that sometimes feels like the steerin increase at the road wheels is not linear. It is very hard to describe and it is different according to car and track. One certainty, I can't play rF2 and haven't been able to sinice the DX11 update. This is on a completely clean and new install of rF2. So @Thrindil you are not alone ;)
     
    Alex72 likes this.
  5. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Thanks Domino, glad to hear that :)

    Is that only in rFactor 2 for you, or are you experiencing this in other simulators aswell?
    Because I had a G27 a few years ago, and I can remember the smile on my face when I put my hands on my T500RS, because I could actually feel something in the middle, as opposed to the G27.
     
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,401
    Likes Received:
    3,095
    I'm not sure if you realise this, but the thread you're replying to isn't about FFB at all. So you're not just describing it differently, you're talking about something else entirely. I'd suggest starting a new thread if you're after assistance.
     
  7. danalm

    danalm Registered

    Joined:
    Aug 31, 2014
    Messages:
    34
    Likes Received:
    42
    A few things to try:
    - Make sure that you have steering help disabled.
    - If you're using a Nvidia GPU, make sure that you use a setting of max pre-rendered frames = 1
    - Reduce the anount of FFB filtering. I use 0.
     
  8. not_him_59

    not_him_59 Registered

    Joined:
    Jan 20, 2017
    Messages:
    60
    Likes Received:
    31
    Only rFactor2 is affected, I also run Assetto Corsa and Automobiilista and they are still as good as they ever were

    @danalm , have tried those and many other settings. The problem only arose since the updates to DX11 build.

    Apologies, wasn't my intention to hijack the thread. I'll keep off this thread now.
     
  9. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,298
    Likes Received:
    6,351
    Next update should have a fix for the input lag some are getting.
     
    DJCruicky likes this.
  10. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Great, is there an ETA yet?
     
  11. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Don't wanna sound impatient, but I haven't been able to play rFactor2 for more than 3 months now, so when will that update arrive?
     
  12. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,260
    Likes Received:
    952
  13. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,181
    Likes Received:
    1,292
    An update to reduce input lag arrived a few days ago as @Alex72 pointed out. By input lag, do you mean that the FFB feels laggy, or that the in-game wheel lags behind your own wheel? I had the second type of input lag early on in DX11, but it was fixed long ago.
     
    FORMULAEFAN71 likes this.
  14. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,451
    Likes Received:
    980
    What fps does your counter show whilst running in-car ?
     
  15. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Thanks, but I was talking about the dx9 version, I opted out of the dx11 beta because it killed my fps the first few weeks, and I didn't bother with it afterwards..
    I turn down settings to get 144fps minimum, because of my monitor refresh rate
     
  16. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,260
    Likes Received:
    952
    Ah gotcha. I seem to have better performance now though compared to how it was in DX9 before. I also had tons of lag/stutter at the start of DX11, but not anymore.
     
  17. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    I'll test again tomorrow, I hope the beta gives better performance than it did for me, and that the ridiculous input lag is gone :)
    I'll keep you guys updated.
     
    Alex72 likes this.
  18. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    The problem is NOT solved for me, I get exactly the same input lag as before, it feels like the screen is just 0.3 seconds behind, and I can't play. All assists turned off except for auto clutch, doesn't matter if I reinstall or not.

    It's quite a bummer, rFactor 2 is my absolute favorite simulator, but it's the only one I can't play at the moment..
     
  19. Thrindil

    Thrindil Registered

    Joined:
    Feb 7, 2014
    Messages:
    122
    Likes Received:
    5
    Oh...my... god
    I feel like an idiot..
    My steering rate was at 1%, that was what's wrong the whole time.
    Put it back to 100%, and steering and ffb were responsive as ever.

    Well, I hope it's helpful to someone in the future!
    Also, game was butter smooth, really felt the performance improvements!
    Case closed, yay!
     
  20. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,451
    Likes Received:
    980
    That steering rate option is a pain in the ass

    Caught me out once
     

Share This Page