HOW TO: Hosting with SteamCMD and Paid Content

Discussion in 'Hosting Help' started by Christopher Elliott, Aug 1, 2017.

  1. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    Yep, just the ones I mentioned. On the modem and router bit, your internet comes into modem, then Ethernet/wireless to router, then Ethernet/wireless to computer?
     
    RealGT likes this.
  2. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    Yup, cable into modem, then wired to a router. Router distributes via LAN to several PCs
     
  3. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    Ahh, now we’re getting somewhere, you will need log onto your modem and put it into “bridged” mode (Google how for your model). This basically puts it in pass through mode and the port forwarding on your router should then work.
     
  4. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    Hehe, my modem is already in bridged mode. It's a Netgear nighthawk modem and was provisioned by my buddy who works for my ISP in bridged mode. :)
     
    Alessio Feletto likes this.
  5. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    Well fark then :D I’m running out of ideas here, only thing I can think of is to double check the port forwarding on your router that it is pointing to the correct PC. Reboot router after changes maybe. When you changed the http port in the server’s multiplayer.json, the server wasn’t running when you made the changes was it?
     
    RealGT likes this.
  6. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    Finally connected to the server on another PC on my network. Then got the error "Failed to download/install packages. Please try returning to the main menu, or restart the game" LOL SMH
     
  7. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    OK so I can easily see the server now on my other PC. But still getting this error.
    "Failed to download/install packages. Please try returning to the main menu, or restart the game"

    I have the same content on both PCs, I literally copied and pasted from the "installed" directory from steam on the laptop to the "installed" directory on the dedicated server PC. All the content is identical. Man what the hell. I need to be able to join these servers so I can move onto the next phase of this project.
     
  8. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    Got a screen of your server’s mod manager showing the content?
     
    RealGT likes this.
  9. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    Here it is, thanks
     

    Attached Files:

  10. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    That looks all good, try re-creating the race event (vmod) with the server’s mas2 tool...make sure when you open the mas tool that the packages folder is set (filing cabinet icon)
     
    Ozzie and RealGT like this.
  11. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    Where should that be pointing? Want to make sure. It's really difficult with RF2, so want to make sure we're on the same page.
     
  12. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    90C01051-97B3-467B-BECF-19EEA77591C2.jpeg
    The server’s packages folder C:\Racing\rfactor 2-dedicated\Packages
     
    RealGT likes this.
  13. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    FYI, when I go into packages in the folder there is nothing in there except "skins". Shouldn't there be stuff in there?
     
  14. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    You won’t see other stuff in mas tool...you got teamspeak and teamviewer, reckon we can sort this out in about 5-10 minutes.
     
    RealGT likes this.
  15. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    Yeah have team viewer. What I mean is that when I go into the share for the dedicated server, not through the mas tool, but file explorer there is nothing in that folder. Weird. Probably a stupid mistake. Let me get teamview installed real quick and I"ll Pm you the key. Thanks
     
  16. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
  17. RealGT

    RealGT Registered

    Joined:
    Oct 22, 2020
    Messages:
    99
    Likes Received:
    14
    I want to give a HUGE shout out and thank you to redapg and Goanna for their help in cracking this nut. I've connected to a server both on the client PC and remotely via my laptop. It seems that every time you kick off your Steam client on one or the other the MAS2 manager resets your default directory back to your Steam client instead of your dedicated server. So I will check every time I start a session to make sure the MAS2 is pointing to C:\racing\rfactor2dedicated\packages

    I can't tell you how awesome this community has been and especially my new mates! :)

    I just need to find a detailed instruction on camera control while in spectate mode. Is there a link to such a document? I need to be able to adjust camera height, and forward and aft and then lock it there. I can't seem to find the keyboard controls for RFactor lol.

    Thank you everyone! Woot!
     
    Ozzie, redapg and Goanna like this.
  18. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,089
    Likes Received:
    440
    Should that be done (multiplayer.json) on both machines (server&client)? The portforwarding is needed for the server and the client?
     
  19. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,405
    Likes Received:
    953
    Hi Juergen, just on the server and port forwarding should be to the IP of the computer that the server is running on
     
    Juergen-BY likes this.
  20. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,089
    Likes Received:
    440
    Dunno what to do, i opened all ports, server is up and running, but i cant see the server in the multiplayer client.
     
    RealGT likes this.

Share This Page